RS+ failing to connect over LoRa

Hey guys,

I’ve got an RS+ that I connect to an RS2 over LoRa. It has been connecting relatively reliably until recently for no apparent reason, it wont move to the “Receiving Corrections” state when confirming in corrections input. I have obviously tried switching corrections input off and back on, confirmed aerials are connected properly, however only very occasionally can i get it to connect to the base and receive corrections.

Any thoughts?

1 Like

Hi Brenton,

Can you share with us the screenshots of your Base output and Correction Input settings? Just so that we could double-check everything.

I had a similar problem. I resolved it by turning the output off then back to LoRa. Eventually, the folks at Emlid fixed the problem with a firmware update. If your firmware is up to date, you might need to reflash one or both of the receivers (but I’ll let someone from Emlid confirm).


Hi Jared,

Yes for a while there that’s what I was doing too. I would turn off Lora and turn back on then all would be fine. It’s just frustrating that it’s so sporadic. Sometimes it will connect just fine, other times I will try for half an hour to get it to connect, trying different frequencies as well but still no good. Firmware is up to date.

Anyway will see if Emlid have any suggestions. I wonder if they’ll give me a good trade on my RS+ for an RS2+ :thinking::yum:

Hi Brenton,

Your setup sounds good, so let’s see what’s going on. In the screenshots, both your base and rover don’t have a solution. Are they placed indoors?

The base needs to receive signals from the satellites to send the corrections. Please provide both receivers with a clear sky view and ensure you have the correct geographic coordinates of the base in the Base settings tab. This should help.

Hi Julia. Thanks for your response. Both receivers were outside with clear sky view. I tested again today and still having the same problem. Tried resetting the Reciever to original setting and starting from scratch, still had the same problem. Then eventually after 40 minutes of trying, it connected.

Hi Brenton,

I reached out to you via PM as further troubleshooting requires some sensitive info from you. Please check it.

Hi there,

Just wanted to post an update that the issue was resolved after the updating of the units to the latest firmware version. It was most likely something to do with configuration.

If you face something similar, please make sure your receivers are up-to-date. You can also follow the steps from this post. And don’t hesitate to start a new thread or contact us at We will be happy to help.

1 Like

Hi Julia. I have only done a few setups but yes since doing the firmware update so far everything seems to be working fine. Thank you for your help

1 Like

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.