RPi4 "board requires new software"

I have a RPi4 Model B 4gb on update 161972685 and I was imaging it when I kept getting the “start4x.elf not compatible” and underneath that it says
“this board requires newer software”

It says the firmware is the in the following (last 6 digits) “de37c43” from sep 2 2020

has anyone encountered this issue and is there a workaround?

Hi @hzainedin,

Welcome to our forum!

Have you re-flashed your SD card with the latest available Raspberry Pi OS image for Navio2? If so, can you share the screenshot of the message you get? I’m not sure I’ve faced something similar.

A post was split to a new topic: ‘This board requires newer software’ message