'This board requires newer software' message

Hello @liudmila.slepova,

I am having the same issue as Haz. I have downloaded the image from this page https://docs.emlid.com/navio2/configuring-raspberry-pi

The 2 pictures shown, are the boot screen I get, and the navio2 itself.


1 Like

Hi Matt,

Did you get this message from the very beginning of working with Navio2? It seems that the image wasn’t installed correctly. Can you please reflash your SD card once again?

Yes this is the only thing I have seen so far when trying to use the system. I have tried multiple times to reflash the SD, and got the same result. My project partner used the same SD card and same image with a Raspberry Pi 2 and it appears to be working.

Hi Matt,

Alright, I see. I’ll check this myself with Raspberry Pi 4 and will write you back.

I have the same issue, I actually don’t understand how this board is being advertised to support RP4 when it clearly doesn’t.

After replacing start4x.elf with a newer one I am able to get past that point however it fails to boot further down the line, raspberrypi 5.10.92-v71+ runs/boots on the board however there is no RCIO usage.

linux-rt-rpi only has a linux kernels up to 4.4, nowhere near 5.10.92 required to boot. Perhaps you could release a patch for the kernel source?

EDIT: I can also confirm that I tried booting the image using “gitbls/sdm” and doing apt update && apt upgrade and it still doesn’t work.

1 Like

Hi Maxim,

Navio2 supports Raspberry Pi 4 Model B. I work with one in the office. But, currently, it seems that the bootloader packages of Raspberry Pi OS were changed, and now there can appear some challenges with the correct booting.

Our devs are checking how we can help here. Once there is any news, I’ll post an update in this thread.

2 Likes

Hello Liudmila,

It definitely doesn’t work on my Raspberry Pi 4 Model B which means it works on some Raspberry Pi 4 Model B’s not all.

The only way around it seems to be a kernel update, and that is likely to take some time.

Thanks, Maxim.

Hi Liudmila,

Did you have any update about this problem? Because I have the same issue with a RaspPi 4B 1GB.

Thanks.

1 Like

Hi Luis,

The devs are still working on what to do best here. It takes some time because everything should be thoroughly tested before we can provide a fresh update for you. Currently, I can suggest working with older models of RPi like RPi 3, if you have any. It should be working fine.

I’ll be in touch once I have a solution to share with you. Thanks!

1 Like

Hi,

I have the same problem with raspberry 4, is there any new about this?

Thanks.

Hi Cristian,

We’re at the testing stage currently. Hope to have some news soon!

Hi everyone,

I’m back with some news for you! We’ve just released the update that should help to make your RPi 4 boot correctly now. Please reflash your SD card with the image from the following guide.

I’d be glad to hear how it works for you.