RPi4 8Gb USB ports don't work after the reflash

i tried these steps with rpi4-4gb and still none of the usb ports work on rpi4-8gb. it does boot up tho!

thats odd. my usb ports do work.

2 gig

i prepared sd card using rpi-4gb and then replaced the sd card into rpi4-8gb, maybe thats why. i ll see if i can get rpi4-2gb version and try again.

@j98221 hi j98221

would you be kind to create zip of your boot folder for rpi4-8gb latest image and share it with me @ asadali4651@gmail.com if possible. for some wierd reason my rpi4-8gb usb ports does not work at all. please do not include the /boot/wpa_supplicant file since its does contain you network info. thanks

Hi Asad,

May I ask you if you tried working with your Raspberry Pi 4 with another image, just to test it? Have you come across this USB ports issue while generally working with your board?

Yes I have used the original raspbian image (https://www.raspberrypi.org/downloads/ )and everything works fine with that. USB ports only stop working when I use emlid provided image (https://docs.emlid.com/navio2/common/ardupilot/configuring-raspberry-pi/ )on rpi4-8gb. FYI this image does work fine on rpi4-4gb which I tested already and used for work around as suggested. In addition, I also tried copying boot folder files from regular raspbian image prepared SD card and USB ports on rpi4-8gb started to work but then WiFi stopped working. Due to frustration and weeks of time wasted, I decided to ask @j98221 for help since he seems to have no problem like this on rpi4-8gb as I understand.

correct. just embarrassed to say i need to figure out how to copy it. regarding the usb ports, i have a little keyboard with a trackpad with a usb (wireless)adapter from adafruit. i always use it when i setup a new pi, thus i connect a pi to hdmi monitor and insert the usb adapter then go through the setup.

Usually if you insert already flashed sd card into you PC , boot folder will show up with all the files. Then you can basically create a new folder on desktop and copy the files over and zip it using 7zip(free software). If it is too much work, don’t worry about it. i appreciate that you took the time to even consider. Thanks :slightly_smiling_face:

Hi Asad,

We’re currently working on resolving this issue. I’ll get back to you once there’s an update.

were you guys @liudmila.slepova actually able to produce this bug ?

i have the zip file, where do i send it to? it looks like i cannot upload. Error file is too big. its 23,563 kb

Hi Asad,

Let me clear this up.

At the moment, we’re working on the new image and trying to figure out what causes this issue.

do you mind posting the output of this ? cat /proc/device-tree/model

Totally understand Asad’s feeling. After frustration for months I decided to newly buy an old version of raspberry pi (sort of irony) and follow the suggested workaround. I came across exactly the same problem: the image provided by Emlid works totally fine on a rpi 4 b 2gb version and can be updated and upgraded. After inserting the SD card with updated image to rpi 4 b 8gb version, all the usb ports stop working.

i suspect that you @j98221 might just be using the rpi4-2gb or rpi4-4gb version which i tried also and everything works fine but not rpi4-8gb. rpi4-8gb definitely still have usb ports issue with emlid provided image. The only work around (not fully tested yet! but working on it) for rpi4-8gb i have so far is to flash sd-card with raspbian image and then somehow use custom ArduPilot binary (https://docs.emlid.com/navio2/common/ardupilot/installation-and-running/) to build ardupilot since everything works fine on raspbian image for rpi4-8gb.

i really have the navio board and ardupilot working on the rpi4 - 8gig. you may want to check your power adapter. sometime ago the motor was jerking forward when i used the steering on the remote rc radio. i changed the power adapter and everything went to normal.

Hey guys,

Thank you for your patience!

The new image for Navio2 with RPi 4 8GB support is out. It’d be great if you checked it out to see if everything works as expected for you. You can get the new image from this docs section.

For more details on the fixes and upgrades, please refer to this community forum thread.