RPi crashes on intitial apt-get dist-upgrade

Hello, I’m trying to set up a new raspberry pi 2/navio 2 using the instructions in the docs. Everything goes fine until I try to run sudo apt-get dist-upgrade, at which point it works for a while, and then crashes (at the point where it tries upgrading the perl packages). Has anyone run into this, or does anyone know why it might be happening?

I’ve also tried just ‘upgrade’ instead of ‘dist-upgrade’ but the same thing happens. I’ve gone through these steps before with other SD cards, a month or so ago, so I’m not sure why it’s breaking now.

Thanks for reading!

I guess that’s the purpose! Is there a chance you can try running the same commands on other SD card?

i also have problem setting up my rpi2/navio2… in mycase, when i apply the command sudo apt-get update && sudo apt-get upgrade , the ugrade starts but it takes a lot of time to complete… whem it completes, i reboot and raspbian is not able to boot again…

you can see my thread here… i am stll waiting for an answer though. Rpi2/navio2 does not boot after image install

Looks like you’re right! I tried it with another SD card and everything seems to be fine, although I feel silly for not thinking of that before pestering you guys. Thanks for the help!

I’m glad it’d helped!