Rpi2/navio2 does not boot after image install


i bought a new navio2 finally, but i have a problem. i started setting up RPI2/navio2 according to the docs. I am powering RPI2/Navio2 through the Rpi2 microUsb using a 5V/2A charger. And the Rpi2/Navio2 is connected to the router of my house. These are the steps I followed:

  1. I successfully installed the Raspbian image to the SD card.
  2. I connect to RPI2/Navio2 through ethernet using PuTTy. I connect successfully and then I run the upgrade command sudo apt-get update && sudo apt-get dist-upgrade. It also successfully finishes the upgrade process.
  3. Then I continued by installing APM successfully using command sudo apt-get update && sudo apt-get install apm-navio2
  4. Then I run the command sudo ArduCopter-quad -C /dev/ttyAMA0 because I have a pair of 3DR Radios. After this command I get the message
    Raspberry Pi 2 with BCM2709
    [RCInput_Navio2]: failed to open channels

So I searched and found a post Error using APM: [RC_Input_Navio2]: failed to open channels related to this problem where it says that the problem is that no reboot has been performed.
So, I unplugged Rpi2 from the charger and plug it again. And then I could not find again RPI2/Navio2 in my network so that i could connect again to it using PuTTy. I supposed that maybe the SD card’s raspbian image was corrupted so I started again the procedure following the steps as I described. I performed steps 1 and 2 and then while connected i gave the command through PuTTy sudo reboot. After this, the connection with PuTTY is broken, Rpi2/Navio2 reboots and then I cannot find again Rpi2/Navio2 in my network to connect to it again.

I tried rebooting the router as well but nothing happened.

So what is the problem here? what am i doing wrong ?? Why I am not able to see again RPi2/Navio2 in my network?? Does it mean that Rpi2 does not boot ??
I would really appreciate if someone could help…

Best Regards,

Hello and welcome :helicopter:

It seems that you’re doing exactly the same steps that are needed. Is there a chance you have some kind of a USB to serial converter like FT232RL or CP2102? If you have one, please edit /boot/cmdline.txt to contain console=ttyAMA0,115200 , reboot with a converter attached to UART port on Navio 2 and post the output of Linux booting process somewhere. This will be extremely helpful.

If this doesn’t give us a clue, I’d like to get the output of cat /sys/kernel/rcio/adc/ch0 on a fresh image.

Dear George,

thanks for your support. I will try your proposal tonight. I just need to clear a couple of things.

  1. I have a USB serial converted (see attached image) that I use for connecting my Tarot gimbal with my pc. It is an FTDI but i dont know of what type. DOes it have to be only of type FT232RL /CP2102 or any FTDI will do ?
  2. THe USB of the FTDI converted should be connected to USB port of Raspberry, right ??
  3. When should I run the command cat /sys/kernel/rcio/adc/ch0 in order to send you the output of it ?? AFter step 1 or after step 2 of my initial post ??

Thanks and Regards,

Dear George,

as i mentioned i found out the FTDI converter that i had but it realized that it is not compatible because the FTDI converter I have has a 4 pint cable/connector (as you see in the previous attached image) while the UART port of Navio2 has a 6 pin connector. SO i couldn’t try what you mentioned…

However, I did try the second option. So I installed from the beginning the raspbian image on the SD card. After the install I connected to RPI2/Navio2 through ethernet using Putty and i ran the command cat /sys/kernel/rcio/adc/ch0
THe command returned the number 5124.
Then I continue by running the upgrade command sudo apt-get update && sudo apt-get dist-upgrade. After the successful upgrade without doing any kind of reboot I ran again the command cat /sys/kernel/rcio/adc/ch0
This time the command returned the number 5118.
Then I gave the command sudo shutdown to power RPI2/Navio2 off. Again when i powered it on again i couldnt find it on my network. SO i decided to power it off again and connect it through hdmi with a monitor without any keyboard or mouse, just to see the boot proccess. In the attached image i took with my phone you can see where it stops. I dont know how to find the whole boot process as a log… is it stored somewhere ??

Does the above information help ?? Could you please advise me what i should do next ??

Thanks and Regards,

anyone please???

I again tried to install a fresh raspbian image on the SD card… If i dont proceed with the upgrade process using command sudo apt-get update && sudo apt-get dist-upgrade I am able to reboot RPI2/Navio2 normally again and again without problems…

Can I proceed to installing APM without upgrading ??? Will I have any problems later ? I ask because in the docs it says “Once you logged in, we suggest upgrading the OS immediately and reboot. This is a required step before attempting to fly your drone”. Could you please advise me ??

Thanks and Regards,


Sorry for the delay. This is extremely strange and have never seen anything like this before. I’m going to try to reproduce the issue tomorrow.

The upgrade is necessary as it has some important rcio-dkms updates.

Right after you install our Raspbian image.This is going to tell us the voltage on the board. If this is lower than 4.5 I suspect you need to just use another cable.


You might be okay just updating the specified package by sudo apt-get install --only-upgrade rcio-dkms.

dear george,

ok i now understand that the upgrade is important…
as i mentioned in my previous posts i tried to run the command cat /sys/kernel/rcio/adc/ch0 after fresh install and the voltage i get is normal.

so there must be something else. it is really strange that for such simple steps where we just execute the raspbian image writing and the upgrade command, no other people have problems even if we are doing the same thing…

i will wait for your response

thanks and regards

Have you tried using another SD card?

It seems like some of our users have [resolved[(RPi crashes on intitial apt-get dist-upgrade) their issues by replacing SD card.

Dear George,

i can try…I can try the following

1)try using another sd card
2) try using the RT_kernel image… Is it compatible to work with RPI2/Navio2 ??

Please, try this one first.

I tried installing image on another sd card… now everything works, and raspberry normally boots even after doing the dist-upgrade… so it was a sd card issue…

thank you

I feel kinda awkward it took me so long to come up with a fix. But either way I’m happy you got it figured out.