Rover Status Fix but signal bars fluctuating and not correct coordinates


My both reach device - Base and Rover working fine.

Even I got Status - Fix

But the problems are:

  1. My signals bar keeps on fluctuating
  2. My rover coordinates are almost 5-10m accuracy even after “Fix” Status

This is my Base Settings.

This is my Rover Settings:

This is Status Page:


You set parameter “integer ambiguity validation threshold” to “1”, which means that almost any solution would be considered a fixed one. This is why you are seeing bad precision. Your sat signals do not look good. Are you testing outside or indoors?

Both devices are outside.

How much “integer ambiguity validation threshold” should be?

By default it is “3”. If you changed any advanced settings you might consider resetting to defaults.

Please provide a picture of your setup. Did you mount it in open area with groundplane under antenna?

Yes I put everything on default.

  1. GLONASS integer ambiguity resolution mode - ON
  2. Integer ambiguity validation threshold - 3
  3. Minimum lock count to fix integer ambiguity - 0

I have mounted on the roof top of my car.

Now the signals still fluctuating and status is “Float” and not “Fix”

You also need to set configs to 5Hz GPS/Glonass to use Glonass and enable dynamic filter to improve performance. Switching from float to fix take a few minutes in good conditions. I can see buildings around, please make sure that sky view is not obstructed.

Is this settings okay?



And yes there is nothing on the top, its an open parking area. The silver dot is where my car is parked.

You need to add Glonass to “used positioning systems” as well.

I can see that you are from Japan. You can try using Beidou+GPS instead of Glonass+GPS.

What will be the “Used Positioning Systems” if I used Beidou+GPS? And shall I used at 5Hz frequency?

Use positioning systems “GPS, Beidou” Config file GPS+Beidou 5Hz.

But there is no “BDS” in Used Positioning Systems.

Only these are available:

It is “comp” here. Compass and Beidou are synonyms. Please also enable sbas and QZS here.

Ok I did this Settings:

Its coming “Float” Status now.

I will wait for 5-10 mins if its getting “Fix” Status or not and then I will update here.

This is the output currently.

Hi @igor.vereninov

Almost half an hour and still “Float” Status.

You can see that there are no grey bars for Beidou and QZSS. Your base should be configured for Beidou as well + enable all RTCM messages.


Hello @igor.vereninov

I enabled all RTCM messages in Base Settings.

I am attaching my Base and Rover Settings and also signal status which is currently “Float”

Base Settings:

Rover Settings:

Signals Status

your settings seem to match what @igor.vereninov recommended and the rest look good to me. some possible problems:

  • GPS satellites: not enough with SNR > 45dB (currently 4; where 5 or 6 is best)
  • the satellite geometry may not be ideal at the moment, and some time later it may be better for a fix
  • base and rover too close together? try increasing the distance between them to 10 or 20m or at least not on the same car roof
  • multipath reflections from the nearby building confusing Reach. Maybe move your setup away from the side and over toward the corner of the building where there are far less reflections
  • check your base coordinates are as accurate as possible


I really have no idea whats going on.

Its always float and never gets fix. I tried all the methods given by you guys but still no success.

Maybe you could upload a set of log files and I or someone else could post-process it and see if we can get a fix out of it.