Emlid

Community Forum

Red LED and Hot IC's on Navio2


(Bill Berzinskas) #1

Greetings,
I was referred here by EMLID support in response to an email. I’ve had my Navio2 for less then a week, I was able to connect to it from missions planner, calibrate compas, gps, etc. All was well.

I returned later unable to power the navio with the power module and I was able to connect to the telemetry network only intermittently but the RGB LED is RED. Some of the components on the board are getting quite warm as well. Mainly IC9 and 11. Most sensors in mission planner are giving various warnings and wierd readings (spinning compass, -5000ft altitude, etc).

I approached my reseller, but was turned to support and then here. Help?


(Igor Vereninov) #2

Hi Bill,

Please provide a picture o your setup and try to run examples to tests the sensors.


(Bill Berzinskas) #3

Had a chance to dig into this today. I ran most of the python examples that were relevant at this point. RC / Servo aren’t hooked up yet. I literally have only power and GPS plugged in. Here are the results:

pi@navio:~/Navio2/Python $ sudo python AccelGyroMag.py -i mpu
Selected: MPU9250
Connection established: False




pi@navio:~/Navio2/Python $ sudo python ADC.py
A0: 0.0000V A1: 0.0000V A2: 0.0000V A3: 0.0000V A4: 0.0000V A5: 0.0000V

pi@navio:~/Navio2/Python $ sudo python ./Barometer.py
Traceback (most recent call last):
  File "./Barometer.py", line 19, in <module>
    baro.initialize()
  File "/home/pi/Navio2/Python/navio/ms5611.py", line 81, in initialize
    C1 = self.bus.read_i2c_block_data(self.address, self.__MS5611_RA_C1) #Pressure Sensitivity
IOError: [Errno 5] Input/output error


pi@navio:~/Navio2/Python $ sudo python ./GPS.py
** hangs, no response ** 


pi@navio:~/Navio2/Python $ sudo python ./LED.py
LED is yellow
LED is green
LED is cyan
LED is blue
LED is magenta
LED is red
LED is yellow

** NO LIGHT **

(George Staroselskiy) #4

It seems like you Navio 2 is not properly screwed down. Might it be the case? Could you please post a picture?


(Bill Berzinskas) #5

it is in fact screwed down. I’ll snap a picture tonite. The hot components are pretty concerning. In the meantime, I’ve purchased another and its working flawlessly.


(Bill Berzinskas) #6

Also, I think its kind of odd that my reseller essentially sent me to a forum to get someone to agree that my board is not functioning before I can return / exchange it.


(George Staroselskiy) #7

Could you also post the output of cat /proc/device-tree/hat/vendor?

Unfortunately, it looks like a hardware issue. You’ll be contacted regarding replacing your board soon.


(Bill Berzinskas) #8

Will do that when i get home this evening. I received an email from one of your people today about replacement… thanks very much for taking care of this!


(George Staroselskiy) #9

I consider this issue solved, then!


(Pierre-Emmanuel Lépicier) #10

Hi there !

I’m new and building a quad with :
_D8R XP
_ESC 4 in 1
_Telemetry via UART
_RPI 3
_S500 frame

It seems that I have the same problem : the chip of my navio2 is very hot, the led lights up green during 10 sec and then remains off and the chips doesn’t want to connect anymore (it worked yesterday, no idea of what happened…). What can I do ?

Thanks !


(Andrew Yushkevich) #12

Hi @pelepicier,

It’s needed to understand which part of your build causes the issue.

Can you try to test your RPi separately?
Does this behavior persist in that case?

Also, you can test your setup with a different RPi if you have it.

Let me know about the result.


(Pierre-Emmanuel Lépicier) #13

Hi Andrew,

Thank you for your reply.
I just tested with an other RPi (unused one, bought this morning), and the RPi is working (detected on the network, I can access with Putty etc) but still the Navio Board has the chip very hot and it seems no to be working anymore. Here is a screen shot I did today :

Any idea ? It was working well before (detected by QGroundCOntrol and Mission Planner, found GPS signal), but not until 2 days ago…


(Pierre-Emmanuel Lépicier) #14

Also the installation of Emlid Raspbian is new (using Etcher), I have formated the SD card and reconfigured everything like before, so the problem doen’t come from the file system.


(Andrew Yushkevich) #15

Hi @pelepicier,

Can you share screenshot of emlidtool rcio check output?
Do you have an available update?


(Pierre-Emmanuel Lépicier) #16

Hi Andrew,

How can I do this ? Is it :
cat /sys/kernel/rcio/status/alive
?
I did all the updates (sudo apt-get update && sudo apt-get dist-upgrade)


(Pierre-Emmanuel Lépicier) #17


(Andrew Yushkevich) #18

@pelepicier, just type emlidtool rcio check command and press enter.
You should see if there any updates available.


(Pierre-Emmanuel Lépicier) #19


(Andrew Yushkevich) #20

Hi @pelepicier,

Can I ask you to share the output of the following commands?

  • lsmod|grep "rcio"
  • dmesg|grep "rcio"

You can share the output text as a file if it’s more convenient.


(Pierre-Emmanuel Lépicier) #21

Also please notice that I have checked connections between Navio and RPI (no false contact…)


Missing log / corrupt file