Receiving Corrections in SINGLE mode

Does it sound familiar to any RS+ users having corrections while the app is displaying SINGLE mode?

It happened today that I was on site for point collection however my RS+'s decided to play tricks on me.

I Installed my base over a known point and ran my rover. Once in the app, I noticed that my rover received corrections but my status said SINGLE. Is this a glitch in the latest stable firmware version (31.3)?

I would like to add that I have been collecting points on this site previously with the 31.2 stable firmware version without problems. I played with the frequencies with no luck.

I had to take my equipment home and run the base and rover again. This time it worked fine.

Anyway, I wanted to address and share this issue with the EMLID team, in case it is a common issue for some users. From what I see, I have to restart my equipment whenever this thing happens again, until newer firmware versions.

I am sharing screenshots.

1 Like

so you had manually put in the coordinates in base setting?

1 Like

At first, the base averaged its position by itself. Then, after taking some time to set my rover on the pole and bipod, I changed the averaged coordinates to the coordinates I had PPK the last time I was on site.

I will post the same screenshots, only this time will be the base ones.

What I will do from now on, after updating to future firmware versions, will be to run tests before taking my equipment to work.

Needless to say, I am very happy with my RS+'s when they work as intended :grimacing:

This sounds like in the first test the base had not yet populated it coordinates in average single depending on how long it was set for, so you will see the radios communicating but no actual base data coming through


The averaging in my base was set to 2 minutes if I remember correctly. I think I turned on my Rover at roughly 1 to 2 minutes after my base ran.

I commonly leave my rover static even after it gets FIX status for some time. 5 to 10 minutes depending on the situation, or until my AR validation ratio gets to 999.

On this occasion, my rover stayed static for around 15 minutes with this glitch.

Anyway, I will keep checking on this, and let you guys know.

Thank you for all your time


1 Like

Is this where you are at Sergio ? I was just looking at your coordinates, looks like a cool place to survey !

1 Like

Yes! this is the place. Lol.

We are blessed with some great spots for the RS+'s to shine, haha

1 Like

Hi Sergio,

I agree with David. And one more thing to check is the coordinates of the base. Just make sure that they are correct and that there are no accidental typos.

The coordinates in the Base mode tab should be geographic, and the height should be ellipsoidal. It’s important because an incorrect position there can prevent the rover from calculating a FIX.


Hola Julia,

I went back to the site to capture some points. No luck whatsoever.

I set up my base. Entered manual coordinates emphasizing the coordinates and elevation input like you said and never had float or fix. Only single status.

I resolved that I had to get the most out of it, so I decided to work around with PPK ‘stop and go’ which I did, although I noticed my raw data showed a date externally way different in the logs. Internally were okay tough.

Anyway, I have attached new pictures from today for you to have a look at.

While collecting point 17 in single mode, I noticed that my rover, at some point in time got information from the base:

After that, somewhere at point 18, it disappeared.

After collecting my points, I came back to my office to post-process the data collected. But before that, I ran my base and rover at the same time on a little patio. Noting that both units were connected to the local internet wifi this time. Nothing was changed, not even the base coordinate from the site.

Both units were working fine

--------------Base screenshots-------------------

------------Rover screenshots------------------

I am lost Julia, please help me :face_holding_back_tears:


I tried to set positioning mode to static, but, it doesn’t have an option for that in the new update. It says kinematic only. how were you able to set it to static?

Hi Sergio !

Could there be any radio towers or interference from microwave towers or such ? I know that radio transmissions can interfere with both the gnss signals as well as your Lora transmissions.

I have a passive control mark near my house and I have visited it often to use as a base. About 4 years ago, our county built a radio transmissions tower about 75 meters from the control mark for our sheriff’s department. It plays havoc with collecting static data and also using our states RTN receiving gnss signals.

I’m wondering if this may be the cause in your case ?


Agree with @EBE111057 as this will definitely throw things off “mysteriously”.

You may want go look around to see if there are any welding machines running. Welding shops? Welder in those buildings? They put out a huge amount of EMF / RFI.

If not, seems something is interfering with the LoRa radios and/or receivers.

Or you simply have the Known Base Coordinate set incorrectly, or maybe all of the above? Who knows!

Maybe set base elsewhere nearby just to test to get a FIX? Do a Base Shift?

1 Like

I didn´t do anything after updating from 31.2 to 31.3 some weeks ago Nanis :upside_down_face:

I just verified my GNSS settings configuration and it shows the option of kinematic or static.

Hi Bryan, not that I know of. I have been to that site before not having any issues. It all started when I moved to firmware 31.3.

There is a new police camera tower installed near the place. I just don´t think this can be the cause affecting the communication between my base and rover.

I think there is something wrong with my configurations perhaps.

The last time I updated my units to version 31.2, my Rinex log versions changed by themselves. As you expect, I had to redo my observations just for not double-checking for changes after updating the firmware.

1 Like

Hi Tim,

Thank you for your ideas, I will keep them in mind, from now on.

Those buildings you see are store warehouses and are empty. I don´t think there is anything electrical feeding the site.

Maybe I have a configuration problem. I am tempted to factory reset my units, do you think this might help?

I don´t think my base coordinates are wrong, however, I will try to make space during the day to test my units again.

It’s weird that when the units are connected to a WiFi signal they do pair, not being in stand-alone mode.

1 Like

This is a CSV From a survey I did in this location.

The fixed collected points on September 6th, my units had the 31.2 firmware installed.

Somewhere in between I updated the firmware to the newest version and that´s where I am at.

The SINGLE points collected on September The 27th were processed in Emlid Studio and were corrected successfully with stop and go.

I was under a mesquite tree when I collected the last point :sweat_smile:

Can PPK solve interference issues if encountering places with your descriptions?

Hmm, are there any obstacles between the receivers? What is the baseline you work with?

Let’s also try a few more things:

  • Switch the base and rover receivers and set them up.
  • Change the frequency you work with.
  • If you have an internet connection at your work site, let’s try to pass the corrections via Emlid Caster instead of LoRa.
1 Like

Hi Julia,

There aren´t many obstacles around, a few buildings here and there, but nothing major.

I surveyed that site before in Firmware 31.2 without issues. After upgrading to v 31.3 this inconvenience occurred. Baselines are short, around 80 meters on average.

I was thinking of reversing my units before, so it seems like a great idea to do so at this time. I will try the caster before I do that.

I will let you know my results.

Thank you to everyone who has been around my post. I really appreciate it. I have been learning so much in a short time. You guys are great!


Hi Sergio,

How is it going? Did you have a chance to carry out tests?