Reachview2 Ntrip Server Settings

Hi @Brent_W, I have try lefebure ntrip caster, I saw just a second in page connection, my ntrip server in reach appear, then disappear, then appear for a second, then disappear again. My base and notebook connect to phone wifi. In ntrip server setting, the address is notebook IP address. Would you help me to solve my problem? I use wifi just for test NTRIP.
@igor.vereninov @egor.fedorov @bide

Hello, I can’t provide you with technical assistance on Lefebure. I can, however, give you access to our caster and you can try out NTRIP and do more research on it. This is what we installed and are running on a server so that we have our caster available at all times.

For now, please copy my settings exactly, (we set up a mount point for you), and then private message me with screen shots of your settings and I’ll send you passwords. All you will then need to do is make sure both units have access to internet.

Base Settings - Base Mode

Rover Settings-Correction Input

Thank you for your response @Brent_W, I see on the address, maybe I have to use public IP on it.

Can you not enter it exactly like I did?

I just understand… Sure, i will try it soon. I still charge my powerbank.

Hello, Brent

I wonder if you could share the ntrip caster’s conf files, obviously leaving out the security info, like password.

1 Like

@Brent_W I’m also interested in an working example config. I tried the following settings for the ntripcaster.conf without success:

##################################
# NtripCaster configuration file #
################################################################################

location TEST
rp_email amdin@domain.ltd
server_url http://caster.domain.ltd

max_clients 10
max_clients_per_source 10
max_sources 4

encoder_password zaevooyu4eeS***

server_name caster.domain.ltd
port 2101

logdir /var/log/ntripcaster/
logfile ntripcaster.log

/REACH0:user:auWiChah5pho***

Do I have to set something in the sourcetable.dat file too?

Addition I forwarded the port 2101 through my router and check that my linux is listing on the port with:

# netstat -tlpn | grep 2101
tcp        0      0 0.0.0.0:2101            0.0.0.0:*               LISTEN

EDIT: Okay seems like that config works. The problem was that the port was not correct forwarded. You can check that opening your domain in the browser: http://caster.domain.ltd:2101/ It should show the following output:

SOURCETABLE 200 OK
Server: NTRIP NtripCaster 0.1.5/1.0
NO SOURCETABLE AVAILABLE

If I have access to a public NTRIP provider, can I setup a Base Station to receive corrections and output those corrections to my Rover?

Or is it best to use the NTRIP data to establish my Base Station position then setup my Base Station to output via LoRa?

Good questions. If you have access to a public NTRIP provider, then you can simply have your Rover get the corrections from the public NTRIP provider (and not even worry about using the Base). When you establish your Base station, that unit could either transmit the corrections via LoRa to your Rover or you can set it up to function as your own NTRIP server (by utilizing some free software from Internet), in the second case, your Rover would require Internet access to receive the corrections. I would recommend to establish your Base and have it transmit the corrections via LoRa to your Rover. In this case, you have full control over your configuration and you don’t need to have any Internet access (or accessing a NTRIP server). PS. I don’t have a Base unit and my understanding is that the Base unit generates the corrections (by giving it a known reference point). If you have the Base unit get the NTRIP from a public server and transmit it to the Rover (via LoRa), then the Base unit would function as a relay. I can see situations where this would be desirable (e.g., you don’t want to set up the Base unit and the Rover has no Internet access, and you are simply using the Base unit as a transmitter to send the NTRIP corrections via LoRa to Rover) and this could be added to the Base software (if it is not already there).

Just trying to get into this here. If I set up my own caster using pc software, is there a resource where it gets the data from the servers?

Alternatively, if I am just going to use the reach and connect it to a public source is there a good resource to find where local public NTRIP providers? In Alberta Canada here, can’t seem to get rtk2go working and haven’t found another source without setting up my own server which is over my head.

Thanks!

Since the base is stationary it is a “fixed” reference point. You can provide the coordinates for the fixed point manually or use Reach to establish them by RTK from a CORS station using NTRIP - which requires an internet connection.

Once Reach has established the base coordinates to use via either method above then it uses them to derive corrections between those coordinates and real time positions derived from incoming satellite data. It does not use NTRIP data to do that so no internet connection is required at the base after the base position is established – unless you use the internet to transmit the corrections to you rover.

I use the LORA radios to transmit the corrections from the base to the rover so I do not need internet access while I am surveying with the rover.

How to set Mount point? can you tell me

I would recommend rtk2go.com. See the following DIY portable hotspot & HOWTO send correction through free ntrip to LTE hotspot

1 Like

I found a link to a global list of ntrip servers here: https://igs.bkg.bund.de/root_ftp/NTRIP/streams/streamlist_world-wide.htm

and I am interested in for example line 2179 or 2448 to connect to them. When I add in the address and mountpoint and hit apply it just says connecting. Anyone have any ideas of what i am doing wrong. Does the address need http:// or are these password protected by chance? need a username?

I also tried line 655 but that one comes back with “Connect Error 111”

Thank you for the nice explanation.
I have a question though, if I set up base station as you described in a fix location and I will use a second unit as rover for survey, what is the accuracy in a range of 10miles or maximum 20miles from my base station?
I can connect through LORA or either through NTRIP and using internet in order to take corrections from my base.
Is there also limitations in distance if I am using NTRIP through internet ? I know LORA is around 10-15miles

Best regards

1 Like

Hello
I finally bought corrections from Topcon through topnet
But my reach is not getting any corrections (grey bars)
Even through youcors caster that were ok before
Maybe I need to reset the device?
Thanks

What is the spec for the correction your are reciving?
Do you have have a datasheet or link to description?

Hello

thanks for your fast reply
Here is the link http://www.topnetlive.com/
although i managed to make it work and receiving corrections from Youcors free mountpoints, when i conect to topnet succesfully insert my password and username, there are no grey bars(corrections)
any sugestion?
I noticed after i connected to topnetlive, that it shows a message Recv Error 114

Could you share settings used to connect? there is a system report button inside reach menu (under settings) you can publish here.