ReachView v2.21.2

Try as user emlid

Ok, found it.
The new combination is: reach/emlidreach

Not working:
root/emlidreach
emlid/reach
emlid/emlidreach

2 Likes

Can somebody from Emlid comment on the removal of root access?

Seems that now we only have user level access. Is this by design? Is this something specific to the dev edition or is this how the updates will come out from now?

Why isn’t this mentioned in the release notes? This is breaking functionality for us and possibly others.

Hi Arik,

Tatiana commented on this in another thread:

1 Like

Few additional bug reports for the dev version 2.21.1 .

“RTK settings” don’t persist. I set “Elevation mask angle”, “GNSS select”, etc. Power cycle the unit and the values are back to defaults.

The BEIDOU satelites are shown as B[x] in the bar area of the “Status” page. In previous version it was C[x] and it is also “C” in the documentation. Is this intentional change?

1 Like

3 posts were split to a new topic: How to update from 2.20.8 to 2.21.1?

Seems to be an issue with base sending Beidou and/or QZSS messages.
I tried with base(RS)-rover(RS+) config over ntrip and both RTK2GO and Youcors show the same issue. Data seems to choke up or not beeing transferd properly and at rover end the grey bars doesnt show up but base data i recived every now and then (10-20sec interval)
2.21.1 on both units

the same happens to me using the RS2 with ntrip , and via Lora I notice the age of differential very high, in RS + it keeps under the age of differential

I’ve been using a couple of original reach rtk units, upgraded to 2.18 and got caught out by the 2.18 3DR radio issue.

Tried upgrading to 2.21.1 to see if it was resolved but doesn’t appear to be. Can’t say if it exactly the same cause as setting UART serial output in Base Mode sometimes hangs (spinning busy circle doesn’t go away). After rebooting the serial output setting seems to have stuck but I cannot receive corrections at the rover.

I also encounter the zero AR and GNSS Select under RTK settings are lost after rebooting.

Good luck bug fixing.

Hi!

Sorry it’s taken so long to get back to you.

We’re trying to reproduce the issue but unfortunately to no avail. Does this issue happen every time you change these settings?

Sorry for not letting you know! This is an intentional change. We’ll update the docs.

2 Likes

I re-flashed the unit and don’t have this issue any more. So this is something related to an upgrade path from the stable version to the new version. Perhaps the format of the settings in the new version is not backward compatible.

Before re-flashing, in the upgraded version, it was happening every time. Try a QA flow where you start with a stable version, set RTK properties, then upgrade and try to work with it.

1 Like

Hi!

This is actually pretty long gone. Since the beginning of 2018. It’d be great if you could recall what version of RV were you using at the time? Either way, we’re sorry this led to some frustration. If this is needed for your work, we’ll bring it back.

It would be nice have it split in 2, one for horizontal, and one for vertical.

1 Like

Hello, guys!

v2.21.2 is out! This release has a lot of bug fixes. The post in the beginning of the thread has been updated to reflect the changes.

11 Likes

“Fix disability to switch from GLONASS to BeiDou in the original Reach, Reach RS and Reach M+/RS+”

It means now we can use GLONASS and BeiDou at same time for RS+ and M+ too?

Hi Veha,

Not really. There was a bug preventing from switching from GLO to BeiDou in ReachView. Now it is fixed.

Hi there!

Today I have updated my RS+ to 2.21.2.
Now I can not open the Survey-tab by using the app. I use a iPhone SE.
Opening in Safari works fine.

Best regards, Christoph

Just picked up v2.21.2 on an original Reach RTK. Zero AR and RTK settings persisting issues resolved.

Still can’t select serial output in base mode (spinning arrows don’t go away) -

image

2 Likes

Hi George.

Several problems with the dev version. 2.21.2 for Reach RS antennas.

•By turning them on in client mode, they keep looking for a new update. The status does not change and shows the message “Fetching metadata version”. I have to turn off and on several times to get the message “You are updated”. Reachview app responds very slowly.

•The problem of unstable input corrections has returned.
Gray bars appear and disappear suddenly.
It is very difficult to achieve the “fix” over very short distances.

•When you are in reachview (no matter client mode or hotspot mode) you change to another app and return to it the message “No connection” appears.
In previous versions you could go from reachview to another app and return without problem the connection was restored immediately.
The problem is the same with the app and with the google browser.

4 Likes

Hi!

Good to hear! Thanks for the confirmation.

Sorry about that. We’ll try to reproduce it and we’ll get back with a fix as soon as possible.