Emlid

Community Forum

ReachView beta v2.2.5


(Egor Fedorov) #1

Hello everyone!

You probably know already, but we’ve had a lot going on in the past couple of months. After a rather long break we are back to delivering improvements to our new beta. Now that Reach has got itself a big brother, the app will provide support for the new hardware as well as deliver new features and bug fixes. Let’s dive in for a more detailed look!

Update notes

  • Reach RS users must drop their settings to default immediately after the update.
  • This is a huge update. I mean literally. It is strongly advised to run it on a broadband network connection.
  • This is our first case of a kernel OTA update. We’re a little bit nervous, but mostly proud. Power fails during the update process are highly unwanted.

Reach RS support

In the last month we’ve been hard at work to make the app run on both devices with the same codebase. This means new features will delivered to both devices simultaneously.

This iteration brings support for Reach RS and its new features:

  • LoRa radio is available to be used for both correction input and base mode output. RTCM3 messages selector will automatically adjust radio air rate depending on the required data bandwidth.

  • Battery and power management. Notice the battery indicator on the screenshot. Reach RS battery charge level is displayed with the icon in the top right corner. Clicking it will also bring out extended system power information.

Bug fixes and improvements

  • RCH-473. Fixed wrong log split time.
  • RCH-490. Caching issues. While this is not a complete fix yet, this seriously improves the overall experience. After this update clean your cache just one more time, please.
  • RCH-485. App prevented from crashing due to empty configuration files.
  • RCH-471. Increased timestamp precision in the solution output.
  • RCH-403. Solution log format mixup resolved.
  • RCH-419. Base coordinate reaveraging button is fixed.

Feel free to leave your reviews and suggestions in this thread.
For those wondering, the RTCM3 fix is coming shortly. Stay tuned!

Best regards,
Emlid team

UPDATE

We’ve just pushed v2.2.1 which hopefully fixes any logging-related problems introduced with v2.2.0.

  • The logs will not act insane when opening the logs tab
  • Solution will not get lost
  • The solution log will not restart for no apparent reason
  • Solution format selector works as it is supposed to
  • Merged RTCM3 fix by RtklibExplorer

Big thanks to @Brent_W for the prompt report of the logging issue.

UPDATE (10.02.2017)

We’ve pushed another update, v2.2.2:

  • Fixed RTKLIB memory leak, which we unknowingly had for quite some time. This fix should resolve most issues with app being unresponsive after a long period of work.
  • LoRa driver has got a heavy update and using the ReachRS built-in radio should feel way more stable.
  • ReachView on ReachRS will warn you about trying to use LoRa twice
  • Logs got a slight looks update and the whole tab will behave in a more stable fashion
  • Fixed small frontend issues, like the LLH/XYZ selector placed poorly

The RTKLIB memory leak issue also affected our flavor of RTKPOST. GUI apps have been rebuilt and reuploaded. The links are, as always, in our post-processing docs.

UPDATE (13.02.2017)

Some users reported Reach crashing after a short period of work time. Although this seems to be an issue that was introduced with the v2.2.0 support update, the symptoms have surfaced just recently.
Anyway, the updated version, v2.2.3, which hopefully fixes this is out! Please report if you experience similar issues after this update.

UPDATE(15.02.2017)

The new, v2.2.4 update has arrived! This one brings out a new feature, which will be invisible for the moment: update notifications. When the next update comes, you will get a notification on the status screen.

UPDATE(20.02.2017)

We’ve addressed the NTRIP issues reported by @Brent_W, @Simon_Allen and @dirkkoller in the new v2.2.5. You should receive a notification about a new available version the next time you start your Reach if it was on v2.2.4.

The new version handles parsing NTRIP tables a lot better with less failures and allow for more flexibility by keeping an option to enter the mountpoint by hand.

We’ve also reworked the antenna offset option in the base position, which is now vertical only. From now on it actually affects the position sent by the 1006 RTCM messages. Thanks to @bide, @TB_RTK and @Luke_Wijnberg for the report.

Edit: forgot to mention, this release also patches ERB to include correct geoid and ellipsoid heights.


Red LED on Reach, where is the log file for the error?
ReachView 2 beta Suggestions/features request
(Egor Fedorov) #2

#3

:heart_eyes:


(Egor Fedorov) #4

Sorry for making you wait for so long :sweat_smile:


#5

And refresh average position :wink:


(Andreas Ortner) #6

Is the Lora module also available for reach?

Could you give us some information about it?

Good work!


(Brent Wiebe) #7

Looks great. Not sure what fixed it but today after update my fixes are perfect. A good fix within seconds! I am however experiencing what appears to be a bug. I guess we’ll see if anybody else reports it. As soon as I open my “logging” screen while recording “Solution” I lose my fix. It seems like just opening the “logging” page resets everything, AR Ratio consistently drops down to 0.0. I tried it on both modules and I got the same results, so I’m sure you’ll hear more of it if it’s a bug. Thanks guys!


(Rob Ratcliff) #8

Would you please post a link to the image for v2.2.0? Even with a fast Internet connection, the update has failed many times without success. I have to update 6 Reach devices and it looks like it’d be faster just to flash it.


(Igor Vereninov) #9

Rob, preparing a new image will take some time for us. Where does it fail during update? Do you have decent internet connection? It takes about 3 minutes for me. The files are delivered via CDN, so there should be no geographical differences.


(Rob Ratcliff) #10

I switched to a different wireless router and the update succeeded. It was failing at the lora step before. I’ll let you know if I have troubles with the other Reaches.


(Igor Vereninov) #11

@Brent_W

We are investigating the issue, thank you for a speedy report!

@Andreas_Ortner

LoRa not yet available on Reach module, software support will come there when we make the hardware available.


(dicky) #12

Awesome…finally.
Great job emlid :+1: :+1: :+1: :+1:

I would like to make an observation this evening. Soon after that post the report.


(Francesco Sisani) #14

Hy

Update Done !
Thx

Francesco


(dicky) #15
  1. @Brent_W I got same bugs, AR down to zero, after open log.
  2. I can’t see solution option log
  3. Z position is not true, I put rover Z position was same with base
    All I post in 2 video

AR drop
(https://drive.google.com/file/d/0B4NFPYGvPmMvZ3NzSXlBVS1xMDQ/view?usp=drivesdk)

Z false position
(https://drive.google.com/file/d/0B4NFPYGvPmMvS1hRdFlydlQ1WTQ/view?usp=drivesdk)


(Igor Vereninov) #16

@dicky XYZ coordinates are in ECEF. Z does not have to match.


(Egor Fedorov) #17

Hey guys!

We’ve confirmed the bug with the logs tab. Working on a hot fix right now.


(dicky) #18

Is that mean, I should use lat lon coordinate?

Sorry, I don’t understand what a hot fix is? How to use it?


#19

Hot fix is something Emlid is working on, a minor update.
I prefer lat and long :slight_smile:


(dicky) #20

Should we push update button for minor update?


#21

I think it will be public announcement