ReachView 3 BLE Beta

Good Morning.
Connecting RS2 via BLE I can’t write raw data?

You cannot go to logging in RV3 when connected via Bluetooth. At least for iOS. I wish it would work too! You have to be on either wifi mode (hotspot/network) unless I am missing something.

Hi Zach and Mauricio,

True, the Logging tab is available only when you connect to the unit over Wi-Fi. That’s for now. We’re working on making it possible via BLE, too, but it’ll take some time for sure.


A post was split to a new topic: How to use BLE in the field

Hi Team, BT Issues FYI below:
FYI I have been having never ending issues connecting RV3 to RS2 unit with this device:
“Samsung S10+, Android 12, One UI 4.1” - “Reachview3 App 7.6” - “RS2 FW 28.4”
I have basically worked this down to a Samsung/Android/One UI thing, You can see the thread here:

I got an older Android v7 device and have confirmed my RV3 Wifi issues do not exist on the older phone.

I tried the BT connection from my Android12 Samsung phone the other day to work around the Wifi issues. I could not get BT connection working. Figured it was a Beta thing.

Just tried on the older Androoid device I have borrowed (V 7) and it works totally perfect, within seconds.

Tried again on newer Samsung Device, and still does not work! So there is some big issues with Samsung devices and the Reachview3 App, in Wifi AND in BT.

I was going to post that BT doesn’t work at all on the Newer Samsung device, but just as I was typing the RS2 BT connection popped up on New Samsung device. When I clicked on it to connect it worked for a minute, then said"disconnected" and now wont show up in Reachview3 Again!

Seems like the exact same issues with BT on newer Samsung as is happening with Wifi, so BT may not be the “Fix” for RV3 on Samsung !
Seems we need to get you a Samsung device with these issues so you can troubleshoot?


@brianC Have you given ReachView 3.7.6 a try yet? Maybe it helps with wifi on the Samsung. The bluetooth connection is not 100% on a Google Pixel 3 either at this point.

1 Like

Hi everyone,

Indeed, we have improved the Wi-Fi scanner in our ReachView 3 app on the latest 7.6 version. In the majority of cases, it should help you. Still, as each Android versions is specific to the manufacturer, it’s difficult to comply with all of them.

We’re testing each new version of the app on our devices at the office, including the Samsung phones. We can’t fully reproduce this on our devices. So we assume it to be more connected to the specific builds and updates on the systems. It doesn’t mean we’re not going to look into it, though. But it does mean that we will need more time to help you.

Regarding the BLE issues, the BLE functionality is still in Beta testing. So, Brian, we need to check out the connection steps before jumping to the conclusions. Let’s go one by one:

  • Please double-check that the app on Android 12 has location permissions and the network permission.
  • Please double-check that the Bluetooth connection is enabled on both your phone and device.

I’d also recommend updating your devices on the latest Reach Firmware 29 stable. This could help make the Bluetooth connection more stable.

Meanwhile, we’ll try to reproduce the issue to come back to you.

Edit: fixed typos.


WiFi and bluetooth connections are improved using Pixel 3. WiFi especially has been improved with 7.6

Thanks Team !


Great to know! Thanks for sharing!


Hi Egor !!! If posible found in firmware 29 stable ?

Hi Luis,

Yes, the latest stable Reach Firmware 29 and above fully supports the BLE beta testing :slight_smile: You don’t need to be on Reach Firmware Beta to test it out anymore.


In my case with reach view 3 updated and firmware 29.2, the emlid does not connect with Xiaomi note 10, it appears waiting for a connection in BLE mode, nor in a realme.
Of course all permissions have been given to the application. However it does work with an iphone.

Hi @javipined,

So do I get right that when you select NTRIP over Bluetooth, you don’t receive corrections on Xiaomi? But when you connect over Wi-Fi, the corrections are coming in, right?

Yes, with ntrip without ble it works perfectly

Hi @javipined,

I see. What Android version is installed on your Xiaomi?

Thanks Liudmila, Now I have conversations with support about the issue.
Mobile device: redmi (Xiaomi)

Modelo M2101K7BNY

Version Android: 12 SP1A.0812.016

Version Miui 13.0.1 Estable



Ah, I see that Kseniia has already replied to you over the email. I believe it’s better to continue the troubleshooting there to keep all the details in one place.

1 Like

Gracias Liudmila
Es mejor

Hello. Is it possible to connect the M2 via BLE?

1 Like

No…for this time, lets pray together so emlid will enable it for M2😍