Reachview 3 Averaging

Setup: Reach RS2 on NTRIP network with Reachview 3 on iOS platform.
When trying to collect points I set “Averaging” to 10 seconds but it will not take a measurement. The measure button does not change when pushed. It doesn’t matter if I set it to 1 second or 1 minute, when you press the measure button nothing happens. I have to turn averaging off before I can collect a point. Any ideas?

Can you post a screenshot?

Hi Doug,

May I ask what firmware version is installed on your Reach RS2? A screenshot or a video of ReachView 3 performance will help to check what might be wrong as well.

Still having major problems with 3 on iOS platform. While using NTRIP Reachview 3 does not want to do “averaging”. When you press the measure button it sometimes takes a minute or two to start averaging if it stars at all. If you collect points without “averaging” the points you collect might be hundreds of feet off. All of this while “fixed”. I had this problem when 3 was still beta and was hoping the new version fixed it. I don’t have this problem while using Reachview 2 so I’ll stay with 2 a little longer.

Hi Doug,

Thank you for the report! Could you please share a screencast demonstrating this behavior?

I will as soon as I can.

My setup is:
Reach RS2
Florida DOT NTRIP network
iPhone 7
Using the hotspot on the iPhone
Reachview 3

This is so strange. It’s like a memory leak that progressively makes the system more sluggish. (1.3 KB)
This is the csv file I exported two days ago when I was having so much trouble with Reachview 3. Multiple shots show up with the same point number. Makes no sense.

Hi Doug!

Thank you for the report and all the data! Could you please also share what coordinate system are you using?

We’re investigating it.

1 Like


NAVD88 height (ft)

1 Like

I tried to use Reachview 3 again today and before I started I rebooted my phone and then started everything up. Right away I was having problems with averaging. Once I pressed the measure button it took 12-15 seconds before it would start averaging and then it got to the place where it took several minutes and then it wouldn’t average at all. I then went back to Reachview 2 to finish the job. I thought that by rebooting everything it would at least start of working correctly by it didn’t.

One other thing. I also noticed that when it was taking several minutes before it would start averaging it was draining the battery on my phone at a lot higher rate.

1 Like

Hi Doug,

Thank you for the details!

At the moment, we’re investigating this issue. I’ll let you know as soon as there is any news.

What iOS version? The iPhone 7 is a little outdated and ever since v13 has been known to have memory issues. Do you have another device you can try?

The only other device I have is an even older Galaxy S6. Maybe it’s getting time to upgrade phones.

1 Like

I would definitely test another device before going too far. Perhaps a significant other or friend has one you could borrow for a few minutes. It would be easy to install the app, test and take it back off. That said even moving to a used or refurbished 8 just as a data collector would be a big improvement. That way you can keep it clean and only loaded with the survey/GPS related apps. The more important thing is the A11 Bionic processor and graphics vs the A10 Fusion of the 7… Big jump.


Hi Doug,

I just wanted to tell you that we’re still investigating this issue. I’ll reach out to you once there’s news. Thank you for your patience.

1 Like

Hi Doug,

Sorry it took so long to get back to you! We’re still investigating this case.

We’ve just released a new 5.5 ReachView 3 version. It contains some improvements that may help to avoid this issue. May I ask you to update the app and check if it helps?

In case the issue persists, could you please tell me if the app works the same way with other coordinate systems? For example, you can check WGS84.

Having the same issue. On the field right now and can’t work.