ReachView 2 beta v2.1.1

Short feedback to v2.1.2:

Further testing follows…

ps: what about my early suggestion to mark the base on the map?

Wittich I also am getting some great connections using TCP even from my balcony where I only have a half view of the sky. (screen shot is this example on a very clear night) Even last night when it became very heavily clouded and rain like crazy for over an hour, I still maintained a fix all that time. My immediate concern is however, is this really accurate, or is this again a cache issue? Just one other question a bit off topic. Does the base line improve the accuracy if its spread apart further? From my balcony I only have a 3m space between the Base Reach and the Rover Reach. Or doesn’t it make any difference?

Thanks for your time to reply with all the good info.
_"I set the coordinates accumulation time to 15min but it seems to take much longer. Sometimes up to 30min to 1hr or more to get a Base coordinate fix. This is even when I have constant 6 to 8 sats well over 45

I don’t quite understand. What do you mean by Base fix? Does the procedure itself start?"

In Base screen for my base Reach in the Base Coordinates settings is the "Coordinates accumulation time " slider , which I assume this is set to a time frame so that the base can collect coordinates data so it gets a best average fixed location with and then it uses that as the correction coordinates for the Rovers correction?. Is this assumption correct? If it then the issue I have is if I set the slider to 15min or over, it takes much longer than that before it finally sets a Base coordinate that gets set into the Rover field. I tried at 30min and even after 2hrs it never set a fixed base coordinate. Is this maybe a cache issue as well? I will try again after I have made a few changes to the settings and see if I get the same issue again.

“Settings are saved every time you hit apply. If they are lost, then it means something went wrong. Probably the file got corrupted. It should be connected to an unfortunate powerdown. Are there more details to this?”

Sometime when adjusting some of the settings there is no popup to click apply with right?. Which makes me wonder if the changes actually got sent and written to the board or not. Perhaps that’s deliberate and/or still in the works?
My guess what I think may happen is if I open ReachViewer in another browser that was used before and that had some old settings, when it connects to the board it updates and sends those older settings to board, rather than the board refreshes the ReachViewer with it settings? Obviously would be a cache issue again?

Thanks again for the great job on this release.

Do you get the “read error” message if you turn turn BT on but have no device app connected?

i have also posted an issue like this months ago. i got a fix with very bad conditions.

but with best conditions the fix is not stable @me.

Yeah, of course you are right. We’ll address this messages altogether.

Cache may have something to do with the page not loading correctly. The status data is always accurate.

Small baseline doesn’t make any difference.

I quess interference will, if units are placed to close…

yes, but as @egor.fedorov says they will do something about it :slight_smile:

@jcampen unfortunately you cut the screenshot in a way that we can’t see the baseline. Is the baseline distance correct between the two units?

@Andreas_Ortner I had the feeling that the fix was not good here. Also as my position stills moved though the to units where mounted on a tripod. And by the way my baseline of 10m (as you saw it in the screenshot) was definntly wrong the units where in a distance of 1-2 m. :wink:

@egor.fedorov nice feature that the settings are saved, even when there where disabled for a while (for example when I switch between radio and tcp correction or between average and manual coordinates of the base)! :+1:

My radio correction also working!!! (I think it’s time that I solder the connections) :wink: Also the the "age of differential is now max 1s with the radio! With the older image I had up to 90 seconds.

Conclusion: nice work emlid team!



i did have a look in ubx.cmd in /usr/bin/RTKLIB/app/rtkrcv

you have again set UBX CFG-NAV5 1 8 = airborne

it like to set it to 1 for base and 3 for pedastrion for me. but after restart the value is again at 8.


updated new release BT works



1 Like

This setting does not affect raw data produced by the receiver, so unless you rely on the single solution calculated on the receiver(not RTKLIB), there’s no need to change it.

1 Like

Would you post a link to the image so I can download it and flash the Reach’s manually? I am on a slow connection and do not want to download the image multiple times to flash multiple Reach devices. Also, the Intel installation application refuses to install without an error on my laptop so I need to install the firmware using the Windows CLI approach.

Hi @egor.fedorov, Why I don’t see Galileo. GPS option is freeze, that access with notebook. But, when i access with wifi, i couldn’t open ReachView, just freeze

My units start very slow and the access via the browser is also very slow and also regularily not successfull (content is missing). Its this way when I use Firefox in incognito mode and worse when I use it in normal mode or use IE.

I also have the problem that one is even slower and that this one does not show up as usb drive in Windows but wants to be formated. Is it defect?

I get only float, I’m still awaiting for fix now

My base configuration

And it’s strange, i turn off base, but rover still get correction

galileo is not available yet. there must by a firmware update and it is not ready.

acessing reachview with some browsers is still very buggy!!

try incognito mode with chrome…

Could you give a little bit more information about this?
How long the Rover continues to receive corrections after shutdown?

A few minutes after shutdown base, rover still get correction, but then I turn of correction, the ratio is 0.0.
I think the real is no correction was received because ratio is 0.0.
I unplug all power, then plug again. Fix result about a minute, then float again for along time waiting for fix, but o fix any more. Then unplug the power, the observation was finished.

I am wondering if the even triggering function is active, or it will be implemented in the future? I was not able to get events logged, while with earlier version it does work.