ReachView 2 beta v2.1.1

Hello, everyone!

We want to thank everyone for the warm response to ReachView 2 and the new image. We’ve had a ton of invaluable bug reports and feature requests.

Almost a week and a half after the initial beta release, we are releasing the first on-the-air update with tag v2.1.1. So what’s inside?

New features

USB is back!

You now have three serial options to choose from:

  • UART
  • USB-OTG, which corresponds to USB accessories, such as USB radios
  • USB-TO-PC, only useful when Reach is connected to a PC as a device

Updater progress bar

Unfortunately, you will not see it this time, but starting with the next update you will have a nice progress bar, showing download and install status.

Added loading screen

Opening the app page will look a little better.

Caching

We’ve implemented some serious cache-fighting mechanisms, but you still need to clean it this time.

Bug fixes

  • RCH-353: Wi-Fi Password should allow any characters
  • RCH-356: XYZ/LLH selectors disappearing
  • RCH-359: Coordinate label is not changing in XYZ mode
  • RCH-374: Allow URL instead of address for TCP
  • RCH-352: Allow connecting to open networks
  • RCH-374: Time syncing too slow via the Internet
  • RCH-373: Base disable output doesn’t work
  • RCH-361: Reset to default button does not work
  • RCH-364: Restart solution log when reconfiguring position output
  • RCH-357: Logs not resuming after reboot
  • RCH-370: Fix logger splitting period

How to update?

  1. Go to the settings tab, and find the check for updates link. You will be redirected to the setup screen you’ve seen when ran your Reach for the first time.

  2. The last part of the setup will show that there is a new version v2.1.1 available. Click the blue update button to perform the actual update.

  3. The update process will have no progress bar. It will only be delivered with this update. Our tests show it usually takes from 1 to 2 minutes, depending on the Internet connection speed. Please wait until it shows that the update went successfully with a green tick.

  4. Click the Reboot and go to the app button.

  5. Clear your browser cache! v2.0.9 suffers from the cache issues and they might still affect you immediately after the update.

That’s it!

Thank you for using the beta, your feedback is extremely helpful. You can leave your reviews and notes in this new thread.

Update

v2.1.2 has been released.

9 Likes

Awesome!!! I will it soon.
Thank you all emlid team. Great job…
Mumtaz…

1 Like

Frontend still buggy with chrome and windows . Works with incognito No problems with iPad and iPhone.

Rfd900 not works with new beta! (Worked with 2.09)

Andreas

1 Like

That’s probably because of the cache issues.

Regarding the radio issue, can you confirm that the WiFi corrections work?

Wifi works.

1 Like

Where can I find advanced settings like in .conf files on

How is the protocoll for sending solution to USB /pc ?
Does reach with this settings work like a GPS receiver sending nmea … to com/USB port ?

Andreas

Hi Egor!
Thanks for the great efforts, looking forward to give it a try!
The link https://files.emlid.com/images/ReachImage_v2_beta.zip points to the new image? Can I flash it, or just a 2.0.9 -» 2.1.1 update is possible?
Best, Balint

Thanks!

You just need to update it via the in-app updater, instructions provided in the post above.

I was not able to have wifi connection with the 2.0.9 (even with wifi name: emlid password: emlidreach :slight_smile: ) so I would give it a fresh look with the new release, starting from scratch!

Hi Egor, I’ve updated to the latest version. The update its self went very smoothly. I was connected to my home wifi for this purpose. Prior to the update, I cleared my chrome browser cache and that worked flawlessly. The Android browser was a little more problematic. I cleared it’s cache prior to navigating to the Reach-View but all that initially came up was a black screen with a blue Bank Gothic Emlid logo that neatly scrolled into position in the upper left corner. No other controls were visible or available.
I found that it wasn’t until I cleared all browser data on my android that the correct front end was displayed.

While I’m on a roll, I’m using the Samsung Note II android device with current pertinent updates. Navigating the map seems problematic, jumping to a location way off the visible map when the screen is touched. Panning with a point and drag method only seems to work when dragging very slowly followed by a 3 second pause before removing my finger from the screen.

If I may suggest, a more Google-Earth like map navigation UI or a subset thereof. By now that has nearly become a standard and is intuitive.

We’ve made the hard decision to remove many settings from the interface. They will be coming back gradually, fully tested and properly supported by us.

What about using position output tab?

You can definitely start from the beginning, although it would have helped if you reported this exact problem as well. Any details on how it went wrong?

yes, WIFI works (corrections via TCP).

Radio/uart not working.

1 Like

We’ve experienced the same thing after the update. Unfortunately, this kind of problems is sort of inescapable, especially right after the update. As I’ve said we’ve implemented some new front-end features to help fight for this cause, so it should be way better next time.

On Android, it helps to request desktop site.

Regarding the Note II issue, are you using mobile Chrome? Not really sure, what you mean by a

Can you elaborate?

OK, will do more tests today. Thanks for the report.

It is not Chrome. Best to see link: http://www.androidcentral.com/inside-samsung-browser.

Regarding the navigation user interface, controls like point and drag to pan any given direction, pinch closed around a point to zoom out from that point, pinch open around a point to zoom in to that point, place two fingers on map and twist to rotate map, click on a north arrow to orient north-up, double tap a point to zoom-step in. I think you guys were trying to approximate this but it doesn’t seem to work well on my device.

I’ve just noticed that the controls on the logging page cannot be used to stop the logging. Once logging is started, if you click the control, it is no longer green; however, the byte counter continues. If the web page is refreshed, the controls show their original on state.

This happens on the android as well.