ReachView 2 beta v2.1.1

Could you please try with Chrome on Android? Because samsung default browser has problems with support of modern web technologies.

First quick test done. I love the fancy loading image!

Correction TCP Server / Client: okay (for the Client, nice feature that you see the details of RTCM2)
Correction Radio USB / UART: not working

Is there any debugging possibility for radio correction?

ps: Android Chrome seems to work okay, but I used the private tab as well. Can’t you used the scripts with a date tag (like script_20161123.js) in the filename to avoid the caching problem?

Can you please verify the radios are working by themselves?

Okay it works! There seems to be another bug. I had to change the frequency to 56000 save it in both units and then change it back to 57600. Further I had to deactivate another position output from the base, which I haven’t set before.

Now another bug I can’t use the BT output of the rover unit. I used it as mock ups provider for my phone. It worked with the previous beta version.

How can I debug the BT connection?

@bug Not sure if its a bug but i cant change gnss GPS and COMPASS
Its grey out

@Feature request:
Sorting and select/delet marked in log windows

1 Like

@TB_RTK at least the GPS should be activated. As far as I know there is no compass integrated (correct me if I’m wrong).

Feature request:

  • toggle active/disable the body of panel element by clicking on the panel header (sorting is maybe to much)
  • set the average base coordinates as a visible marker on the map

Update went fine. To be consistent with naming, can you call compass either compass or beidou but stick with one? It’s called compass on rtk page but beidou on base page.

1 Like

I wonder if this checked mark disappear when there is no vissible satellite (GPS ex.) ??
I got the check mark back again now, but then it disappeared. I have the antenna indoor for testing.

Can anybody confirm that problem?

Hey guys!

Just a little update on what’s going on. We’ve confirmed a bug with serial connections(both USB and UART are affected) and are currently working on fix to roll out quickly.

I’m not sure what exactly happened. Are there GPS satellites in the status bar? If there are not, you should reset to default settings, it’ll probably help. The button is located in the settings tab.

Good catch

Will check

1 Like

I got it working twice yesterday but today I had no success. At 56000 the base unit seems to send a lot of information but the rover doesn’t receive them. If I switch back to 57600, the base sends few information and then stops. Well I’m not sure what actually happens but that’s what I interpret from the LEDs :wink:

1 Like

Ok I am not going crazy!!!

I have not been able to connrct UARt radios either.
Also yesterday I noticed the GPS box was greyed out with a check mark and then once was greyed with no check mark.
Of couse unable to select this box while greyed out.
Keep up the good work Team Emlid.


Another bug, when I check the checkbox “Send NMEA GGA messages to the corrections provides” the Applay button doesn’t appear. But when I now uncheck the box again it appears.

Just checked the box:

and now unchecked it again:

Seems like there still bugs in the function which checks if the settings have been changed. It might be better to show the Apply button always after any change, even if the settings have been set back to the original.

PS: a work a round is the toggle OFF and back to ON, then it is possible to hut Apply :wink:

Also me I have problem to output bluetooth nmea to my laptop
with previous version it works perfectly


1 Like

ok same here. when switching between 56000 and 57600 some messages arrive…
after seconds all stops (no red blinking led)

i was also able to get this…

after that reach config was destroy . if had lose every setting…



wifi: my reach is connected with wifi to my internet router. ( connection signal is good)

after power off and on reach does not connect to my router and starts a hotspot. (sometimes)

you should give reach more time to find a wlan…

I was wondering if it was possible to have an Edison image with latest ReachView already installed. I’m out of town at a remote site working, and the corporate network has a lot of characters, ie: $!# and with the defaulted ReachView Installation I’m unable to connect to the network, and while it’s running in AccessPoint mode the reach will not let you reboot to the app if you’re unable to connect to a network. (Tried clearing Cache, Running a modern browser, etc etc).


Hello all,

Keeps getting better with minor action items.

Setup: LG LTE Lite using FireFox browser.
beta v2.1.1 Upgrade
Base: Using Stock Emlid Antenna
Rover: Using Tallysman 3710 (Emlid antenna probably damagd in use) Antenna alignment off vertical about 30 degrees (poor holder).
Weather: fair
Sky View: Poor. Pine Trees, Industrial Buildings

Used Kinematic and Static modes during real-time testing. Mostly consistent FLOAT on ReachView APP beta v2.1.1

FLOAT accuracies +/- .5M on realtime plot.

STATIC mode, AR Lock GPS +Glonas +SBAS
Resolution/ Accuracy: Good considering setup and environment. Good FIXes on post-processing. Agrees well with previous testing. Don’t know why Demo5 gives better FIXes than ReachView.

Resolution of Fixes: approx 1 CM on 20.3 M baseline.

Latest Version Problems:
Map response unpredictable.
Map Vertical does not automatically adjust to fit screen. This causes map scale to go offscreen for small scales. The scale is there, I believe, but with a horizontal scale of 100mm, the vertical scale may be city blocks long.

           Map automatic centering of last  coordinates does not seem to work on this version.

I would like to see LLH and ENU solutions as logging options. Be nice to see ENU solution in realtime.

Bottomline: I understand the tremendous amount of effort that goes into what is state-of-the-art development. Good progress.


I started from the beginning and now changed my wifi password to 12345678 and it magically worked, so the password field is even more restrictive on the v2.0.9 then reported previously (8 characters I guess). Everything looks fine now!