Reach won't boot

I usually power my rover with a pair of small cell phone battery packs. I usually run it till the battery goes dead then swap the battery out with a fresh and put other one on the charger.

After low power today, I can’t get the reach unit up and running. when I plug in the battery the reach flashes as usual, but after a few color changes, the LED on the reach begins to blink off and on yellow. It never does anything else, just a flashing yellow light.

I have been having consistent success with achieving RTK fix and consistently getting 1-2 CM accuracy using two 3dr radios (915 mHz). recently I have been working with NTRIP. I am using a free program called SNIP (windows 10) and set up the base to send corrections to the rover correctly (again 1-2 CM accuracy) as long as the base and rover were on the same LAN.

I just added a Static IP address to my ISP package and today I was hoping to set up a complete RTN with a base station on a know point at my office, connected to my LAN sending correction data to my rover the internet. I have the base set up and broadcasting corrections.

The rub today was getting the reach to log on to my mobile hot spot. For two hours I would log into the reach and set up login credentials for my hot spot, then tell the reach to change networks to the hot spot. The reach would then stop broadcasting it’s own hot spot, and appear to login to the hot spot from my phone. I would scan all available networks and could not find the reach rover, yet it’s light was steady green usually the status when it is connected to a network. I was assuming it was on the hot spot (since I couldn’t find it anywhere else) yet Snip was listening but not finding any login attempts, thus no corrections being sent out.

I figured I had the unit mis configured, yet at this point I had no way to login into the reach rover and change settings, since I couldn’t find it on any of my networks. Many folks had had success using various apps (Fing, for example) to find the IP addresses for other clients on the network. no luck, every app I tried would only show my phone and tablet as logged into the hot spot, yet the Reach unit was sitting there, Green light shining, and not visible on any other networks. Very Frustrating!!!

The the battery went dead and now I can’t get anything out of the reach rover unit but a flashing yellow light.

Any help would be appreciated.

FYI today I started off by upgrading both rover and base to V2.4.0

If you are familiar with the command line, you can set up USB over Ethernet, then ssh into Reach and monitor / modify the wireless connection with the command line tools.

Thanks,I am a little. Thats not not my first choice, as I don’t wish to carry around a laptop. At the moment I’m concerned with the flashing yellow light and no connection to anything.,

@bide, is there a link you can share with me to use ssh, I found PuTTY for windows, but I’m stumbling in the dark as to find imformation as to how to connect and use. I have a laptop running linux (ubuntu 16.04) if that’s any easier.

If you use Windows and have USB over Ethernet setup already, then Putty is the right tool. Just enter Reach’s IP address, probably and connect. User root / pass emlidreach.

Start with these commands to get some info:

  • ifconfig
  • iwconfig
  • cat /etc/wpa_supplicant/wpa_supplicant.conf

If iwconfig shows you are in Master mode, that means Reach has created a hotspot, if it shows Client mode, then it should be connected to your Wi-Fi network. If in client mode and not connected to your Wi-Fi network, try: iwlist wlan0 scanning to see what networks are available.

Type exit when you want to exit Putty.

Putty for client is available on Ubuntu 16.04. I’m not sure if it is in their SOFTWARE package because it always crashes and I replace it with Synaptic and install what appears to be an earlier version of SOFTWARE CENTER.

USB over internet is not Set Up. I’ve been trying to find how to do this. I keep getting links to this page. they keep point me to the same worthless page here (@bide your link also)

please tell me where on this page are the instructions to set up Ethernet over USB

I’m assuming Putty on Ubuntu won’t work any better than it does on windows if USB over internet is set up incorrectly.

if by set up you mean connect the reach to the computer using the usb cable, then mine is set up.

When I run putty I try, connection times out

Sorry, I do not have Windows. If you have a Linux machine, you just plug Reach into the USB port and type
ifconfig usb0 (usb0 interface might be called something different on your computer)
then to ssh, just type
ssh reach@

Oh, and as luck would have it, I just found this in some docs that I have saved on my computer:

the above is a pic, so here is the plaintext so the search will pick it up for the next guy:

Using Ethernet over USB With Reach you can use a virtual Ethernet network over a USB connection. Intel Edison officially supports this type of connection on Windows and Linux hosts. Windows You might need to wait for Windows to install the driver after plugging Reach in. In Windows 7 and below, go to the Control Panel. Under Network and Internet, click View network status and tasks. Click Change Adapter Settings in the sidebarIn Windows 8, right-click the Windows Start menu button and select Network Connections Choose the network adapter with RNDIS label. Go to properties, configure IPv4 IP address. Set manual IP address with mask. Apply changes. Reach should now be available on address.

link to docs

I mean, it shouldn’t stay blinking yellow, but maybe the wireless configuration is messed up. I’m curious as to the contents of the wpa_supplicant.conf file. (warning: don’t post your wireless password here / it is contained in that file)

[quote="RickJ, post:6, topic:5899"] Putty for client is available on Ubuntu [/quote] [quote="mwfoshee, post:8, topic:5899"] Putty on Ubuntu [/quote] You can run Putty under Linux, but there is no need to. Just use the `ssh` command from your command line (or open xterm, rxvt, or whatever your GUI uses for a terminal emulator).

As am I, I don’t appear to have one, at least not one I can find. Could it be a different name in 16.04?

There are 3 files in this folder -, and

Did you get anywhere with this?. From the last post it looks like you were viewing a directory on your Linux computer and not on Reach.

If you were on Reach, you would have been seeing these files:

entropy.bin p2p_supplicant.conf udhcpd-p2p.conf wpa_supplicant.conf

I can help you further, but maybe it would be easier to reflash Reach rather than trying to troubleshoot?

Thank you so much. I’m feeling a little overwhelmed.

Yes, I’ve been trying to reflash. I was looking on my Ubuntu machine for the file you mentioned. Sorry, that was a wasted hour, lol.

No machine I have, windows or Linux seems to be aware my reach is plugged in.

When I try reflash, on either OS, I arrive at a point where I am instructed to plug in my Edison device, I plug it in, it begins to boot up, gets to a point where the led flashes yellow (I interpret it as yellow) continuesouly and my computer eventually asks if I’ve plugged my card in, then offers options.

From this point on, let’s stay with Linux, more specifically Ubuntu 16.04

I’ve been working through possible solutions, as offered by messages in the terminal. I’m not having much luck installing the last tip from my terminal. I’m not at the office now so I don’t remember the exact spelling, but it was prompting me to install something like xftls?

I’m definitely needing some direction.

@igor.vereninov any suggestions from the Emlid

Linux is not my cup of tea. Cant help you there.
No luck on windows?

Edison flash, in my experience is very sensitive to USB cable from Reach to Computer. Usually reports a bad connection. Replug the Edison. May be a speed or timeout problem. I use a dedicated cable that I found that works. Sometimes, I had to continue to reflash dozens of times to get the reflash to finish…

New upgrades from Emlid don’t appear to have that problem.

My flash edison usually done on Windows. Run RTKLIB on Reach, Windows 7 & Linux 16.04.

@TB_RTK no luck on windows, It’s like my reach isn’t even plugged in, which, come to think of it, is exactly what it’s doing in Ubuntu.

@RickJ, Thanks, and I will try another cable now. My reach seems to be hanging up and flashing yellow without connecting to wifi then in lieu of no wifi, it should broadcast it’s own hotspot, which it doesn’t do. Do you remember/know what the behavior of the LEDS is or should be when connected to a computer?

gonna change my handle to mwfoshee_JBY “Just Blinking Yellow”: :confounded:

Mike, could you share some screenshots with your Ubuntu steps and error in the end?