Reach with no Wireless network, straight hotspot on boot up

Is there a way start the Reach on hotspot mode immediatley? I tried deleting all the known wifi network, but that didn’t help. The reach just went back through initial setup…

Are you saying that you have a brand new (or newly flashed) Reach and you:

  • do not want to hook up to a Wi-Fi with Internet access, and
  • do not want to update ReachView and/or GNSS receiver firmware, and
  • just want ReachView to start up so you can use it immediately on first boot?

Yes I do not want to hook up the Reach to a Wifi network and would like to always connect to it while it is on hotspot mode…

This is what I have done and what I am doing…

I set the reach up when the ReachView Updater shows up, I get this when I connect to my Emlid Reach as a hotspot via… After that, I am able to connect to the Emlid via the address… everything is great until the emlid reboots, gets unplugged, or strays away from the wireless network.

At which point, I have to reboot, multiple times, watch it blink all the seizure inducing blinks… only to have to reboot it over and over. I eventually found out about the 192.168.2.x I can connect to which is the ethernet over usb, which is fine at times, but now I am stuck on the ReachView Updater screen as this thing tries to continue to connect to the wifi network, and when it does… it gets stuck in Time Sync… Then it will ask me to select a different wifi network or add another wifi network. THIS SHOULD NOT BE THIS HARD…

That is solved by booting it up outside or near a window (or having a NTP server running on your local network).

ReachView wants you to update the software on first boot, and that requires either a Wi-Fi connection with Internet access. If you must bypass those requirements, then you have to run this command over ssh:
touch /etc/reachview/first_time_setup.cfg

Be aware that this is an abnormal thing to do. It is a bypass technique, and because of that, you won’t be running up to date software.

For reference the command above was copied from this post:

I ssh’d into the emlid reach successfully, ran the command you recommended, it seem to succeed… opened the browser to connect to it, and got… the same ReachView Update screen, only this time, it will no longer connect to wifi it seems.

I guess I should have explained: The command just creates a file which ReachView looks for when it boots up. So you must reboot.

I did that, now I can’t connect to the reach via, or or… I can however connect to the emlid via port… it is still not running as a hot spot… Is this at all possible?

Well, ssh works, right?? You won’t get ReachView until it time-syncs. You don’t have it hooked up to a Wi-Fi network with an NTP server, so you must give it some satellites to look at so it knows what time it is. Take it to a window at least.

One of the reasons it needs a time signal is for naming log files and another is for correct age of differential numbers which directly affects your ability to get an RTK fix.

I am actually standing outside right now on the hood of my car…

Hmm. It can take a minute or two to get going, but if that has passed, then I don’t know what to say.

Does the LED blink sequence look normal as compared to the docs?

If you still have grief, then maybe you should try to reflash.

The other thing is maybe that command I gave no longer works on the latest versions. I have not used it myself for some time now, so I can’t be sure.

this is the second time today I reflashed…

Since you were outside, did the LED sequence tell you that you have completed time sync?


Well, I don’t know what to say then. I’m out of ideas at the moment. Hopefully someone else can shed some light on it for you.

I got something to work… here are my steps…

  1. Reflash the emlid reach…
  2. Go through the setup of updating and putting the reach on a wireless network
  3. Connect to the reach via the USB port network connect (192.168.2.x) as oppose to the or
  4. Add a random non existing wireless network as one of the wireless networks
  5. Turn on the hotspot mode, and delete the original existing wifi network from the list
  6. Reboot, wait 2 minutes, and connect to the emlid again via the USB port (192.168.2.x)

Great! I’m glad you got it working.

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.