Reach with Foxtech map-02

Hi,

I did a short flight test today with a Foxtech map-02 and a combo Reach RS / M+

I took 116 pictures, I was able to find the same amount on my arduplane log, but the Reach gave me 130. You will find logs from base and rover Here

Later today, I did a ground test with manual triggering and got 488 pictures, but the Reach registered only 414. You will also find logs from base and rover here

I really to know what is wrong.

Thanks

Benjamin

Hi Benjamin,

What RTK Settings do you have on Reach?

Could you please share the hardware setup photo?

I have the same settings as the ones on this picture :

About the hardware, I am no longer at the office but I connected the camera trigger to my flight controller and the hot shoe from the camera to the M+ C1 pin 1 and 2

In the camera control of the M+ I can see the camera events updating every time I am taking a picture manually

The actual frame rate during a flight i about, one picture every 0.7sec

Btw, I am using PPK and i used both 2.16.1 and 2.17.3 firmware version

I did another test today with setting GPS + Glonass at 5hz, 567 photo recorded by the Reach M+ and 685 taken by my camera.

Something is really wrong here :expressionless:

What is the limit of frame per second for the Reach M+?

Hi @mathon.benjamin,

You have quiet bad satellite view with a lot of cycle slips on your rover.

Can you share a photo of your antenna setup, please?

Also, it’d be nice to see a photo of the connection scheme.

I recommend you to update ReachView version on the last stable v2.16.2.
There’re some improvements connected with missing events.

As for the rover settings, it’s recommended to use settings from our docs you can find here.
There’s no GPS + Glonass 5Hz configuration, so you can have missed time marks with it.

Thanks for your reply.

You have quiet bad satellite view with a lot of cycle slips on your rover .

Yes I had, I install the antenna just over my FPV system which is the worst place you can see it here

https://drive.google.com/open?id=1urytCKnG2z0JdPGAi5DwZKZe5tcba5UR

As for the connection you can find it here

https://drive.google.com/open?id=1VyXSwVqxoVgjMuq6hD3ubvhgnPDwol-r

But after your post, I use this setting : GPS + GLONASS + QZSS 5 Hz and moved the rover antenna, you will see on this picture

https://drive.google.com/open?id=1PxuGi7zc_jsLBQrYSvO5lDA0NgPg9Y-z

And still the same problem : 413 events on the event files and 517 photos taken :worried:

The only time it was working correctly was when I captured at 1fps and a maximum of 30 pictures, the rover antenna was inside a building

Right now it’s 2-3 fps continuous

UPDATE :

I wrote some code on an arduino board, counting the number of trigger from the PPK/Hotshoe output on my camera and it’s working perfectly, I consistently get the same number of trigger and photo.

So the problem is with the Reach M+ and we need to find a solution

In another post about Foxtech camera, 2.11 seems to have fixed the problem, why not try that.

Hey there,

It’s been week without reply from the support staff.

Hi @mathon.benjamin,

Providing that Reach captures the events correctly at 1fps, I assume the issue is caused by the frame rate parameter. Perhaps the camera outputs signal somehow different from what Reach expects at 2-3fps.

We didn’t change the way Reach M+ logs time marks since v2.11 so I don’t think firmware version involved here.

Also, we never tested this camera and don’t have one to investigate why this behavior occurs, therefore it’s difficult to make predictions. At this point, I’d recommend checking with an integrator and look through community forum threads about this camera model.

Hope, some of the more experienced Foxtech users will help you.

I don’t think that will solve the problem, but I would bring the Reach unit away from all that probably noisy electronic you have inside your uav.

I think a possible reason why this happens could be that some of the pictures are taken with an interval shorter than 200 ms when you are working with 5Hz. Please try a configuration with 10 Hz and report whether the same problem occurs or change your Arduino code so that it reports if the image interval is shorter than 200 ms.

Explanation: the uBlox module will only report the last timemark within the epoche. If you work with 5 Hz only one timemark per 200 ms will be reported.

Hi everyone,

I tried to use GPS only at 10hz but nothing, still missing some images even if it’s a flight with 34 and 35 pictures. on my event file, only 32 and 31 are recorded. I also played with the trigger duration on mission planner from 100ms to 500ms and no luck. by the way I changed the lens and reduced the overlap, now the time between pictures is about 1.5 second.

I moved the antenna on the top with a clear view.

I tested it, with a program on arduino and a relay that triggered the camera, with a delay between frame of 1s, 950ms and 900ms, every time with a trigger duration of 100th second, no issue except double recording in the event file for the first frame, the antenna was inside a building.

So I am really getting desperate, maybe I have a faulty unit or something else…

I

Do you another camera to test ?
Also you could enable feedback on pixhawk in comparison.

What is interesting to show :

1 Like

I would also propose to get rid of that red BEC and power Reach via USB during the test.

Thanks both of you for your reply.

I will test today the feedback on the Pixhawk on 3, 15km flight and let you know.

And I will be able to do the other test by the end of the week.

Test on the ground, no need to fly. Arm and let’s trigger your camera by autopilot. Don’t be too agressive on time trigger, there is buffer in camera. It’s just an a5100 Sony customised.

I came back from the flights, 3 of them using the flash feedback connected to my Pixhawk and it’s flawless with 401, 956 and 941 pictures all logged.

The issue is not the camera, I will try tomorrow again with the Reach supplied via USB, but my hope are not high.

Also I can understand that my accuracy could be impacted by various factor, but It should still record the event, right?

No ! Try inside, if you have no gps : no event.
So if you have gps signal suddent drop : no event

Are you flying low ? Time between pictures ? Did you ask foxtech ?

1 Like

Based on the test done before it is clearly a problem with the Reach module. The Arduino and the Pixhawk are working.

Now its time to use the Reach module without any exteral things but the camera and a usb power device, preferably 2 different power tanks. And outside the plane of course.

I have seen massive problems with the reception when Reach was connected to a 3DR radio clone frome Drotek. So I think problems introduced by the power source or the telemetry connection are possible. Maybe there is also a pattern which events are missing, probably events during/after high power draws/voltage spikes etc.?

You may also add a small resistor between the camera an Reach if it is not already there.

1 Like

Ok, I did a few test.

If the Reach M+ is powered via USB and the drone is not supplied with power, It’s working nicely, pictures match the events and I get a good signal.

But if I still use USB and power up the Nimbus, then the signal is really bad and I can’t even get a position.

So right now I can see that bad signal can mess up the event file and the camera is fine

Right now the antenna is here and it follows the same path than the battery cable, which I am pretty sure interfere with the signal :

https://drive.google.com/open?id=1-qo1oGZ6G8KIDQCFzD0k0Zav5Ji51to6

My goal is to move the antenna on top of the nose closer to the pitot tube, move the FPV camera under the nose and move the video transmitter under the belly.

I have some copper tape, do you recommend me placing some under the antenna?