Reach USB to RJ45 - any suggestion for solution

Hello,

I ordered a couple of micro usb to rj45 adapters, None of them has worked.

I have to connect my rtk to ROS.

Thank you

Micro USB to RJ45? That doesn’t sound right.

How about:

  1. Micro USB to normal USB / OTG adapter
  2. then a normal USB to RJ45 adapter

This setup has worked for me with Reach RS. It should work with Reach as well, but you would need to supply 5V power to Reach through the DF13 connector.

1- http://www.ebay.com/itm/152204439171?_trksid=p2057872.m2748.l2649&ssPageName=STRK%3AMEBIDX%3AIT

2- http://www.ebay.com/itm/322404568560?_trksid=p2057872.m2748.l2649&ssPageName=STRK%3AMEBIDX%3AIT

they did not work.

Can you please share your two working items’s online website?
Did you use external 5v power?

I plugged power to 3dr radio ( with micro usb port), it is connected by DF13 to rtk. If possible can you send your connection’s picture

Thank you

OK, those are OTG devices. They look very suitable for the task. Maybe the driver is just missing. If you plug each into a Linux box and paste the output of /var/log/syslog (or similar), then Emlid could possibly add the driver in the next kernel release

Also see:

Yes, probably it is missing driver issue. I do not have much time. If you know a product is working, i can order it immediately.

After this issue, i have to look at how i can publish nmea data to ROS with this rtk.

Thank you for your support. As you feel, i am very new to rtk and linux environment.

Well, as I said in my link above, this one worked for me:
D-Link; model DUB-E100; USB 2.0 Fast Ethernet Adapter (10/100Mbps)

and this is probably where I purchased it:
http://www.ncix.com/detail/d-link-dub-e100-10-100-ethernet-usb-2c-40300.htm?promoid=1854

I just plugged in the USB-OTG cable that came with Reach and attached the DUB-E100 and an RJ45 cable and it just worked. In my case I had a Reach RS, so it had internal battery. You say that you are supplying Reach with DF13 power via the 3DR radio, so that should be good too.

I ordered the same one, it is on the way.

How i can communicate between Reach and ROS? i searched the key words, nothing.

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.