Reach RTK fails test 2

Hello good afternoon.

I have problems with test 2 with Reach rtk. I have already flashed the module but continue with the same error.

The ed blinks red and white.

I would appreciate if you had a solution.

Hi Agustin,

May I ask you what firmware version was on the Reach Module before the reflashing? Do I understand correctly that you tried reflashing to the latest stable image v2.22.3?

Hello Polina

I don’t know the last firmware version, I am new in the use of Reach modules, I was trying to configure the base and rover reading in the emlid community but I could only flash one module.

I tried to update to the latest stable image v2.22.3 as the documents explain.

I attach a photo of the process, thanks.

Hey there,

Just wanted to say that we’re looking into why the failure of Test 2 might happen on Reach Module. We’ll keep you posted.

I am having the same issue. Reflashing the unit to the latest firmware did not resolve the test failure. What would be my next step to resolve the issue?

Just to let you know I’ve the same problem after updating to V2.22.3 & V2.22.4 on my Reach module (all tests were ok in V2.20.8)

Any news on this?
I would like to be able to use my 2 Reach Modules (while awaiting the final solution), now they are stuck in the updater. My last work was done on 2.18.1. (in-app OTA update to 2.20.8 seems to pass the tests, but didn’t used it).
If needed I can setup some remote ssh-access to the module.

Where can we download older firmware images?
(I’ld prefer the 2.18.1, sure it works & can in-app update to 2.20.8)

Hi Cody,

Would you mind specifying what firmware version was on the Reach Module before the reflashing?

I don’t know exactly the version but it would have been somewhere in the 2.18 range.

Either way I have attempted a number of reboots and re-flashing of the firmware with no change in the outcome. Test 2 always fails afterwards.

A post was split to a new topic: Reach Flash Tool doesn’t download the latest image

Hi everyone,

Just wanted to give you an update on this. We’re working on a fix for this issue. We’ll inform you once the firmware update with the solution is released.

Hey there,

We’ve just released the v2.22.5 update that should solve the issue of Test 2 fail. You can find the full list of fixes and improvements in this community forum thread.

It’d be great if you could check how the new release works for you.

Just performed the firware update (link in flash tool & docs still points to 2.22.4).
After flashing 2.22.5, I succesfuly passed all tests (Test1, 2 and 6)

Device seems to work properly now (I could at least get a ‘single’-quality solution. I’ll examine RTK features in the coming weeks

Hi Polina

I have the exact same problem after updating the firmware from v2.20.8 to v2.22.7.

I have been reflashing the unit for several times and at one instance of the reflashing, it gives me some error and a log file. The log file is as attached.

Right now, not only it fails test 2, it also flashes 3 red light and 1 blue light continuously.

I have 2 reach modules. The first module that i have flashed is working as expected. But i failed on the second module.

The failed unit can connect to the network but it seems that the reachview is not available. I can view the unit in my wifi network with only 2 ports opened i.e. port 22 and port 80.

Please help me.

Thanks (26.0 KB)

Hi @remi,

Please specify on which step the reflashing fails. It’d be great if you could attach the screenshot of it as well.

Could you also check the process with another USB cable and another USB port on your computer just to exclude the possible issues with them?

1 Like

Hi @polina.buriak,

  1. It happened only once, in the middle of flashing buti didnt capture it. The subsequent flashing were successful but failed at test 2. After connecting to wifi, i restarted the unit and the led blinking 3 reds and 1 blue continuously. Whenever i go to reachview, it will bring me to the port 5000 page…doing the test again.

  2. I have already tested on different computer and different cable. It yielded the same result. But i havent try flashing from my mac. Would give it a try later.

  3. I have ssh to the unit and the logs folder is empty.

  4. One question, does the flashing wipe out the entire edison or just some folders?


hi @polina.buriak,

flash logs (47.3 KB)

Hi Remi,

Thanks for the detailed information!

I’ve written to you in PM. Could you please check my message there? The next steps are easier to handle in the private chat.

The reflashing procedure resets all settings and deletes all the stored data on your device.

i forgot to tell that before the led flashing 1 blue and 3 red, it was flashing 1 white and 3 red. this is before setting the unit to connect to any wifi network.

and @polina.buriak i have already replied to your PM. Could you please response to it.

Thank you very much.

Hi Remi,

Thanks for the info. The change of the LED color from white to blue does indicate the change from the internal hotspot to the available Wi-Fi network. More on different LED statuses can be found in our guide.

Let’s continue our discussion in PM so that it’s easier to reach a solution.