Reach RS3 firmware update

I need to update the firmware on my RS3s. I know the current version is 31.7 (with 31.8 coming out soon) but Flow keeps saying that the firmware is up to date and won’t give me the option to get the current version. I’ve gone into the settings through Flow on my Android tablet and through ReachBase.local on the desktop computer but hit the same dead end.

Hi Steve,

When Reach can’t find an update, most likely it’s not connected to the internet to update to the latest firmware. Could you please try connecting your device to a Wi-Fi network or your phone’s hotspot and try to update again?


Thank you for the response but there is something I’m missing here. I use a Samsung tablet, with the Flow360 app loaded on it, to run the Reach RS3 Base and Rover. The tablet and the RS3s communicate with each other via wifi. To communicate with the internet, the tablet connects to my office wifi. Therefore, the tablet can be connected, via wifi, to the office wifi OR the Reach RS3s wifi, but not both at the same time. How do I connect the RS3 to the internet via the tablet when the tablet has to be connected to the RS3 to see what is going on in the RS3?

Connect your RS3 to your office WiFi then everything is on the same network


Thank you for the response. The wifi connection procedure is somewhat nuanced and rather confusing for a new Reach user like me. The following procedure was given to me by tech support (Patrick) at E38 Survey Solutions and contains the amount of detailed steps I needed. Worked perfectly when I followed them. All good here now. The Reach RS3s are great units. I’m very pleased with my purchase.

“You will need to go into the wifi settings of your receiver within Emlid Flow and connect the receiver to the office wifi. It will disconnect from your tablet at that point and you will have to refresh your receivers. So long as your tablet is on the same wifi network you should be able to find it and reconnect. Then you can initiate the over-the-air update in emlid flow.”


Yes all devices need to be connected to a wifi that has a internet connection


Hey Steve. Welcome to the community.

Working with gnss precision receivers is highly detailed. Do yourself a big favor and make use of the excellent documents and videos authored by Emlid. Then, ask questions if something is confusing or not working as explained in the docs.


Thanks Dave. You’re absolutely correct and I did look into the RS3 Firmware Update documents but they’re lacking (or maybe just vague about) the subtle but significant step to go into the receiver’s wifi settings, while the tablet is connected to the receiver in Flow, and redirect the receiver’s wifi connection to the office wifi, at which time the receiver will disconnect from the tablet. That missing link was killing me and without understanding the step I was doomed until the guys at E38 made it obvious. I included the E38 directions in my post in hopes that others might see what helped me if they bump into the same issue. The Emlid folks have done a great job developing the RS3 (along with software and documentation) and I’m thrilled to have a pair. You’re actually responsible for me now owning them due to a suggestion you made in early September, in a post on the Commercial Drone Pilots forum, to a member where you said “Do yourself and favor and get an Emlid”. I’d never heard of Emlid but did some research and discovered the Reach was exactly what I needed for surveying in GCPs for my P4 RTK work as well as a ton of other tasks I’ve already used them for. Thanks for that as well. The RS3s have changed my working world almost as much as the P4 and 3DSurvey.


Hey Steve. That is great to hear!

1 Like

i agree the rs3 is great working in locations with reception issues like building corners and cover issues i am having the same issue with our rs2+ which ive conveniently set up as my base on a rooftop with a sim card and in trying to update to the latest version it tells me im updated at a earlier version not the 31.7 we are at currently which is funny the sim card/ receiver setting is not connecting to the internet as the system is functional otherwise

the rs3 heats up and begins to have difficulty providing the fix solution

Hi Victor! Could you please send your unit’s Full System Report to I’d like to take a look to see what could be the source of this.

@jamie1! To update your firmware using a SIM card, you should turn on the Allow updates using mobile data option on the Mobile data screen in Emlid Flow.

hi zoltan
i have made this allowable in the settings and restarted the rs2 from reach panel
but still have the same result short of removing it from the mount and trying a update on the office wifi im not sure what else to do it would be way more convenient to leave in place and find a solution as this will be an ongoing issue if it wont update remotely

It’s quite unusual, so we’d like to investigate this issue. Could you please send a screenshot of your Mobile data tab and the full system report to In the meantime, as a workaround, you can connect the Reach to the Internet via a mobile hotspot to update the firmware.