Reach RS2 Mobile data off

Did they ever work inside the reach unit? Are they on a GSM network or CDMA network?

One of the cards was in RS2 and it worked fine (since February 2020) until I upgraded to version 2.23.7. After I upgraded to 2.23.7 it worked intermittently and now after I upgraded to 2.23.8 it doesn’t work at all. Recently, bluetoot also stops and I have to restart RS2 to run again (it’s very annoying and a big waste of time).
There are GSM cards in the 4G network.
Can I do a firmware reflashing?

I’ll let one of the Emlid support people answer that.

Hi @amc.proiect,

May I ask you to generate the Full System report on your RS2 device with this SIM card inserted and send it to me? I recommend sharing it in PM or over since it may contain some sensitive information.

The Full System report may allow me to understand what went wrong here.

I have a couple of more comments. First of all, I’d like to clarify that dev branch is needed for testing purposes and allows gaining earlier access to try new features. We need dev versions to make sure none of the difficulties that happen on them won’t migrate to the stable.

Reach RS2 only works with 2G, 3G, and 3.5G. Any chance this SIM card may handle one of these frequencies?

Thank you for the report! We’re looking into that currently and hope to fix it in the nearest time.

If you want to return to the stable branch, you can reflash the device following this guide. Please note that all the data will be erased from the receiver during this procedure.

However, if you decide to return to the stable branch, I’d like to ask you to generate the Full System report since it would help us a lot in resolving the issues you faced.

I’ve been using this sim card since February and it went ok. The network also works 3G and 3.5G.

Hi @amc.proiect,

I’ve got the data, thank you! We’ll look into what might be wrong with it and I get back with any updates.

Hi @amc.proiect,

Have you reflashed the device back to v2.22.5? If yes, does it work as expected?

Today I reflashed the device back to v2.22.5. It seems that now the mobile data is going well and I have an ok signal. I haven’t tested the device in the field yet, but on Monday I will go out again and let you know how it behaves.

Hi @amc.proiect,

Keep us posted!


Now it’s almost fine. No more problems with mobile data. Sometimes it does not receive NTRIP corrections although it is connected to the internet and to the provider (I have several gps and the others receive corrections and go well, and RS2 does not work)

Hi @amc.proiect,

Any chance you can share with us the following data?

  • raw data log (UBX)
  • base correction log (RTCM3)
  • solution log (LLH)

I’d like to check why it may occur.


Also, any chance you remember from which version you updated to v2.23.8 before it happened? Was it another dev version or stable v2.22.5?

Today I re-installed version 2.23.8 from version 2.22.5, and the mobile data doesn’t work again (I can’t activate the button). Looks like it’s a problem with version 2.23.8 (and version 2.23.7 was doing the same thing but intermittently)

Hi @amc.proiect,

At the moment, we’re trying to find out why it happens. Unfortunately, we weren’t able to reproduce this issue with our devices and it looks like it can depend on the mobile operator.

I’d recommend you stick with the v2.22.5 firmware version while we’re working on it. Also, it’d be extremely helpful if you could get back to v2.22.5, enable Mobile data on the device, generate the Full System report, and send it to us. This way, we could check the differences between establishing the connection with your mobile operator on v2.22.5 and v2.23.8.

Thank you!

A post was split to a new topic: RS2 Mobile data can’t be turned on

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.

Hi everyone,

We’ve just released the new v2.25.2 dev firmware version. Now the Mobile data should be easy to switch on. You can find all fixes and improvements in this community forum thread.

Please note that dev versions mainly serve as early access to the new features. They are not intended for the important fieldwork.

If you have any questions or reports, feel free to create a new thread or contact us via