Reach RS2 Mobile data off

260/5000
Mobile data cannot be activated on RS2. I tried with 2 sim cards (from different operators). In the phone both sim cards work perfectly and I have maximum signal, in RS2 I only have one dash and the mobile data cannot be activated (I entered the correct APN).
Mobile data is activated once every few dozen attempts and even then it does not work well.
I have version 2.23.8.

Are the SIM cards on a GSM network?

It works perfectly in the mobile phone and in another GPS.
The problems appeared after I upgraded to software 2.23.7.
After upgrading to 2.23.8 it worked fine for a few minutes. When I started it the next day it didn’t work.

Did they ever work inside the reach unit? Are they on a GSM network or CDMA network?

One of the cards was in RS2 and it worked fine (since February 2020) until I upgraded to version 2.23.7. After I upgraded to 2.23.7 it worked intermittently and now after I upgraded to 2.23.8 it doesn’t work at all. Recently, bluetoot also stops and I have to restart RS2 to run again (it’s very annoying and a big waste of time).
There are GSM cards in the 4G network.
Can I do a firmware reflashing?

I’ll let one of the Emlid support people answer that.

Hi @amc.proiect,

May I ask you to generate the Full System report on your RS2 device with this SIM card inserted and send it to me? I recommend sharing it in PM or over support@emlid.com since it may contain some sensitive information.

The Full System report may allow me to understand what went wrong here.

I have a couple of more comments. First of all, I’d like to clarify that dev branch is needed for testing purposes and allows gaining earlier access to try new features. We need dev versions to make sure none of the difficulties that happen on them won’t migrate to the stable.

Reach RS2 only works with 2G, 3G, and 3.5G. Any chance this SIM card may handle one of these frequencies?

Thank you for the report! We’re looking into that currently and hope to fix it in the nearest time.

If you want to return to the stable branch, you can reflash the device following this guide. Please note that all the data will be erased from the receiver during this procedure.

However, if you decide to return to the stable branch, I’d like to ask you to generate the Full System report since it would help us a lot in resolving the issues you faced.

I’ve been using this sim card since February and it went ok. The network also works 3G and 3.5G.

Hi @amc.proiect,

I’ve got the data, thank you! We’ll look into what might be wrong with it and I get back with any updates.

Hi @amc.proiect,

Have you reflashed the device back to v2.22.5? If yes, does it work as expected?

Hi
Today I reflashed the device back to v2.22.5. It seems that now the mobile data is going well and I have an ok signal. I haven’t tested the device in the field yet, but on Monday I will go out again and let you know how it behaves.

Hi @amc.proiect,

Keep us posted!