Reach RS2 is missing the list of available receivers

Hi, I have a similar problem. I connect with my phone (Nokia G50 running Android 12) to my RS2 via wifi when the unit is in hotspot mode (wifi indicator is white), but it doesn’t show up in the available devices list in RV3 (v6.17). I cannot tell the firmware version, since I cannot establish connection with the RS2 in RV3, but I updated the unit firmware 1-2 months ago.

I managed to finally connect to the unit through the browser version of RV3. I updated the firmware from 28.1 to 28.4 which seems to have solves the issue.

1 Like

Hi Otto,

Welcome to our community forum!

Have you managed to connect to the unit in ReachView 3 after update to 28.4?

1 Like

Hi, yes, the update solved the problem. Now the unit shows up in hotspot mode in RV3.

2 Likes

Update:
I ran into again the same problem. I connect through wifi (Nokia G50, Android 12) to my Reach RS2 (firmware v28.4), but when I open ReachView 3 (v7.1) the unit doesn’t show up in the list of available devices. I turned everything off and on about 20 times, sometimes the RS2 shows up for a brief second in the list of available devices, but it immediately crashes the app. The thing is, that I can connect to the RS2 through a browser using the IP address of the device, so it got to be a software issue in ReachView 3.

Hi Otto,

It sounds weird, especially because everything worked fine a month ago. Did something specific happen before this issue came up?

You can try to remove the app and install it again. Please note that it’s important to save all your projects because they will be removed as well.

If it doesn’t help, try to change the battery optimization settings in Android settings. It may affect the app’s work since it can close it in the background.

I reinstalled the app (v7.3), it got somewhat better but the problem still persists around half of the time I try to connect to the unit. It either doesn’t show up in the list of available devices, or it shows up for a sec and crashes the app. It throws no error code.

Hi Otto,

Does it persist with the same device’s model on the same OS version (Nokia G50, Android 12)? Do you connect to the receiver’s hotspot or another Wi-Fi network? Is the device available in Reach Panel via IP address?

I’m experiencing the same issues with the RS2 receivers (all three I have). Sometimes it seems impossible to connect to them via their WiFi hotspot. I use Samsung phones (S20, XCoverPro and A52) and it happens to all of them. I tried different firmwares (28.1, 28.4 and 29 Beta), but that doesn’t seem to help.
After multiple times rebooting phones and receivers, they magically appear again in the list of devices. When you’re out in the field, this is pretty annoying. Any solution?

1 Like

Yes, same device and OS. I connect to the receiver’s hotspot, I have no issue while using Reach Panel via the IP address, the problem only occurs when I try to use ReachView.

1 Like

I am in the same boat as you. Both my RS2 have been intermittent for a couple of months but 28.4 completely killed any connections to the app.
Support is telling me to restrict my wifi network to 2.4Ghz only. Why would this fix an issue that the update created.

Hi @seanzandbergen

We’ve recently released a new BLE feature. It allows connecting to the receivers via Bluetooth in ReachView 3. You can check this topic to learn how to do that. Give it a try and share your feedback with us!

@james.barnes, I see that you’ve already contacted my colleague Julia to solve it. Let’s keep that topic not to mess things up.

Quick update: I gave the beta BT connection a go, for now it seems to work without problem, also the wifi connection improved with the new release (v29 Beta 2) but it is still not 100%. I’ll give another update after a few weeks of testing on the field to see if the solution is more permanent than last time.

3 Likes

Hi Otto,

Thank you, keep us posted!