Reach RS2 disconnects bluetooth when there is no mobile coverage

Reach RS2 latest fw 2.23.9 disconnects from my Cat s60 when there is no mobile coverage.
I have Survey Master and SW Maps installed on my phone, and receiving NMEA by bluetooth.
SIM card is inserted in RS2, it is connected to local NTRIP network, everything is working excellent when there is good cell coverage, but as soon as it is spotty and RS2 loses mobile signal, it instantly disconnects from apps I use. I have tried multiple apps, multiple phones, but the problem is the same.
As soon as it disconnects, I try to reconnect, but it fails, because ReachView still shows in Position output tab that It is Connected to localhost, so applications can’t reconnect bluetooth.
I tried to turn Output off and on, but it shows that it stays connected to localhost.
I tried to turn off phone bluetooth, then i shows Send error 111, but when i I turn it back on, it still shows error and I’m unable to reconnect app.
Only solution is to restart RS2 and than it is able to reconnect to app.
I am can work for hours without problems when cell coverage is good.
SystemReport.zip (1.7 MB)
Here I was working successfully for hours till at the end mobile data went down:
https://drive.google.com/drive/folders/1VR2_zbia5PWponv0yTWnM-R0m3b8tUGf?usp=sharing
And here it disconnected in a few minutes:
solution_202009031357_LLH.zip (11.1 KB) base_202009031357_RTCM3.zip (278.7 KB) raw_202009031357_UBX.zip (899.8 KB)

1 Like

Hi Gints,

Welcome to our community forum!

We will try to reproduce the issue and I’ll come back with the summary.

So I have been testing and noticed one more thing - when I put a hand on antenna so it loses satellites, it disconnects bluetooth from apps I use. When I take my hand away and satellites are in sight, I can reconnect app.
Only this time I don’t have to reboot antenna to be able to reconnect.

EDIT:
Did some more tests, seems that disconnects are directly related to losing data from base/NTRIP server. When I put my hand on antenna, Reachview shows that RS2 is still receiving signal from satellites and base, but after a moment base data are lost and at that moment bluetooth disconnects. Lowering SNR mask to about 25 mark fixes this problem as high noise satellites are still used for corrections, but it is not recommended for precision.

2 Likes

Friday I was in a bad mobile coverage area and had some more bugs.
When there is no mobile coverage, RS2 reboots by itself and goes into bootloop.
It can’t seem to boot up when SIM is inserted and there is no coverage. As soon as I remove SIM, RS2 boots up without problems, even after being in bootloop for 10mins. After it’s booted, I reinsert SIM and it starts bootlooping again.

Hi Gints,

It’s interesting. Could you please share an updated version of the Full System Report after your Friday tests? We need to take a look at what happening to the unit during these boot loops and what had particularly caused such behavior.

Please, PM it to me instead of sharing it here as it might include the sensitive information.

I have sent you report.

Also it goes in bootloop when I insert SIM from different mobile operator.
Usually I use LMT, but I have bought BITE sim card to try in bad reception areas, but with this SIM RS2 doesn’t even boot, but stays in bootloop.

Gints,

Thank you.

Could you please share a photo of the contact pads of both SIM cards? Such a behavior when the RS2 boots fine with one SIM card (even in case the signal quality is good) and does not boot at all with another one might be caused by the issues in the SIM card layout.


They are a bit different, but in general, layout is the same.
I will try to test SIM card from the third mobile network operator and see what it does.

1 Like

Hi Gints,

Sorry for the delay.

We are trying to reproduce your setup. I’ll come back with the summary once our tests are be done.

Hi Gints,

Just wanted to give you a brief update on this. From our investigation, it looks like the issues with the Bluetooth connection being lost are connected to the latest versions of the Survey Master app. We’ve checked your setup with other Bluetooth apps and couldn’t reproduce the issue.

We’re still checking the issues with the SIM card you reported. We’ll be back once there’s news about the test results.

Hello!
I have this ,disconnect when there is no cell coverage, problem on all apps I tried.
Sw maps, survey master. Lefebure Ntrip client disconnects and is unable to reconnect.
When rs2 loses ntrip corrections, it disconnects, but is able to reconnect.

Problem is, built-in cell antenna is small and not powerful enough in low coverage areas.
I have temporary fixed issue by making Lora antenna work as 3.5g antenna. Now reception
has increased considerably and it doesn’t lose connection.

Hi Gints,

Thanks for your patience in waiting for a response from us.

We were not able to reproduce the issue you’ve faced. We’ve conducted a series the tests with Reach RS2 but to no avail.

We’ve recently released the new dev firmware - 2.25.1. It brings performance improvements, which may help to resolve the issue with your unit. Please note that dev releases provide early access to the new features and are not intended for real-field use.

You need to enable the dev updates in the receiver settings to install this firmware. The menu looks like this:

A post was split to a new topic: Connecting Reach to SurvCE

Hi Gints,

Please share how do you do to make lora antenna work as 2.5G antenna.
Thank in advance

Diego

It involves disassembling antenna and voiding warranty.

On mainboard you have to switch lora antenna and 3.5g antenna connectors.
You have to know how to work with electronics, like wearing antistatic wristband and
having the right tools, better take it to electronics specialist.

Cell reception problem can’t bet fixed with software, it’s clearly hardware problem.
3.5g antenna is too small to provide good reception in remote areas. Using Lora antenna for cell signal completely fixes the problem.
Emlid should have combined these antennas in one as other manufacturers do.

But anyway, for a price, you can’t find a better instrument.

Edited my post because moderators got angry and closed this topic :frowning:

1 Like

Hey guys,

Please note that we don’t support disassembling our units. If you disassemble your Reach device, the warranty is voided. We can’t provide further support as we can’t guarantee that the unit will work correctly.

Diego @dialfranco66, if you have faced any issues in working with the Reach device or have any questions, please, contact us here on the forum or via support@emlid.com. The majority of the issues can be solved in a troubleshooting process with us.