Reach Rs+ with Edge not working

Hi All

İ want to use rtk witk reach rs and edge for tractor guidance. But not working rs with edge. i tried every way and not comminicate any way.

usb to pc output select reach rs not working navio2 and emlid (im write dev/ttyUSB vs vs vs)
reach rs db9 cable directly connect rx/tx cable from edge ser1 and ser 2 not connect
reach rs db9f cable connect with rs232 to ttl edge bot connect
reach rs usb to ttl not working edge
wifi tried navio2 not connect to rs
im tried erb and NMEA

How do I connect rs to edge

Hi Akay,

Please post:

  1. The screenshots of position output tab with all the configurations while you’ve tried to integrate it with Edge;
  2. Hardware setup photos.

May I also ask you to describe how exactly you’ve configured Edge?

Edge is parameters same the reach m+ setup 38400 baundrate and gps_type auto and all serial connection baundrate is same uart output is not working, not working wifi method and not working usb connection

Navio Gps parameters E- dev/ttyUSB0 and Ardupilot parameters same the M+ Setup

Hi @Akay_Yesiloz,

In regards to Navio, you should specify -E /dev/ttyACM0 for USB connection. I’d also recommend you to use a higher baud rate.

Also please make sure you connected Edge to the RS-232 converter correctly. You should use Edge SER-I2C port and need to connect:

  • Edge SER-I2C GND (1) pin with GND pin of the converter;
  • Edge SER-I2C RX (4) pin with TX pin of the converter;
  • Edge SER-I2C TX (5) pin with RX pin of the converter;
  • Edge SER-I2C 5V_EXT (6) pin with 5V pin of the converter.

Please refer to the Edge pinout.

Hi @tatiana.andreeva

I tested connections of edge as you say and it doesnt work. I tried to connect to SER-I2C and SER-ADC ports but unfortunately it doesnt work too.

Please share photos of RS-232 to SER-I2C port connection.

What about Navio?

And RS output tab selected ERB 38400 and UART now testing navio

You need to connect the yellow wire to connector RX pin, and the blue wire to TX pin.

@tatiana.andreeva Not connect navio and im tested blue pin and rx/tx cable changed ports not not not not they are not connected in any way maybe have a bug your systems ?
Because we tried every way but failed. RS232,USB,Wifi,UART

I do not understand why RS not have directly uart or canbus or I2C for your other products ?

This is a big problem because we are not makeing only drones every products configured for drones

This setup should work without problems, it was tested earlier. Please don’t worry, I’ll help you to configure it.

Usually, Reach M+ is used for integration with flight controllers.

Let’s try to connect Reach RS+ to Navio firstly.

  1. Connect Reach RS+ to Navio over USB;
  2. Configure position output on Reach RS+ as on the screenshot;


  1. ssh to Navio and run the command screen /dev/ttyACM0 115200

Please post the output of this command here.


I’m tired of repeating things , but I’m trying again and as a result same FAIL FAIL FAIL

Only work gps1 and this onboard gps

Please post the output of dmesg | grep -i usb command with Reach RS+ connected to Navio USB port.

@tatiana.andreeva have not problem usb connections.

can we use wifi ?

May I ask you to run the command screen /dev/ttyACM0 115200 and post the output here?

How can i know ? I write Telemetry Tab E- dev/ttyACM0 115200.
are you talking about a different screen ?


this command allows to open RPI USB port and see messages that come to it in real-time. I ask you to run this command in order to figure out if Navio receives messages from Reach. You can just type it in the command line, as you did it with dmesg command, and share the result with me.

I also noticed that you missed the first / symbol in TELEM2 string from /etc/default/ardurover file. It should look like this: -E /dev/ttyACM0 115200

Great! That means that RPi receives ERB messages.

May I ask you to post the output of sudo systemctl status ardurover to make sure you’ve specified everything correctly?

Then let’s proceed to QGC configurations. You need to specify:

  1. GPS_TYPE2 to AUTO;
  2. SERIAL4_BAUD to 115200;
  3. GPS_AUTO_SWITCH to Enabled;
  4. GPS_INJECT_TO to send to 2nd GPS.

Also, please make sure that Reach has at least Single solution status.

Let me know about the result!

Not working second gps

First is onboard gps