Reach RS+ unresponsive! Help!

Pulled my Reach RS+ out of its case to warm up for another project, plugged it in to charge, and got a brief orange blink on the Pwr LED, but then absolutely nothing. Have had no further response. No indication of charging, won’t power up, hold pwr button for 3 secs and nothing, hold it for 15 secs, and nothing. Have tried multiple USB charge sources (all working fine on other devices). Nothing.

Help, have a rush project, too!

Any suggestions??

Sure enough, just a little patience required. After sitting for awhile on charger, the “charging” LED began it’s flashing…must have just let the charge decline too far. Thanks


If they have been off for that long, then you should to update the software to the latest version (currently v2.16.2).


Yeah, would do so, tho I can’t get it to boot up at all. It has progressed to showing the blinking “charging” light, but when power button pushed, it starts to cycle up, but soon shuts down before green light comes on sustained. Orange flashes 3 times to indicate shut down, then it goes back to charging.

Was it still charging when you powered it up?

If not, then try that.

Yes, was still plugged in and charging. I also let it sit and charge for 6hrs. It got to where orange LED showed solid (ie, “charged”). Same result (while still plugged in): no boot. During flashing blue, that stops, then orange does 3 quick flashes, then all shuts off.

U might want to email Emlid direct, especially if possibly still under warranty?

Also since the release of the RS2, might be a good possibility of getting some used RS/RS+ deals from other users if it justifies the cost of doing business you have. If your units are out of warranty etc.

Personally, i’d start cheap, and try some other chargers/cables…and if u can get them to revive, connect up via usb to a windows pc and reflash to a stable new version. (That’s if u can get a solid stream of power via usb and PC that is. U dont want them dieing in the middle of reflash… or possibilty of bricking them).


It sounds like the battery might still be low based on that.


Hi @jwood,

I’ve just replied to your email regarding this question.