Reach RS post processing with multiple base station observation files

Hello,

I am trying to post process using RTKPost v 2.4.3 data collected in static mode with a Reach RS. The raw .ubx file was converted to one .obs .nav and .sbs without problems. These data were collected over a period of 13 hours that span two calendar days. The base station data I would like to use was downloaded from the Canadian Active Control System (https://webapp.geod.nrcan.gc.ca/geod/data-donnees/cacs-scca.php?locale=en) and consists separate .clk, .sp3, .17o, .17g and .17n files for each of the two calendar days. In RTKPost I cant find the option to be able to add two .17o files in the RINEX OBS: Base Station field, it only allows me to put one, and there arent enough fields to add two .17n, two .clk and two .sp3 files. Is there a way to use these multiple base station files to correct the data from the Reach RS or do I need to cut the Reach RS data into separate calendar days?

thanks,

Margaret

2 Likes

I’ve had this problem before, but there are several things you could do, and I don’t remember what I did to get my result.
Here’s a couple of suggestions:

  1. Concatenate the 2 day’s files together into one file, or

  2. Process each day separately, and then combine the 2 result files. Or open up both result files in RTKPlot at the same time.

Covered elsewhere, but here it is in summary.
RTKLib file names accept wild cards.

So look at your files type the bits that are common and replace the variable bits with the appropriate number of ?

e.g
useful_data_20171001.O
useful_data_20171002.O
useful_data_20171003.O

Can all be read in sequence in RTKLIB by
useful_data_2017100?.O or if the data spans a bigger period (included 30th sep for example)
you would replace day and month with ?'s

Hope this helps

Hy Simon

I have more than 1 day of observations so I want to postprocess the data using the rinex from base station of day 1+day2

I inserted the ?? but I received error
what’s is wrong in my setup ? llo bmp

thx

Francesco

Your files seems compressed. Have you tried unpacking them?
pado267A.17d.Z
I am not sure RTklib like all types of compressed formats

HY

attached result with unzipn

error

indeed with the rtklib of tomojitakasu I’m able to read multiple zip file using wild car* but only for few rinex

thx

Francesco

And you get rinex error with one file as well? And you have verifyed files contain data needed and not “shipped” with a stand alone position file?
Those “no position in rinex” issues, i get if the .conf file has been messed up. It sometimes help to delete it and reopen RTKpost

Maybe the problem is the version of rinex of my base station that isn’t a reach unit but a base station of Italy network ?

If you have a file i can test, i might give it a shot?

The .d files are compressed in the Hatanaka format, according to RTKLIB information some Hatanaka compressed RINEX files can not be handled by RTKPOST, RTKPLOT or other APs.

Try unzipping them using the CRX2RNX.EXE program available at http://terras.gsi.go.jp/ja/crx2rnx.html.

Sorry for my bad English but I’m using the Google translator.

Thank you very much the wildcards have solved the problem! Since the CACS data are in RINEX 2.11 I had to reconvert the .ubx from 3.02 to 2.11 since it did not find a solution otherwise.

3 Likes

Hy Guys

I Have collected in statis mode 1 day of obs to try to define the coord of my base station but unfortunately I have 3 ubx zipped so my question is
IS it possible to merge the 3 ubx raw data and then post process with the rinex downloaded from cors network ?

thx

Franceesco

Have you tried wildcard solution? it should work the same way.

Tried
doesn’t work

Could you share files i can test ?

Yes
I appreciate

sorry but the zip file is 72mb

where I can upload ?

wetransfer ?

can you give me an email ?

THx

dropbox,google disk or onedrive and share link ?

https://drive.google.com/file/d/0BwGGVRDiRFGYVzJROTR2SVlxZVk/view?usp=sharing

try it never use ,

Perfect, I`ll take a look at it

Thx
Bye