Reach RS fail to update. Do not turn on after flash Firmware

Here are the log data of the firmware flash tool.
The device does not turn on after this atempt to update the firmware…
The LEDs start blinking, then stops with the orange and the blue fixed, as in the picture.
To see the blinking lights on YouTube
Any one, please! Help! (5.0 KB)

Today I was able to connect the device to my computer (It was not doing that)
So… I tried again. No sucess… The device do not turn on yet.
Is there an older firmware that I could try? (4.7 KB)
Here is the log file.

I found another way to flash the firmware here (version 2.18.1):
I tryied … no sucess!
The receiver do not turn on - this was the version that was instaled before I tried to update!
Is there a way to factory reset the unit?

The equipment was working just fine… I can’t stay without the receiver for too long - can any one help? Why did the flash tool did not work???

Hi @fabio_lobo,

Could you clarify whether you try hardware reboot? For this, you need to hold the power button for 15 seconds.

I have tryied so… the equipment keep olny showing the sequence of lights as shown on the video - it does not turn on


If I get you correctly, you have no access to the ReachView app. Also, based on the solid blue LED, the device is in hotspot mode. Whether you see the Reach hotspot from your smartphone or laptop?

I tryied again with the REACH FIRMWARE FLASH TOOL - here is the video

The device keep the same (the orange and the blue ligths on all the time - I am keeping it connected to the computer… but I don’t know if it will show as fineshed on some time…)

I will send the log data as soon as i close the REACH FIRMWARE FLASH TOOL.

No… the device does not show any wifi to access

As seen on the video, the process does not show a device on the end… and the receiver keep the two lights fixed on.


I noticed that you have already sent the Flasher logs above. Was a previous flashing attempt also stuck at 100% without any message?

On the first attempt, it shown a error - I tryied again and it showed sucess… But the receiver kept off working. I tried to roll back with the version 2.18.1, found here:

Nothing… and I tryied again with the last firmware - as shown - nothing again!

What a mess to try to keep it uptodate!

I hope I don’t losse my equipment trying to update it!!!


Please, share with me the Flasher logs one more time so it includes the data for all last attempts.

I’ll look into it and get back to you with the results as soon as possible.

I closed the software here now and unpluged the receiver - to it turn off, only with 15s pressing the button!


It all looks very unusual. Please send me the Flasher logs, we’ll try to find out what caused the issue.

Here they are. (5.0 KB) (4.7 KB) (6.6 KB)


With version 2.18… you try to reflash the old way; running flashall.bat from the image folder (2.18.1).

That’s right - tryied with the .bat (From here:

Ok, so to finish the old reflash option, did you download the image into a folder and attach the libus and dfu files (circled in red) and then run flashall.bat?

It is strange, I have returned several times to old versions with this method and it has never failed me.

If you have time, remember to go to a friend’s computer and try to flash with it. Also try a different USB cable. Sometimes even changing to a different USB port (back vs. front or add a powered USB hub). These are all things one can try while waiting for a recommendation from @svetlana.nikolenko.

This was a long time ago I even put an RS in the freezer for 30 minutes and I was able to get a successful flash. I don’t want to really suggest that putting in a freezer is the right thing to do because we might start another “cargo cult”, but when there is difficulty flashing any device (whether Reach or other type of hardware) sometimes a small change can bring success after lots of failures.

After all, we just need all the digibits to get put in the right place within the eMMC chip. :floppy_disk:

(check the MD5 sum of your downloaded image too: to make sure your image file is not corrupt)