Reach RS+ does not fall to hotspot mode

I am using two RS+ receivers in a base+rover configuration, firmware version 30.1 and I use the latest version of Emlid Flow for iPhone to connect to the receivers via their own wi-fi.
Everything worked well, until one day I turned the receivers on and they got stuck in the “searching for network” mode (blue light flashing) and never started their own hotspots. I reflashed them both, worked well for one time, turned them off and on again, the problem is there again. Works for exactly one reboot after reflashing, then something goes wrong in both receivers.
This happens with absolute regularity, so I had to add reflashing the receivers to my daily routine before heading out to the field. Is this a known problem?
Thanks in advance for any help.

1 Like

If they were connected to a network when they were started it will stay on that network or keep searching for that network until you manually put it into hotspot mode or restart them away from a known network.

1 Like

And that is the problem - they were never connected to wifi, yet they still search for one instead of entering the hotspot mode.

Hi @josefnm,

Hmm, so the units don’t have any saved Wi-Fi networks, right? Does the issue persist on both Reach RS+? Did anything specific happen before the issue occurred?


I’m in the Arctic with my two brand new RS2+ receivers, and I’m having exactly the same issue.

The receivers have been updated at home (in Scotland) to the laterst firmware and have gone through the initial set up. This morning in our accommodation, we connected to both the base and rover receiver and set up the correct options for RTK survey, as per Emlid’s online tutorial. This worked fine and we were able to connect to both receivers on their broadcast WiFi hotspots.

We’ve now taken the receivers outside to test them, and the base has been stuck on the ‘WiFi search’ (flashing blue WiFi symbol) for 30 minutes or more after booting up (we switched it off to walk to an open sky location) - it’s refusing to default to broadcasting it’s own WiFi network. I’ve tried rebooting it once, and had exactly the same issue. This is going to be a major issue for our Arctic fieldwork.

Is there a way to force the receiver to broadcast its own WiFi again, to prevent it continuously looking for other WiFi?



1 Like

No, even from completely clean setup with no saved wifi networks, they both just fall in the wifi search mode after one reboot. The very same issue as @calum.hoad describes.

For @calum.hoad : I feel your pain, I was stuck in Syria with them exactly like that. At least I could eventually find some internet, download the firmware and reflash them every morning. That is the only solution I have now.

1 Like

I wrote out the below info, then switched on our unit again to double check before sending, and the problem is back once more. Frustrated beyond belief. See below troubleshoot anyway, it worked for a joyful hour.

Hi @josefnm , I think I may have found a temporary fix after spending the whole afternoon troubleshooting. Now when I power the units on and off, they seem to reliably default to broadcasting WiFi rather than searching networks. Details of what I did:

  • List item
  • Plug receivers into laptop with Reach Emlid Flash Software, run flash with v30.1 (only option available… For some reason you can’t flash to older stable firmware, so what’s the point…).
  • When the process enters reboot (which eventually resulted in failure-to-flash on every attempt), wait for the white network light to come back on solid and then pull the cable from the receiver.
  • Connect to the receiver’s WiFi hotspot with phone.
  • Open Emlid Flow and connect to the receiver.
  • Receiver prompts for initial set up: Re-name receiver in step one, then go to step two (WiFi connection) DO NOT ENTER THE DETAILS OF ANY WIFI NETWORK AT THIS POINT. Instead, skip it by clicking the number 3 in the top right of the screen. Emlid flow will show a progress bar and finish setting up the receiver, despite having no WiFi connection.
  • Once initial set up is complete, switch receiver off and back on again.
  • Network light should default to white (broadcasting WiFi hotspot).
  • Connect to the newly named and set-up receiver’s network from phone.
  • Open Emlid flow, receiver appears in available connections. Connect to receiver.
  • I don’t think this step makes any difference, as neither the phone nor receiver have connection to internet anymore Find the firmware menu for the receiver, go into the Beta updates and enable them (I saw this advised in another forum post on this issue). As I say, this probably makes no difference since the receiver is not internet connected.
  • Set up base and rover settings on each receiver as normal, using Emlid flow app.
  • Turn everything off and on a few times to make sure it doesn’t search endlessly for WiFi again.
  • Go outside and test.

This seemed to have been successful for us: in every boot up since this process on both the base and rover, the receivers defaulted quickly to broadcasting WiFi rather than searching networks. I assumed this was because I’d never connected them to the internet after being flashed. However, the problem is back and I’ve no idea why, I’m back at square one.

The sites I’m surveying are a 10km hike to get to, through deep snow, in a valley in Greenland. If I reach the site and this happens, I’m stuffed. Hopefully someone can find a fix very soon - till then this kit is totally useless to me.

1 Like


Thank you for reporting this issue. I passed all the info about it to our devs. They are working on a solution. As soon as I have any updates, I’ll post the news in this thread.

Hi there,

Just wanted to say that we’ve released a 30.2 firmware version with a possible fix for this issue. Please test it on your receivers and let me know if it helps.

Thank you very much, I reflashed the units, set them up, restarted them many times and the problem seems to be fixed for me.

1 Like


Thanks for the update! Glad to hear that everything works fine now.

See Corrections cannot be received by the RS2+ rover when using hotspot mode & firmware v30.2

Hi Kelly,

I see that you found a solution for this issue with receiving corrections, and everything is working fine for you on 30.2. So just wanted to post an update about it here as well.