'Reach not set up' cyclical connection issue/cannot export

have contacted tech support and been asked to post here as they are busy.

I repeatedly could not connect my rover to the App -black screen, despite working when did last survey fortnight ago.

Uninstalled app and installed ReachView3 to my Android phone.

Turned on phone wifi, connected to the Rover wifi, and the Rover appeared on the Reach list as available to connect. However when click to connect says ‘Reach not set up or firmware out of date’.

Clicked on ‘set up reach’

Updater says v2.16.2 STABLE ‘You are up to date’, back to list of devices…

The app still won’t connect, still says ‘Reach not set up or firmware out of date’…

I can open my last survey project, and see the points on screen (so presumably is connecting at some level), but cannot export the project –says cannot download.

What to do?

Best wishes


Hi @chiz, welcome back to Emlid Community Forum!

ReachView 3 is only supported by the latest firmware versions. In the version you are in, 2.16.2, it is only possible to use ReachView 2, already discontinued.

Connect your receiver to a Wi-Fi network with internet and update it to the latest firmware version, 26.1.

Best Regards,
Pedro Augusto.

I had posted a reply but it has now disappeared :frowning:

Thanks Pedro, the app said I was up to date, obviously not! Odd as the machine worked fine two weeks ago for a survey.

I don’t have wifi, I only have phone internet, will this work?

Hi @chiz ,

Yes, to work with ReachView 3 app, you need to update the device to the latest firmware version. To check available updates, you need to connect Reach to the Internet.

It’s possible to update your receiver using the Internet from your mobile phone. This guide from our docs can help you connect your Reach to the mobile hotspot and set up an Internet connection.

After getting an Internet connection, Reach prompts you to update it to the latest firmware version, 26.1. So you need to follow all steps suggested by the receiver to update it.

In case you face any difficulties, please reach out to us. We’ll sort it out.

Thank you, but I have followed the steps in that guide and I cant connect to the Rover as it is not up to date. And I have to turn my mobile internet off to turn wifi on?

In the guide, ‘Connecting to Wi-Fi’, is this on my phone, or on the App?

What does ‘Choose the available one if it’s visible’ mean??

You have missed a step from your guide: click on ‘Set up Reach’
That takes you to ‘Updater’
Can then select Wifi from the menu
“Choose Wi-Fi network
Choose the available one if it’s visible
If you can’t see your mobile hotspot, press Connect to a hidden network”
What does this mean? What available one?

To connect Reach to the Wi-Fi network from the Updater page, you need to click on the “Plus” button in the Wi-Fi tab:

After that, you need to enter the credentials of your mobile hotspot and press the “Connect” button:

If you try to access Reach from the same phone you use as a hotspot, please do the following:

  • Connect to the Reach’s hotspot and open the Updater page
  • Add your phone’s hotspot as I described in previous steps
  • Now reboot the device with the Power button
  • Enable Wi-Fi hotspot on your mobile device
  • Reach should connect to your hotspot during the next boot

If these steps don’t help, please clarify whether you work with Android or iOS. I’ll provide some specific steps that might help.

Thank you.

I’m (not) working on an Android phone, as stated in OP.

Except I don’t get that screen when I go into Updater… I get this screen:


I cannot follow these instructions as they neither match the screens I get, nor are they precise enough in their phrasing

I got you. At this stage, we need to connect Reach to the Internet first:

  • Please connect to your Reach’s hotspot and open the ReachView 3 app
  • Select the Wi-Fi tab in Settings in ReachView 3
  • Press “Connect to a hidden network”
  • Enter the credentials of your mobile hotspot and press the “Connect” button. At this step, Reach won’t connect to your phone’s hotspot since it’s off
  • Now reboot the device with the Power button
  • Enable Wi-Fi hotspot on your mobile device
  • Reach should connect to your hotspot during the next boot

Then you should go here:

Reach will check available updates and suggest you update it to the 26.1 firmware version.

Thank you, have put in my mobile internet name and password and restarted the phone. Turn on wifi and it connects to my Reach Rover, turn on ReachView but I get this screen on Updater:

Could you share the screenshot of the ReachView Wi-Fi tab as well?

Have you rebooted the Reach after adding your mobile phone’s hotspot?

Thank you
What do you mean by reboot? I restart my phone by turning it off and on again, and turn on the ReachView app once the phone is on.


Android AP4574 is my mobile internet

Hope they help

I had problems connecting to my RS2 the first time, you need to reboot the receiver. Turn the unit off and then on. Have the hotspot on the phone on before you turn on the RS2.

1 Like

Thanks Bryan, I’ve connected fine previously, that’s not been the previous problem, but will try that later. The Emlid advice doesn’t include that, but it hasn’t been any good at getting it to work so far :frowning:

1 Like

Hi @chiz,

It seems we get confused a bit. You can’t work with ReachView 3 since you need to update your receiver first. To check available firmware updates, Reach should be connected to the Internet.

I’ve described the whole workflow down below:

  1. You’ve already added your mobile hotspot to saved Wi-Fi networks on the Reach

  2. However, your phone is still connected to Reach’s hotspot

  3. Now, you need to turn the receiver off. This step is needed to turn on the mobile data on your phone

  4. Turn on the mobile data on your phone

  5. Turn the receiver on. It should automatically connect to your phone’s hotspot

Sorry, I was following your step by step guide and that hadn’t said anything about turning off the Rover.
I assume receiver means the Rover? Do I need to do all this for the Base as well?

Ok, I have turned off the Rover, my phone is connected to 4G. I have turned on the Rover, and opened ReachView 3. It says no Receiver connected. All three lights on Rover are on, no flashing?