Reach not connecting to WiFi - how to reset

My Reach RTK module was last updated and used six months ago. I want to say I was at ReachView 2.2.5 and image 1.2 (I’m not 100% certain on that). I successfully used both modules.

Today, after 4-5 months, I wanted to bring the modules online and update my software.

I was able to update one of my modules through the ReachView app, no problem.

The second is not connecting to my WiFi network. The LED is solid blue (note- this isn’t the current LED usage). I note that the LED stays on magenta for a long time, then goes to solid blue.

I tried looking for the local reach hotspot, and it’s not there. I tried powering down my WiFi access point and then power on the Reach module, and it didn’t start its hot spot. After restarting my access point and then the module, it didn’t connect.

Next I plugged the module into my laptop, which I thought I used to load the new Reach image six months ago, and this Win7 64-bit machine wasn’t able to install device drivers. I have two “Other Devices” showing up in Device Manager, one of them with the name of MERRIFIELD, which I think is the Edison module.

Something isn’t happy.

Any suggestions on how I can bring my module back to life?

INstall fing on your phone (android or iOS) and connect to your network then see if your reach is connecting to the network too!If it isn’t then it should be setting up as its own wifi hotspot. its pretty binary either connect to a known network or create own hotspot. If neither then (seriously) go somewhere else where there is no network that you might have connected to in the past and power it up so that it should create a hotspot.

…or try the new Emlid app for Android!
(but only after you do a software update - which is a catch-22 situation for you, I know!)

…and check if battery is delivering enough power. It might have run out of juice. Laptop usb power is not always a good idea

1 Like

2 posts were split to a new topic: Could the Reach RS battery be charged with a mobile phone charger?

I’m in bad shape on getting this module updated.

I don’t see it with Fing, it’s not in hotspot mode. LED status is solid magenta for a long time, then solid blue.

I plugged it into my Win7x64 laptop and successfully ran flashall.bat to apply ReachImage 2.3.

I still don’t see it on the network. LED is magenta, then blue after some minutes. I don’t have an RNDIS adapter or device in device manager. I briefly get a device “MERRIFIELD” in device manager when the module boots.

I do boot Windows 7 with F8 and “Disable driver signing enforcement”.

Note that my local network is on subnet 192.168.2.*, so I need to change a subnet address in a file on the Edison that Bide helped me with some time ago when my module had ReachImage 1.2. I think that’s all I need to do to get it to connect to my LAN. (would the module still have my network credentials after a full image installation?)

If I turn off my WiFi router, the Reach module does not go into hotspot mode.

I can’t seem to get RNDIS on my laptop. It doesn’t show up after applying Intel drivers.

I have a Mac, but the intel software doesn’t work on MacOS X 10.13 (High Sierra), so those instructions in the Emlid ReachView docs are no longer valid.

I suppose I have to put Ubuntu on a USB drive and boot my laptop with that?

The intel Edison configuration tool dropped an “install.log” on my disk. Here are the contents:

x64os
Windows version: 7
CertMgr.exe MFLD_USB_driver_cert.cer returned 0
Installing drivers, please wait
drvinstall.exe intc.usbcomp.inf returned 1
drvinstall.exe intc_rndis.inf returned 1
drvinstall.exe intc_cdcserial.inf returned 1
drvinstall.exe intc_dfu.inf returned 1

hmm… I think “1” is unsuccessful?

Hey Matt,

It actually feels like a power issue to me. There is not enough power for the module to fully boot. Please try with a different power source, like a phone charger. Some laptops do not provide enough. You can also try a different USB cable or laptop port.

Well… During the holiday break I’ve had some more time to play with this. Unfortunately, the same status. It’s solid magenta for a long time, then solid blue and doesn’t show up on my network and isn’t in hotspot mode itself.

I have it plugged into an iPad wall power supply, 5V and 2.1A. That has got to be enough power?

This was my base module. I’ve never had it plugged into anything else, other than a USB power supply.

Any other ideas? Can I send this to Emlid to test?

Matt,

We can arrange a replacement, but would you be so kind to try reflashing it again? Do you you have a different computer at your disposal?

Something does not add up. We don’t really have any update related problems, so it seems weird to me something stopped working after an update. However, if something did go wrong, it will be fixed by reflashing. If you don’t have any luck reflashing, send me a PM.

Thank you Egor! I will definitely give it another shot.

I will also attempt another computer if my next attempt doesn’t succeed.

Worst case this will happen near the Christmas holiday.

1 Like

Hey Matt. I just had a problem updating a Reach module and ended up with a solid red (magenta) LED status. I took a couple tries with the Edison Flash utility to get back up and running. It didn’t work the first time and I was also unsuccessful using the terminal method. May be worth a few minutes to try a couple times.

I finally am back in business.

I can’t explain how, but the Edison part of my Reach RTK module somehow had failed.

I was able to flash it from the Windows command line successfully, but the module did not activate the local hotspot, or, connect to my WiFi network.

I replaced the Edison module, flashed it with the Reach image, and it worked just fine.

I tried to recover the original Edison module, but although I could flash it, it never was able to boot successfully. When flashing I always waited minutes to let it finish setting up the file system and boot, but it just never worked.

oh well, I’m relieved!

2 Likes

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.