Reach not connecting to WiFi automatically

Hi! I have a WiFi network set up with internet connection, but when I start my reach module it always goes into hotspot mode (blinking green and white). I then have to log onto the reach network and manually go to Wi-Fi/Bluetooth, click the network name and then ‘connect’. This procedure always works but it’s a bit time consuming, does anyone know of a solution?

I’m using ReachView 2.7.1 and as far as I know this problem did occur on 2.6.x and previous.

1 Like

Fails here too. It sometimes connects but fails on test 2.
Edit: What was test 2 again?

1 Like

Edit: After some time, it reloads and reachview loads fine again. My second device had not this issue

if have also the same problem with wifi for a long time over many versions of software.

sometimes reach connects without problems - sometime reachs starts a hotspot…

if have tested this problem with different routers/handy/and mobile hotspot.

power off and a restart solves sometimes the problem - otherwise i connect to the hotspot and manually connect to a existing connection on reach.


I’m just speculating. It seems to me that if Reach is turned off before logs have processed, that the boot process is unpredictable. Once the files are processed, it seems to boot OK for me. But, have not tested enough to know for sure. Just something to look at …

It seems random when it connects with mine.

same here too

@TB_RTK, I just encountered the “test 2” error today as well. I was worried until the “have you tried turning it off and on again method” worked.

Same problem here. One reach (which connects to powered USB) always connects to wifi. The other one (which connects to computer via USB and we use this USB to read IMU) often doesn’t connect to wifi. It creates a hotspot. After manually connecting to wifi it works. But I would say 80% of the cases it creates a hotspot.

1 Like

here is a link to my old post:

i did try ap_scan=1 long times ago.
i am no linux expert …

Hi i have insert :slight_smile:


in wpa_supplicant.conf. No i think reach works better…!

When using IBSS or AP mode, ap_scan=2 mode can force the new network to becreated immediately regardless of scan results. ap_scan=1 mode will first tryto scan for existing networks and only if no matches with the enabled networks are found, a new IBSS or AP mode network is created.

have this issue too (test 2 fail), both of mine, reach RTK and Reach RS
edit: reach RS can still connect automatically

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.