Reach M2 integration with Ardupilot - NOT WORKING

Hey guys,

So I am trying since December to integrate an M2 receiver to an Arduplane setup without success. I tried everything that I found online across the web and on this community page. Nothing works.
The unit is powering on and is apparently working normal, I just don’t ‘see it’ in mission planner and I also cannot send send corrections.

I tried with NMEA and also ERB.

The M2 unit is connected through S1 port to Serial4 (RX TX 3) on a Matek H743 FC. I tried with different baud rates and different configurations. Nothing.
I really think is a hardware problem, a connection issue or something.
It is beginning to be very frustrating also as I bought the second one after emlid didn’t want to replace one of the two boards inside it as they decided for me if it is worth it or not.

So, I trash this tiny piece of … tech … or is anybody actually working with this thing on ardu???

Have you checked on another device if it sending data?

Hi Vlad,

We haven’t tested the Matek H743 FC with Reach receivers but I suppose the integration should not be that different from other boards.

Let’s cross-check the main parameters so that everything is configured correctly.

Position output of Reach rover:

  • Device - UART
  • Baud rate - 38400
  • Format - NMEA

Mission Planner settings:

  • GPS_TYPE2 = 5 (NMEA)
  • SERIAL4_BAUD = 38

M2’s S1 to the board connection:

  • RX to TX
  • TX to RX
  • GND to GND

It’s important to test the integration outside so that the unit calculates at least a Single solution to send. Also, after you change the parameters, you need to restart the ArduPilot and very likely need to reboot the board.

Please specify if these settings work for you.


It worked flawlessly when I went outside with all the installation.
It is important to be known that ardupilot (mission planner) will see gpsstatus 0 - equivalent with No GPS if there isn’t a fix solution on emlid m2.

Now I must get working to hold the rtk fix also as it floats most of the time and in the same time the gps 1 which is also an f9p stays fixed. I think there is a configuration issue or something.

Hi Vlad,

Great to know you can receive the position of Reach on your controller!

We recommend using the Reach receiver as a second GNSS receiver. When you have the Fix solution on Reach, Mission Planner should show gpsstatus2=6, in case of a Float solution gpsstatus2=5. If you have no corrections coming, it should indicate gpsstatus2=3 and can’t use RTK.

If you have another indication, please, check that your corrections are coming and that the ArduPilot checks for the best solution out of the two connected modules.

1 Like

A post was split to a new topic: M2 no solution with MP

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.