M2 no solution with MP

I have a similar situation I am using a EMLID M2 giving data to cube black in GPS2 and feeding our on board computer USB to serial. Emlid is powered by the computer not the board. So I have a similar situation I get 0 satellites showing in mission planner also.

Hi Tom,

Could you post the photos of your setup, especially the connection of the M2 unit to PixHawk’s GPS2 port?

The EMLID is powered by the USB cable so the only wires going to PiXhawk from EMLID are the TX, RX , Ground

Hi Tom,

Please make sure that the unit is capable of obtaining at least a Single solution. This will require satellite visibility so please test the setup outside.

Please, cross-check the main parameters so that everything is configured correctly.

Position output of Reach rover:

  • Device - UART
  • Baud rate - 38400
  • Format - NMEA

Mission Planner settings:

  • GPS_TYPE2 = 5 (NMEA)
  • SERIAL4_PROTOCOL = 5 (GPS)
  • SERIAL4_BAUD = 38
  • GPS_AUTO_SWITCH =1

M2’s S1 to the board connection:

  • RX to TX
  • TX to RX
  • GND to GND

Also, it’s important to restart the ArduPilot. For Pixhawrk, it’s very likely that you need to reboot the board so that the changed parameters are applied.