Reach M2 GPS integration in Arducopter failed

Hello everybody,

I wanted to ask why I can no longer get connection data in Mission Planner?
I made all the settings according to the instructions, once I also got signals from the Reach RS2 base, then suddenly none again.



In addition, I connected the Reach M2 module as a rover in the copter to my Pixhawk Orange Cube on the GPS port.
Everything configured according to instructions, but do not get a GPS display from GPS Type 2?
What can this be?Only the first GPS signal from the internal Here 2 GPS Antenna.

Thanks for help in advance!

Hi Fred,

Could you please share the screenshot of the Base mode tab of the ReachView app on your Reach RS2? This will help us check your setup.

May I ask you if you have specified Reach M2 as the second GPS in the ArduPilot configuration file? Also, to see the data from the receiver in the Mission Planner, please, check if your parameters are set as the following:

  • SERIAL4_PROTOCOL = 20 (NMEA Output)
  • SERIALL4_BAUD = 57 (the baud rate you set up in RV)
  • GPS_AUTO_SWITCH = 1
  • GPS_TYPE2 = 5 (NMEA)
  • GPS_INJECT_TO = 1

Dear Polina,
these are my settings:
Base REACH settings:


Reach M2 settings:

Settings in Mission Planner:





Hi Fred,

Thanks for the screenshots!

I can see that everything seems to be configured correctly. From your post in another thread, I believe that you were able to receive the base corrections on the GCS.

Could you please check the status of the second GPS in Mission Planner? For that, you can go to the Status tab and check the parameter. Alternatively, you can choose to show the gpsstatus2 parameter on the main screen by choosing it in the User Items. To open the User Items, right click on the main screen.

I am now astonished because EMLID in its docs what the GPS_TYPE2 parameter says otherwise: “GPS_TYPE2 = 1”
see screenshot from the EMLID docs:


and you suggest now: GPS_TYPE2 = 5 (NMEA)
What is now the correct setting?

Hi Fred,

It’s better to specify the type of solution you’re sending from the device. If you’re working with NMEA stream, please, set the GPS_TYPE2 parameter to 5 (NMEA).

May I ask you to continue our discussion in the following community thread? This will help us keep all of the information together and solve the issue faster.