Reach M+ version 2.22.4 - missing events

Hello

Since updating Reach M+ version from 2.18.1 to 2.22.4 I miss a lot of events during UAV flights. The events are triggered through hotshoe and I’ve never experienced any problems before updating to new firmware. I’m sure the hotshoe is triggering properly. The results of PPK and missing events are as follow:

  1. Flight path:
  2. Events logged:
  3. Approx. missing events:

So far I’ve tested changing RTK survey parameters in ReachView:

  • GPS+GLO+QZSS at 5Hz
  • GPS+GLO at 5Hz
  • GPS at 10Hz
  • Disabling RINEX logging, just UBX raw logging and then converting to RINEX in RTKconv

But none of the above resolve the problem, the are always 30-60% missing events.

I noticed this COMMENTs in RINEX files:

I tried changing this invalid time marks manually to match the RINEX timeline and coding but I could not manage to do it properly.

I would appreciate any help on resolving this problem as soon as possible.

Greetings

Have you downloaded the data in UBX or rinex format?

In my case with an M2 if I download the logs in Rinex format I had a similar problem, I explain it here:

2 Likes

@alzabale
I saw your post before and I tried both ways - downloading RINEX directly or downloading UBX alone and converting it. Also I tried to disable RINEX data logging at all (just UBX logging and then converting in RTKconv).
Unfortunatelly, in my case none of the above resolve the problem.

Which version of rtkpost do you use?

You need to configure Reach M+ before flight. I do recommend you to configure GPS+GLO at 5Hz directly on Reach M+

Hello!

I second what @joao.reberte said. Before flight, you need to make sure you have one of the GNSS selections proposed in our docs:

https://docs.emlid.com/reachm-plus/common/reachview/rtk-settings/#gnss-selection-for-time-marks-logging

The events may be missing if you use other configurations.

@alzabale I use the current version, that is 2.4.3 (Emlid b33)

@joao.reberte @dmitriy.ershov I tried this configurations by setting them up before each flight independly, that means I did at least 4 test flights with no positive results. The parameters I set and flew where excatly the same as proposed in Emlid docs.

This is interesting. Could you please share the logs from these tests?

Hi @airwojtas,

Is there any chance you can share with us logs as Dmitriy asked? I’d like to investigate why you experienced this kind of issue.

We had a lot of problems with the 2.22.x update.
But now with 2.22.4 there are fewer problems but still not without problems!
We’re using Reach M+version 2.22.4 on Phantom 4 Pro/adv/v2, and now we don’t have missing TimeMark problem with the following configuration in the Reach M+ settings page.


RTK settings page
Processing mode: Kinematic
GPS AR mode: Fix-and-hold
Glonass AR mode: on

Elev mask and SNR and acceleration not use in PPK and not important!
GNSS select
GPS +Glonass 5Hz

Logging page
Raw data: On | ubx only (No rinex)
Position: OFF
Base correction: OFF

Other pages:
Correction input: Off
Position input: Off
Base mode: Off
Camera Cotrol: Off
Blutooth: Off

If you have missing TimeMark after these config,
I think you must downgrade Reach M+ firmware to 2.18.1 by following link and document.

Reach m+ 2.18.1 firmware
http://files.emlid.com/images/reach-plus-v2.18.1.zip
Document for refalshing and downgrading
https://docs.emlid.com/reachm-plus/common/reachview/firmware-reflashing/