Reach M+ Reflash, no longer connects

Hello there, Newbie Emlid guy here,
Hopefully this is the right category.

Anyways, I recently purchased a few M+ modules. when I initially tried to set up the first two with the reachveiw app on Android, the app would hangup each time they tried to connect to the network that I had just set them to connect to, even after unplugging and trying to restart the process. Eventually I found them on the network using Fing.

After awhile I got the first two connected to windows 10 via Bluetooth, but they both kept disconnecting. I also tried a second computer.
So I tried to reflash one of them to v2.14.0. I ran the Zadig tool, ran the Firmware Flash Tool, and I thought I was good to go. Only now, whenever I try to power it up, all I get is one orange light. No connections, nothing.

Like I said I have a second here that doesn’t want to stay conncted and I have a third one still in the box, but now Im scared to do anything because I don’t want to mess them up as well.

Any help is appreciated, Thanks

Are you sure you reflashed it properly?
Also what kind of powersource do you use?

Well I tried to follow the emlid page.

Looking over this process, I think I forgot to extract the flash image to the C:/Emlid folder like it says to do, just put it into a separate folder…?

Using it, I had it connected to a separate 5v power source, but have powered it with computer port or phone charger.

This is what the flash tool shows me.

If a step was missed i would retry a second run at the reflash process.
Carefully follow every step. Also use a powersource with a stable 5v and preferably 2amp, like one of the phone charger or batterybank. The port on the computer my not be sufficient

Hi @timmy95,

Can you try to go through all steps from the start and make sure to reinstall driver by using Zadig?
If you’ll still have problems, feel free to ask more questions here.


Well I got one of my friends to look over my process with me, and then he tried to reflash it himself with his computer but we weren’t able to achieve any more. I extracted the image using the windows tool that shows up in the dropdown when right click, and when it extracts, it shows up as “Disc Image File” with a size of “2,138,112” and that is what I tried to flash to the M+.

And then (just trying to create a process of elimination, as I wasn’t sure that the first computer i was using was functioning properly), I grabbed another computer we have here and i used the “7-zip” tool to extract the files. It than shows up as an IMG File. I then can use the 7-zip tool to again extract it. Then there is 5 files that show up. One FAT File and four IMG Files. Is this what i should have flashed to the Emlid? The date on those last files is from August. I’m just trying to point the obvious things I see.

Thanks again.


Only unzip the Reach file one time after you have downloaded it from the Doc section here at the Emlid site.
Should look like this. And use 7zip

Ok. This is what the file looked like that I tried to flash to the Emlid. I think it looks like what you have there…
so I don’t know what happened…

Any suggestions as to why I keep getting “No removable device found” when I try to connect to the flash tool, or what I can do to fix this?

9 posts were split to a new topic: Reach RS reflashing in Windows

Hi @timmy95,

Can you clarify the next points, please?

  1. Can you see a removable device in the Windows File Explorer after connecting Reach to PC?

  2. If not, can you see it in Windows Disk Manager?


Hello again,

I have been busy with other things so thats why the silence on my end, but here goes

  1. It does not show up in Windows File Explorer.

  2. Yes, does show up in the Disk Manager.



Hi @timmy95,

In that case, can I ask you try to reflash with another PC?

Well, I tried everything that I could think of, which maybe isn’t a lot… but I was not able to get anywhere with a second or third computer.

Hi @timmy95,

  • Please, can you clarify what is the goal for connecting Reach to PC via Bluetooth?
  • Can you connect Reach to the phone via Bluetooth for example?
  • Can you see any pop-up windows in ReachView when it disconnects from PC?


This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.