Reach RS reflashing in Windows


To reflashing my antennas reach rs in windows.
I unload and unzip the image (v2.14), I save it in a new folder. Now I download dfu-util.exe and libusb-1.0.dll. I put these two files in the same folder where I put the image (v2.14), is that correct?.

My doubts are; Once the intel edison driver is installed, should I place it inside the new folder along with the image and the two previously downloaded files?.

And my other question is, my antenna must be on at the moment I have to connect it to my computer ?.

I would appreciate your help very much.

Erro, you are referring to NON-PLUS versions correct? You may need to start your own “NON-PLUS” versions thread that utilize the former Edison chip… this new post may confuse things for new users of the PLUS versions?



Continue with these steps once the files above is placed in the same fiolder as the image.
-Unplug Reach if it’s plugged in
To flash:

Navigate to the image directory
Run flashall.bat
Plug Reach in
Monitor progress in the terminal window
Proceed to “After flashing”.

ok, I have read the instructions in emlid docs. But I’m not clear about the intel driver section.

I downloaded the intel driver file and paste it into the folder along with the image v2.14, (do not install / run it) how it appears in the photo I uploaded, is it right to do that? or should I download it and run it independently?.

Intel driver is downloaded and then double clicked to install. Thats it.

Understood, the intel driver must be installed before running flashall.

Do I have to install/run it inside the folder where I have it now? or do I have to place it in a different folder?.

It can be run from anywhere on your computer, i use the default download folder. :+1:

Hi @erro.alfaro88,

Did you manage to reflash your device successfully?

Hi Andrew.
Thanks for you help.

I really have not tried. I am still not sure if I am following the instructions correctly and if the reflash solves the problems.

Start by asking what can be the cause of the reachview app being frozen, showing negative age, loss of gray and orange / green bars and frozen baseline. Everything in fix and in short distances.

He clarified that they had never failed in that way, it was the second time that I used them with version 2.14, the first one made it very difficult for me to keep fix and a very low Ar. Something that did not happen with version 2.11.

Another problem I have is with the battery of one of my antennas rs.
The orange led began to flash (low battery), it had 12%. I connect to charge and in just over 10 minutes it shows that it is fully charged (100%). Even so I leave her carrying more than 3 hours. When disconnecting it; the load starts to fall very fast in 15 minutes is 70% and I prefer to turn it off.

Can the battery failure be related to the malfunction that you experience in reachview?.
Reflash can be a solution ?.


Hi @erro.alfaro88,

How’s your firmware reflashing process goes?

Let’s continue the discussion about battery issue in this thread, please.

Hi Andrew.

To charge my reach rs antennas, should they be on? or can I load them off?.

They can be either, doesn’t matter

Ok. Thanks Christian.

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.