Reach M+ [boot stuck]

Our company have bought many Reach M+ and RS+ devices and they worked well.
But now, after updates, all Reach M+ can’t boot.
Due to the boot issue i do firmware reflashing but this didn’t help.
I made a little investigation and that is what I figure out.

The leds status is : Internal error (assuming the device is in hotspot mode).

  1. After firmware reflashing, i can connect to emlid hotspot.
  2. Navigate to and ReachView Updater is showing up.
  3. I add my local wifi network and connect to it.
  4. Disconnect form emlid hotspot and connect to my local wifi network.
  5. Navigate to (emlid’s IP) and ReachView Updater is showing up.
  6. There is all OK, and click Reboot and go to the app.
  7. Wait for boot and navigate to , ReachView app is showing up, OK.
  8. In : Control panel , ReachView version, v2.18.1, STABLE, You are up to date!
  9. In wifi panel : enable wifi hotspot
  10. Disconnect from my local network and connect to emlid hotspot.
  11. Navigate to and ReachView app is showing up, OK.
  12. In wifi panel : I do action to forget my local wifi network. I want to always boot in hot spot mode.
  13. In settings menu do reboot.
  14. Hotspot is showing up but not responding.
  15. Navigate to and stuck here : Please connect to Wi-Fi network and install an update. LED’s says Internal error.
  16. Loop to 1

Also try to not forget my local wifi network but only turning it off, but the same behavior is happening.
The normal behavior (when it working) was connecting to my local wifi network on boot up or do hot spot when local wifi network was not reachable.
Sorry English is not my first language. Please help.

What are your lights doing? Solid orange, blue and green? Have you tried forgetting the hotspot and reconnecting?

LED’s are exacly as described here :
Internal error, assuming the device is in hotspot mode.
I can not forgetting the because there is emlid’s hot spot webpage …

Just to clarify, all solid correct? That page supplies all the states.

You have to connect to the hotspot as a WiFi device so you should be able to forget it.

LED’s are exacly as : Internal error, assuming the device is in hotspot mode.
2 solid, one off.
In point 14. Hotspot is showing up, then i connect to emlid’s hotspot but is not reachable.
In my opinion, device does not saving information that is up to date or update was OK.
So after power up, every time it want connect to internet to check for updates thus it needs my local wifi network.
For example i am on photogrammetric mission far away from my local wifi network, where i do not have internet and the device creating own emlid’s hot spot but can’t boot properly.
I can call it “Update loop” problem.

It is understood that it shows up, but have you tried forgetting the WiFi connection and re-establishing?

Also can you verify that you have tried connecting to ReachView while outside?

This post is very similar to this thread…

Forgetting the WiFi connection and re-establishing did not help. And i am inside of building and gps antena removed.
Is there any ssh-connection command to check main reach app running ?
I went outside with connected GPS antenna. After power up LED’s are strange.
There ( is no configuration that i have.
Power led is on, Network led is fast blinking like scanning state, Stat led is off.
Not working so i power off device. Then i went inside and power on and it forgot previously added local wifi network…strange. After adding local wifi network, it appears to change its own IP. There is dhcp active, but its the first time today emlids IP changed after many reboots.

Forgetting the Reach hotspot connection correct? It is confusing…

You really need to be outside so that the unit can collect satellites. The antenna is just for the LoRa connection and is not necessary for just connecting to the receiver.

Yes, it sounds like it sent itself into WiFi (not hotspot) mode. The stat light will not resolve until the network is resolved. The IP will change from to your local range once it connects to your WiFi. I would forget all conenctions including your WiFi, go outside and try again.

What device are you using to connect to the Reach receiver’s hotspot?

Emlid’s forgot my local wifi network. I know how wifi and dhcp working, thx.
But i just figure out what happening. The TIME SYNC.

“The app will not launch until the time sync is complete. Internet connection allows this to happen automatically, but in hotspot mode Reach requires a connected antenna with some satellite visibility.”

Just funny fact i can not power up device and download RINEX logs through http emlid’s app, using emlid’s hotspot if i am inside company basement.
Problem solved by mooving company room to the roof of the building, hehe.

1 Like

Correct, time sync is with the satellites on hotspot. You probably already know, but for others that view this we can clarify that by antenna it means the receiver, not the LoRa antenna.

I was talking about Reach M+ device, which do not have LoRa antena connector (but support LoRa through external device).

1 Like

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.