Connecting Reach to iOS hotspot

i want this to work so i can use ntrip, i have tried this workflow, and got it to work when i was connecting to my wireless at home, so i know the correct process, but it doesn’t work using the iphones hotspot. im using IOS (iphone 6s) and after i add the hotspot details the blue light blinks fast, then i reboot the emlid RS+. At this point the instructions says it should connect to the hotspot… it doesn’t, solid blue light, yes the password is correct. i reconnect to the wifi emlid connection and go to the wifi tab, but its says the iphone hotspot is unavailable.
The issue would appear to be that the iphone cannot connect to its own hotspot…

Also - i cant connect to the work wifi as it needs a username and password and when i try and connect it only asks for a password.

Maybe try going to Settings > General > Reset, then tap Reset Network Settings then.

I had the same trouble initially. I can’t say 100% if this fixed it but here goes. I went through the following workflow and found it would’t work. I then changed my hotspot password to only letters and numbers (no symbols) and it worked. Workflow: I turned on the RS2. I went to my iPhone 7plus and turned on the hotspot mode. I turned on my iPad Pro, found the RS2 in my wif-fi networks list and connected to it. Then I opened the ReachView app on my iPad and connected to the RS2. Then I went to wi-fi and didn’t see my hotspot. I added a hidden network and tapped it to connect. Then I closed the app completely. I could see my iPhone had 1 connection. I then connected the iPad to the hotspot (seeing 2 connections on the hotspot) I then opened ReachView and saw the Reach with the new ip address from the hotspot and was able to connect. So, It appears that either the RS2 doesn’t like symbols in passwords on hotspots or I just fat fingered something else the other times but it works now and I hope this helps.

2 Likes

Hi Matthew,

Could you please try to do the following steps in the ReachView on your iPhone:

  1. Go to Wi-Fi tab and choose “Connect to a hidden network”.

  2. Enter your hotspot name and password and press Connect. Please, double-check your credentials.

  3. Turn off Reach.

  4. Enable Wi-Fi hotspot on your phone. Note, on iPhone Wi-Fi should be enabled along with hotspot. Please, make sure that you are not connected to another network.

  5. Turn on Reach. It should connect to iPhone’s hotspot.

Let me know if it works for you.

2 Likes

Its working now!
Initially i tried these steps but still nothing
Based on what Matthew Collins had written in the previous post i changed the hotspot password to only letters (before i had only letters and numbers)
Then i retried your steps and it connected!
Thanks to all who took the time to reply!
The key seems to be the hotspot password has to be letters only!

3 Likes

I changed my password to contain letters AND numbers but no symbols but that aside you have it working which is good.

2 Likes

I have had similar difficulties. There seem to be (at least) three problems.

(1) The connection sequence is very counter intuitive. It goes like this: on the iOS device, switch on the Personal Hotspot. Make the Reach device discoverable. On the iOS device, wait for the Reach to appear, click on it and pair (so you pair from the iOS device, NOT from the Reach). Once that’s done, go back to the Reach and switch to the WiFi tab. The iOS device appears as a WiFi network(!!!) and you can connect to it using the WiFi password, which is displayed in your iOS device in the hotspot menu. Sometimes you need to switch Bluetooth off and on at both ends and switch the iOS hotspot off and on to get the two devices to see each other.

(2) Once paired, there is a hidden rule for connecting. The Reach will not connect to an iOS device unless something else is already connected! Fortunately I have an iPhone and an iPad, so I can log into the iPad with the iPhone, and the Reach will connect to the iPad.

There is another more sensible rule that if there is a usable WiFi network available when the Reach is switched in, it will use that rather than a Bluetooth connection. This means that if you are at home, it will use your home network.

The initial configuration stage is very tricky. Initially the Reach connects to your home WiFi or, if that’s out of range, it creates its own WiFi network. If I connect my iPad to that, it breaks the connection from the phone, so that’s no longer logged in, and the Reach will not connect to the iPad. So I need a fourth device such as a laptop to connect to the Reach while the phone is connected to the iPad. I can then set up and configure the WiFi connection to the iPad and then instruct the Reach to switch over to it.

Usually, if you have all this configured AND there is no WiFi network available AND the iPhone is logged into the iPad, then when I switch on the Reach, it connects automatically to the iPad and uses its Internet connection, so I only need those three devices. Usually. Occasionally it doesn’t, and I have to connect to the Reach using the fourth device and persuade it to connect to the iPad all over again.

So now when I go out into the field I have to carry an iPad to provide an Internet connection, an iPhone to allow the Reach to connect and a laptop, in case the whole ramshackle arrangement decides not to work today and I have to kick it all off again.

None of this is documented in the manual, which is why everybody who has an iPhone finds it impossible to connect.

(3) An iOS device can’t always see a Reach over Bluetooth. I have two Reach M+ devices, bought at the same time. Initially they were running the same firmware. The iOs device can pair with one of them, but not the other. The second Reach doesn’t appear in the list of devices that it can pair with. I’ve messed about switching bluetooth off and on again. I just upgraded the Reach firmware to the latest version but that did not fix the problem.

Hi,

Can you please tell us more about why BT pairing is necessary for your workflow?

At the moment, Reach doesn’t support BT connection with iOS devices. Moreover, you don’t need to pair Reach and iPhone via Bluetooth for connecting to iPhone hotspot.

The iOS device appears as a WiFi network(!!!) and you can connect to it using the WiFi password, which is displayed in your iOS device in the hotspot menu. Sometimes you need to switch Bluetooth off and on at both ends and switch the iOS hotspot off and on to get the two devices to see each other.

If you can’t see your network in the available networks, you can try to enter your credentials by pressing “Connect to a hidden network” button. After doing that, proceed to iPhone settings, turn off Wi-Fi and turn on hotspot mode.

Initially the Reach connects to your home WiFi or, if that’s out of range, it creates its own WiFi network.

In case you don’t want Reach to connect to your home Wi-Fi, you can forget this network in ReachView.

Please, try to forget all available networks and reproduce our step by step guide, in case you still encounter issues with connecting to iOS hotspot.

A note for hotspot connection issues. I have found that once about every ten attempts it will ask me for the WiFi password again and sometimes it will not accept the default password. If you forget the connection and reestablish it will work again. It is a bug that I have experienced off and on for a while on the developer firmware. I think 2.17 that it stopped happening, but it seems to be happening again on the 2.18 version.

Thank you, that’s extremely useful.

At the moment, Reach doesn’t support BT connection with iOS devices.

As far as I can see, this is not mentioned in your user guide, You could save your customers a lot of wasted time if you made that issue clearer.

Moreover, you don’t need to pair Reach and iPhone via Bluetooth for connecting to iPhone hotspot.

The user guide is not at all clear on this either. It would make things much easier if it contained a simple step-by-step set of instructions.

It is not mentioned in the quick start guide, that you should use Bluetooth, so why should you?

https://docs.emlid.com/reachrs2/quickstart/first-setup/

I don’t see much of a point in mentioning all the interfaces that you should not use when connecting, but only those that should indeed be used. In this case WiFi.

1 Like

Hi Michael,

Please, send me the Full System Report from this unit in PM.

Have had some more trouble getting connected, i wanted to use the ipad as the phone was busy on the DJI mavic drone. After some time trying, it seems that after entering the hidden network details and turning off the Reach it is also important to kill the app in the ipad (double click the home button and swipe the app away).
I did that and it connected to the ipad hotspot when restarting.

1 Like

Hi Mattew,
Sorry for the delayed reply.

I’m afraid I was unable to reproduce this case.

After some time trying, it seems that after entering the hidden network details and turning off the Reach it is also important to kill the app in the ipad (double click the home button and swipe the app away).

May I ask you to elaborate on why it is needed to reboot Reach to connect it to iPad hotspot? Reach should automatically connect to the specified network after pressing the ‘Connect’ button.