No LoRa radio connection on my brand new RS2

Hello y’all

I recently bought a new RS2, and I’m trying to connect via LoRa Radio on a M2 with a LoRa Module, but I’m struggling to get a Fix signal.

I also have a pair of RS+, and in both of them I can connect right away to the M2 via LoRa, without any issues.

All of my devices are up to date with the most recent version of Reachview.

My workflow is:

Base - M2 with LoRa Module
Correction output - LoRa radio
Rover - RS2
No connection, not even float

Base - M2 with LoRa Module
Correction output - LoRa radio
Rover - RS+
Get a float signal right away, Fix signal after a few minutes

Base - M2
Correction output - NTRIP
Rover - RS+ and RS2
Get a float signal right away, Fix signal after a few minutes

I’ve generated a full system report, could someone take a look? I’m sending via email.


1 Like

Hi @rsurveyor1,

Thanks for the detailed explanation of your tests! Helps a lot to get a full picture :slight_smile:

Full system report always shows us the settings on the units, they are necessary for drawing any conclusions on what happens with your receivers. I don’t see a letter from you in our email, though. Please share the ticket number with me so that I could check it.

The behavior of M2 base - RS2 rover via LoRa is something similar to what we have reproduced on our own devices. To say for sure, please try out these RTCM3 message combinations in your setup:

  • ARP 1006 0.1 Hz + GPS 1074 0.5 Hz + GLONASS 1084 0.5 Hz
  • ARP 1006 0.1 Hz + GPS 1074 0.5 Hz + Galileo 1094 0.5 Hz
  • ARP 1006 0.1 Hz + GPS 1074 0.5 Hz + Beidou 1124 0.5 Hz

If the behavior repeats, please record these logs for 10-15 minutes and send them to me:

  • raw data with Raw data debug option enabled on the base and rover
  • base corrections on the rover
  • position on the rover

Hi Polina, thank you for your answers. Unfortunately none of your suggested combinations worked. I’ll be providing the logs as you requested.
Mind to share your email address?

Thank you once again.

You can go for the, I’ll pick it up there :slight_smile: We have a few more combinations to check out, but let’s first see the data.

Hi Polina, just sent you the logs. Thanks.

Hi rsurveyor1,
I recommend sending corrections from base to rover using the Emlid Caster service with a SIM card in both your base and rover. You can get Mint Mobile 7 day trial SIM cards for $2 that include 250mb of data. I highly recommend trying this. This is what I’ve been doing, and it has worked flawlessly. Not to mention, LORA needs proper LOS. So, heavily vegetated sites will be a problem with LORA. Using SIM cards and transmitting corrections via Emlid Caster over NTRIP eliminates this issue. That’s just my 2 cents though. If you have any questions feel free to ask. Take care :slight_smile:


Hi Garrison, thanks for the input.
Our M2 will be used in two different scenarios. NTRIP will be used where we have 4G/3G connection on our phones, LoRa where we don’t. I live in quite mountainous place, so we don’t have cell phone connection in all the places. Hence the LoRa connection.

Hi @rsurveyor1,

I’ve checked your data, thanks! I can see that the RTCM3 log is empty. This means that the corrections are not coming from your M2 to RS2. There are a few reasons for it. Let’s get the most obvious ones out of the way.

  • Please double-check that the frequency, the output power, and the air data rate are the same on both base and rover
  • Try reverting the roles of M2 and RS2 to exclude any kind of hardware issues. You can check out the same settings of the RTCM3 messages that I’ve suggested earlier

Please record the same logs during the test as before so we can asses the situation.

1 Like

Just wanted to mention here that we’re receiving all of the data and analyzing it. We’ll make an announcement here once we have news.

1 Like

Good afternoon, I also have the same problem since version 28.1.
Before I could have my M2 base (connected to a gnss Beitian BT-200 antenna and external source) and my RS2 as rover, without any connection problem in lora. Now my rover doesn’t recognise the lora connection, it stays in single. I have a RS+ and it has no problem connecting to the base so far in lora mode.

I tested the RS2 as a base and the M2 as a rover in lora connection and if I get the connection in lora it gives me FIX.

I thank you in advance for your help and attention you provide.

I apologize for my bad translation from spanish to english.


Envío reporte. Saludos

Hola hermanito. No need for apologize for the english. It’s pretty good.

Yes, I had the EXACT same problem as you. Changed the RS2 to base mode and the M2 as a rover, got a Fix solution right away using LoRa. And I also have a RS+, tested with the M2 as a base and the RS+ as a rover, got a Fix after a minute or two.

The problem here is the RS2 working as a rover and the M2 as a base. Polina said to test these configurations on the RTCM3 messages:

ARP 1006 + GLONASS 1084 + Beidou 1124
1006 @ 0.1hz
1084 @ 0.5hz
1124 @ 0.5hz

On the very first test, got a Fix after a couple of minutes (although it should Fix after a few seconds), but once I’ve tried these configurations on the field, it didn’t worked. Only Float. Got a Fix after maybe 10 minutes, but it would change to float right away.

We’re in the same boat here buddy. Hope we can get a solution from Emlid ASAP. Preferably a Fix solution (:


This problem of the Lora of the M2 has been reported for many months. We are waiting for EMLID support solution.
See the treaties

The only option for the Base to work well is to keep it in the OBSELECT version 2.24.2, any update we will have problems with Radio Lora.


Hi Jaguero, I can’t thank you enough for this link you’ve provided. I always check if someone else posted before, but this one flew under my radar. IOU a beer.

I’ll try the 2.24.2 version on the base.

And by the way, that is not an issue with only the brand new RS2. A coworker has a RS2 with 1.5 year of use, I’ve tested it, had the same issue.

I just came back from a test outdoors, had some success with the following RTCM3 messages:

1006 @ 0.1 Hz
1074 @ 5 Hz
1084 @ 5 Hz

With these settings, got a Fix solution right away. Float solution when below trees (not dense vegetation), but got a Fix solution in less than 10 seconds. I can work with these conditions for now, but I’ve noticed that the age of differential would increase, even standing right next to the base.

1 Like

Try these combinations, it may work well for you, but if you activate more than two constellations, the problem may remain.

  • ARP 1006 0.1 Hz + GPS 1074 0.5 Hz + GLONASS 1084 0.5 Hz
  • ARP 1006 0.1 Hz + GPS 1074 0.5 Hz + Galileo 1094 0.5 Hz
  • ARP 1006 0.1 Hz + GPS 1074 0.5 Hz + Beidou 1124 0.5 Hz

After maybe one hour or two, I got the following message on the Base:
LoRa is not connected.
Then, nothing. Back to square one. Only single solution.

I’m trying to get back to update 2.24.2, but having some issues. The flashing program won’t let me return to this update.

I’ve tried all these configurations that you’ve mentioned, no luck at all.

Hi everyone,

Sorry for the missing updates in this thread. Let me explain the current state of this issue.

As Polina has previously mentioned, we reproduced the same behavior with the M2 base and RS2 rover over LoRa. Indeed, for several sets of RTCM3 messages, the RTK-link between M2 and RS2 can’t be adequately established. Even though it might seem evident, it wasn’t clear straight away what actually causes such behavior. That’s why the investigation took some time after we confirmed the issue.

Now, our devs have found the reason for this issue and working on implementing the enhancement in LoRa communication between the M2 base and RS2 rover. It still needs to be thoroughly tested before we release it to make sure RTK-link is stable. Once we push this improvement, I’ll let you know here.

Currently, the workaround is to use alternative ways to set up the corrections link. For example, you can use our free Emlid NTRIP Caster for this. Here’s the guide explaining how you can configure the base and rover via our NTRIP Caster. Or you can swap the roles for your receivers and use the RS2 base for the M2 rover.


Hi Liudmila, thank you for the update. Do you have any idea how long will it take to correct this issue? As I said in my email, I really need the LoRa corrections because NTRIP won’t work, the area I’m working doesn’t have cell phone coverage.

1 Like

Hi Rafael,

I’ve replied to you via email. We’re working on the implementation of this enhancement, but currently, I can’t share any exact dates of its release.

1 Like

Hi there,

I’m back with the news! We released 29 Beta 2 Reach Firmware with improved stability when working over the external LoRa module on Reach M2. It should help you to resolve the issue with the LoRa link stability when M2 is used as a base. It’d be very helpful if you test this out and let me know how it works for you now.