Reach Firmware 29 Beta 3 is out

Hi @l3technologycambodia,

We added this mainly for the users working in the 3d-party software who could use the files from Reach. For Emlid Studio, you need to export the file from ReachView 3 to process it in Stop & Go.

I’ll take it as a feature request!

1 Like

Any reasoning for the underscore being forbidden in the device naming?

1 Like

A post was split to a new topic: Split RINEX log

Hi Adriano,

It was done to follow the rules of the standards for the correct hostname of the device in the network.

Edited: mixed up introduced fixes.

1 Like

Tengo el mismo problema amigo, encontraste solución? Saludos

3 posts were split to a new topic: Reach RS2 does not pass booting mode

What happens if the device names already have underscores? My three are RS2_Base, RS2_Rover1 and RS2_Rover2

1 Like

Hi Rory,

All devices will be automatically renamed to the name without underscores (e.g. RS2_Base → RS2Base)


4 posts were split to a new topic: M2 doesn’t turn on after updating to 29 Beta 2

A post was split to a new topic: RS2 stuck in loading after updating to 29 Beta 2

*Not sure where you want this. Move as necessary.

I installed 29 B2 on an RS2 today. And, enabled Bluetooth in RV3 via the Profile button switch.

Results and feedback.

The install of the firmware seems to be a success and uneventful.

Background. Before the change, A successful connection between my Pixel 3XL and the RS2 via the phone’s hotspot has always been intermittent. The RS2 always connects to the hotspot, but the phone only sees the RS2 about 50-60% of the time on the first try. The Refresh button has never been successful. Only force closing RV3 or rebooting the phone and/or the RS2 works…sometimes. That is why the Bluetooth connection sounds great!

On the Pixel 3XL

After the update, The RS2 still connects to the Pixel’s hotspot without issue, RV3 on the phone still only see the RS2 intermittently, either via wifi or bluetooth. (I use many other bluetooth devices that work fine with the phone and have not had any problems with bluetooth connections)

When the phone does see the bluetooth connection and displays “connected” tapping on Settings results in a grayed out page with a spinning icon like there is no connection. It finally times out (or I can tap the Receivers button) and in both cases, it returns to the Receiver page still indicating it is connected. If I then disconnect from the RS2 via bluetooth, it does not see the wifi option any longer. And then won’t connect via bluetooth again either. If I then force close RV3 from Android settings, I may or may not see the RS2 in the Receivers panel.

If I do, and choose the wifi connection, then the connection to the RS2 is workable. So, with 29.2 the wifi connectivity is still very sketchy with the Pixel 3 (android v.12) and I have yet to be successful with a bluetooth connection.


Using an ipad on ios 14.x and on the phone’s hotspot, it sees the RS2 both via wifi and bluetooth …sometimes. Sometimes it only sees the wifi connection. When it sees the wifi connection but not the bluetooth, it seems to connect automatically to the wifi. If I disconnect it and hit Refresh, it still only sees the wifi connection and again auto-connects. If I then close RV3 and disconnect from the phone’s hotspot, and re-open RV3 it still does not see the bluetooth connection.

If I then reboot the RS2, and re-start RV3, it sees the bluetooth connection. On the iPad when connected via bluetooth, the app is fully function-able unlike with the Pixel 3

It almost seems like that if the RS2 has been running for awhile, the ipad won’t see the bluetoooth connection but it does if I check right after the RS2 has completed start-up.

1 Like

Hi Dave,

While this new functionality is in Beta, each report is valuable. And such a detailed one is of great help!

Of course, we’ve tested BLE with different mobile devices and OS versions. But maybe yours have some features we need to check additionally. Can you share the Full system report from your unit at

And if, by any chance, you have another Reach RS2 or RS+ and can test BLE with it, it would be helpful too.

1 Like

Email sent @ 2:18 AM, Wednesday, June 15, 2022
Coordinated Universal Time (UTC)

I just started the RS2 to download the FSR and today, on the Pixel 3 phone, the RS2 was available via wifi on the first try. But not under bluetooth.

The ipad sees the RS2 in both cases and I can switch between them with full functionality.

Thank you!

1 Like

I received it. Thanks a lot!

1 Like

More observations using the RS2 on a job today.

The Pixel 3 saw both instances of the RS2, wifi and bluetooth. I worked with wifi and after I completed the job, I disconnected the RS2 and reconnected through bluetooth and this time, everything was functional ! During the job (via wifi) I did have one unforced disconnect in about 40 minutes. But it hooked back up when commanded.

I used the new Base > Manual > Point from Project on this job and it worked just fine !

I was using a P4RTK. At first, I tried connecting to the RS2 via Local NTRIP. This time the P4R would not connect. I switched to Emlid Caster and the P4R connected immediately.

I’m trying to be as consistent as possible with my approach but my results are not always consistent. If it is just me, I guess we can chalk it up to the Pixel 3 being “not ideal”


1 Like

Hello everyone!

We’ve just released the new Beta version of Reach Firmware - 29 Beta 3!


  • Output leap seconds in RINEX NAV logs
  • Add support for NTRIP v2 to the NTRIP local caster option
  • Add approximate position to RINEX Events
  • Improve RINEX logs quality with the OPUS preset


  • Some cases when receiver could stuck in loading
  • Issue when it wasn’t possible to update base mode RTCM3 settings, when NTRIP was selected as base mode output
  • Some cases with an empty RINEX Base corrections log
  • Representation of the current GSM modem mode for Reach RS2 receivers
  • Stop recording logs if rolling logs is disabled and no space is left
  • Solution logs file extension being always LLH
  • Some cases when devices with same names are not visible in ReachView3
  • Some cases with the wrong Bluetooth device name representation after changing the receiver name
  • Typo in the name of the sdun column in *.POS files

Hi Dave,

Maybe it indeed was a one-time issue. Still, we’ll check the report.

About the issue with P4RTK, is it reproducible? Did you connect to Reach’s hotspot or external Wi-Fi?

I will check with the P4R with Local when I get it out next. It’s probably just a one time issue.


1 Like

Thanks! Let us know if it occurs again.

Imagining there is a button in Survey Interface for Start Stop & Go mode and when pressing it, ReachView will take care of correct setting for logging file and duration of each survey point. And when press Stop, all necessary files are packed and download.

Just dreaming :blush::blush::blush: