Reach Firmware 26 Update: Legacy RTCM3 Messages and NMEA Output Settings

Great news, can’t wait to install this on my units. I have a special request for the RINEX settings. I love that you added the antenna height option, but I would like to have an option to specify the antenna I use with my M2. It’s obviously automatic with the RS2, but not with the M2 since I can attach any antenna.

Thank you

4 Likes

I second that request! Having a field in the app to enter the antenna code would be welcome.

4 Likes

Hi there,

We’ll note your request. Thanks for that!

Thank you so much for Talker Codes selection, and NMEA selection. No outside conversion needed anymore just the M2 and a ttl / 232 converter very easy to setup.

Taking it for a spin on the Tractor Harrowing tomorrow very excited, spring is here again.

7 Likes

Spring has sprung here. Some farmers have started “early” planting. I think we are 1 to 2 weeks out before everyone starts planting.

Farm drainage work is in full swing before the planting begins so I am BUSY. I haven’t had a chance to test the 2nd Beta release. I want to test the talker as well.

After updating to Firmware 26, using ReachView 3, anyone else having Bluetooth connection issues with a Trimble Nomad 6G handheld data collector? Worked fine before the update.

In ReachView, the MAC address shows, and shows a very quick connect during pairing… and the Nomad says it connected during so… but after that, the Nomad will not connect again.

Works fine with my (2) Surface PCS and a desktop workstation.

Could be very well something of my own, but figured I’d ask just in case as I have exhausted every option that I have control over.

EDIT: after some more searching, found this:

I did not have BT enabled in the Position Output. I had mistaken disabled it.

It now connects while in FieldGenius9. But for some odd reason, in the Windows 6.1 OS on the handheld, it shows BT is disconnected, yet its connected during FieldGenius use. Seems it used to state connected either way before. At least it’s staying connected now… took forever to figure out.

NMEA and Talker code selection is working great :grinning: :smile: :grin: :blush:
The Trimble Ez Guide 150 has never steered better, threw out the WAAS antenna this morning!

But iPhone hot spot gremlins are back :cry:

The M2 was very militant about making its own hot spot no matter what, and would not lock onto the iPhone’s hot spot by itself.

I had to log onto the M2’s hots pot with my iPhone, then transfer to my Friends iPhone Hotspot.

Is there a way to have a software switch to make the Reach prefer a external wifi hotspot, vs starting its own immediately by adding a substantial delay. This would make it easier to latch onto an external wifi hot spot, while still making it able to start its own hot spot much later for recovery without having to re flash it?

7 Likes

What is this NMEA Talker ID (GN GP?) and Messages “simply” please?

“GP” talker code signifies the message was generated by a gps receiver

“GN” signifies it was a GNSS receiver

Then there are multiple sentence structures that contain different measured data. Like “gga” or “vtg” there are many of these sentences that contain different data.

Velocity and direction of a gps unit would start with “gpvtg” in ascii.

NMEA was developed for maritime use of all instruments on a ship sharing data over the same data bus.

GPS uses only a small amount of the sentence structures laid out in the NMEA communication standard.

Most older and some newer commercial equipment uses the GP code

Modern equipment may use the GN code

3 Likes

Please can you send me the link for reach firmware 26 update I only have the image of it.
I’m using RS+.

1 Like

Hi, i have updated my to Reach RS2 units to firmware 26, but when i tried to Measured height in Raw data settings, it does not allow to put height like 1.34, just whole numbers like 1. Anyone experienced the same issue?

Try “,” (without quotes) instead of “.” (without quotes).

It does not allow me, i am using samsung s10, nut i am going to try with windows now.

Try with Google Keyboard.

1 Like

And another issue, i have troubles finding Reach RS2 as bluetooth with a windows mobile device, and carlson surv ce, even thought i have checked on ReachView that bluetooth is on and discoverable.

Sorry, after a couple of restarts of both devices, finally windows mobile found reach rs2’s bluetooth.

Past posts, I think had something to do with region settings in the phone itself? Been awhile.

I think agrimgalina had a post on this a couple years back?

2 posts were split to a new topic: Reach Module RINEX header

The solution is to download a Gboard google keyboard, thanks to @polina.buriak

2 Likes

Thanks for the suggestions :slightly_smiling_face: