Reach Firmware 26 Beta 2 is out for all devices

No, that was your legacy 1008. Previous tests when I enabled legacy I didn’t have the 1006 enabled.

Your 1008 is working ok with Trimble. I couldn’t get the 1004/1012 to work for fix though.

1 Like


Thanks for your help with this!

We’re currently looking into the issue with the legacy messages. I’ll be back with the updates as soon as there are any.

1 Like

If I get a chance, I want to check the format of the messages against OH CORS legacy messages. I can do this with SNIP and see if there are any glaring differences.

1 Like

Could you add the following messages too?

GPS ephemerides: 1019
GLONASS ephemerides: 1020
BeiDou ephemerides: 1042
QZSS ephemerides: 1044
Galileo ephemerides: 1046
GLONASS bias information: 1230

It is useful to record these information with NTRIP Client and used them for post-processing in software such as EZSurv.



Hi @l3technologycambodia,

Thanks for your request! It’s noted.


if i want to revert to the latest stable firmware should I unsubscribe from the dev option the reachview app?

1 Like

Yes and reflash. Here is the link for the RS2

Here is the link for the M2

Hello everyone,

We’ve just released the Reach Firmware 26 Beta 2 .

You can check the list of all fixes and improvements including the support of configurable RINEX logging that allows a simpler setup for PPP in the first message of this thread.


With the new pole height setting in the logging tab, if the pole height is set to 0 is 0.134m still added (i.e. the distance from the ARP to the antenna)? I ask this as for PPK missions we need the actual antenna position in space, not relative to the ground. If the ARP difference is always there then our Z will be out by 0.134m

1 Like

Hi Rory,

Sorry for the delay!

In the logging tab, you just need to enter the survey pole height only. The ReachView will add the distance between the bottom of the device and the antenna placement automatically for RS2 and RS+.

1 Like

Hi Polina,

Thanks, but what I mean is if the pole height is left at 0 does RV3 still add 0.134m to the height? That would be a problem unless it allows negative values and we can set the pole height to -0.134. For PPK logging we don’t enter any pole height so it records the actual height not the ground height.

1 Like

I haven’t tried it yet, but I’m guessing that it merely enters antenna height in the RINEX header, which you could change to 0 after the fact. The actual observations are always at antenna phase center.

Ah yes, that makes perfect sense, I’ve just updated a unit to 26.2 so I’ll run a quick log and look at the RINEX header. Editing large logs can be a bit of a pain, they take ages to open in a text editor! If the ARP to phase centre is added I could just remove it in RTKPost by entering a negative number.

Notepad++ handles large text files well and is a great ASCII editor.


Been using Notepad++ for quite a while. Works great for several applications.


Nice app to edit kml file for dji pilot, i’ve been using for 3d flight dji pilot

Notepad++ can select a column of data off the side of of the group of unsorted ascii. Its awesome just for that function, saves me much time.

1 Like

There is a bug in the new firmware 26 Beta 2 with regards to the new logging settings. I found it happens on both of my RS2 units primarily when the RTK Settings Update rate is set at 3Hz.

Tested Logging settings:
Interval 1s
Constellation: happens with GPS only, with GPS + GLO, and GPS, GLO, GAL, BEI
File format: Tested both Rinex 3.01 and 3.03

At this point, it does not seem to happen when the RTK Settings Update Rate is set at 1 Hz or 5 Hz.


Left: Rinex file downloaded direct from RS2
Right: UBX file from RS2 converted to Rinex with rtkconv/rtklib 34a (from rtkexplorer)

Below are the original files from the RS2 (2.9 MB) (122.3 KB)

1 Like

Buenas a todos los colegas . esperando se encuentre bien queria consultar a los mas experimentados de estos receptores. Es conveniente pasar de la versión firmware 2.24.2 a la version beta 26.1.
desde ya muchas gracias



1 Like

Hi everyone,

We’ve got some updates about the legacy messages issue. To ensure the messages are correctly read on your rover, please, set the Update rate in GNSS setting the same as the frequency of the GNSS RTCM3 messages in the Base mode tab.

So you need to set the update rate to 1 Hz on in GNSS Settings:

Then, the GNSS RTCM3 messages frequency should be also set to 1 Hz:

Please check if this works for you. We’ll be glad to hear your feedback.

Edited: fixed the screenshot and the information about frequency.