Reach does not charge through cable

Hello,
We have a Reach RS base and rover running v 2.11.0. We use the Reach cable that comes out of the bottom of the antenna for our data input stream, which works fine. But this port does not seem to be able to charge the battery.


There is a sticker on the bottom next to the cable that says; “DC in 5 - 40V”, which seems to imply that this would charge the battery.

We have two cables, one is a Reach RS to DB9 female and one is a Reach RS to DB9 male. Neither will charge the unit. We have tried it using UART adapters into a USB port to a laptop as well as a wall charger, and we have tried plugging directly into a computer with a DB9 port. None of these will charge the antenna.

The antenna will charge via the micro USB port, but these units need to be mounted externally where they will be exposed to weather and vibration and we do not feel that the micro USB port is rugged enough to handle this.

Why will the antenna not charge through the Reach RS cable?

1 Like

Hi, it should. But does your serial provide power/enough power (amp)?
Pin 9 and 1-3 should charge it.


And your serial

Not all laptops has enough output power (even USB) to power reach/charge it.
Check your computers spec to verify this.

3 Likes

I think you’ll find that you need to purchase a CBL101 plain end cable for charging. However, with the cables you already have, you may be able to a) cut off the DE9 (DB9) end and access the charge wires, or b) carefully remove the cable insulation behind the DE9 (DB9) and tap into the charging wires.

9-pin computer serial ports (RS232) don’t have power for charging in their specification, so my guess is that it is probably unsafe for Emlid to supply it in a non-standard configuration like that. So then you can wire up your own connector on in a non-standard configuration if you like.

2 Likes

Ok, that attached document, “DB9F” pretty much explains it, there is no connection to either the 3.3 or 5 volt line. Looks like we have no option but to make our own. Thank you, at least we know what we will need to do now.

as bide said:
https://store.emlid.com/product/reach-rs-cable-2m-wo-2nd-connector/

or butcher what you have! ; )

1 Like

Did you get it charging using this cable? I am having similar issues…

Hi, not yet, I have ordered the cable with out end connector from the link above. Once it arrives I will try to wire it up to see if I can get it to charge. I’ll post the result here.

Received the cable and wired it up but its still not charging, although there does appear to be some current going through… when I check the Battery Status, the “Charger status” has changed to: “Constant Current” and the “Current” value has dropped by about 10 milliamps but is still ready a negative value. We are running this through a UART converter so I suspect that it is siphoning off most of the available juice out of the USB port, so I will try to make up a new cable bypassing the converter to see if there is enough straight power out of the USB port to charge it.

Don’t expect a UART port to deliver close to any power.
Connect it directly to a battery, or a USB power bank, for convenience.

1 Like

So I’ve cut off the UART adapter, and spliced the Reach cable straight to a USB plug. Using the pin out diagram from above, I wired the Reach plug pin 9 to USB pin 1 (+5v), and Reach plug pin 1 to USB pin 4 (GND). Then plugged that into my USB charger (which is the same charger that I use with the micro USB port so I know it works and has enough power to charge the battery), and still NO CHARGE!

Hello to anyone from EMLID? This is a problem! We need to mount these antennas outside in the weather and were advised that the bottom plug was a weather proof plug that would allow us to charge them.

For ref

erence, attached is the wiring diagram that I implemented.

Wouldn’t think would matter, but just in case try using GND Pin2 (BLACK) instead of Pin1 (red) on the Reach cable?

Did you ring out the cable to make sure that your USB pin1 connects to the RS end pin1, and the USB pin4 connects to the RS end pin 9?

By “ring out” I mean to use a continuity tester or ohm-meter.

2 Likes

Yes, I checked before I soldered them together and then afterwards again… I might try timd1971 suggestion and swap the two.

That’s good. Here’s some additional confidence that the wires should be connected at the RS end.

My CBL103; RS connector disassembled for inspection and showing all wires soldered:

1 Like

I’ve created a new custom cable that only has pin 9 and pin 1 connected, I wanted to eliminate all other variables just to see if I could get a charge current going into the antenna. Have you been able to charge the antenna using your RS cable?

I’m not going to cut into this CBL103. I do have a CBL101 here too with a plain end. Let’s see what happens with it. Stand by…

That CBL103 in his photo is for serial data connection. Not for charging.

Let’s see what happens with his CBL101.

; )

Yours may not be grounded or connected properly or your flux capacitor isn’t powerful enough? : )

Make sure your PIN 1 & 4 on USB aren’t crossed also. Check for continuity.

Hopefully you don’t have an incorrectly wired (terminated) to the physical pins on the reach cable or even in the RS unit.

1 Like

I confirm that power = purple (violet) and ground = red.

I’ll apply power next…

1 Like

Personally I always designate ground as BLACK. But (Reach pinout) diagram does state RED is also.