Reach base module configuration

Hello, I want to use my rover module in a drone and the base module in the ground in a known position and then do the post-processing correction. I would like to configure (set) my base module. How should I set the base using the ReachView? Sorry, but new users cannot upload images and I would like to do that to ask you in more detail

Are you using Reachview 0.4.9?
Would recommend you to start @ the Docs https://docs.emlid.com/reach/
Or directly to base configuration https://docs.emlid.com/reach/reachview-base/

Hello, and thank you for your reply. No, I’m not using the ReachView 0.4.9, but the ReachView version: v2.1.6-r0. I have already “studied” the documentation at the web adress you indicated to me, but as the interface of my version is very different from the previous I’m missing some steps.
Here the screen shots of my ReachView interface:






How to set the the interface in “Base mode”? Where can I find documentation about this ReachView version?

1 Like

Docs is not updated yet. Its still beta and will be when ready.
For base unit, you wanna use base mode (one step up from logging) for RTK kinematic.
For post process, turn on logging for base and rover (RAW) And follow this doc for converting raw to Ublox https://docs.emlid.com/reach/gps-post-processing/

Thank you again. So in the interface “Base mode” I will set in this way:

  1. Corrections output: OFF
  2. Base coordinates: LLH (in my case)
  3. Coordinates input mode: AVERAGE SINGLE (but which is the difference betwen this one and the other options?)
  4. Coordinate accumulation time: NO IDEA
  5. Lat, Long, Height: AT EACH RECORDING I HAVE TO SET THE COORDINATE OF THE BASE?
  6. Antenna off set: I HAVE TO MEASURE IT
  7. RTCM3 messages: 1002, 1006, 1008, 1019, 1107 (in my case).
    Could be reasonale?
    And how to save my setting?

I think, you should turn on the output for base mode, then choose one of three options, such as serial for radio, tcp for wifi, or ntrip. If you choose serial, you should have radio such as rfd900, I think you have know about it. Then set the rover, input correction from serial too.

As described in your first post, wanted to postprocesss. There is only need for you to activate raw logging for base and rover, for the purpose of postprocessing.
Unless you need live correction data from base to rover and/or display output solution. But thats a different story :wink:

1 Like

Hello again. I followed your suggestions and I made a surveys placing the base unit in a static position and walking with the rover unit in my hand around a sidewlak for 4 times (the same path made 4 times). Then I post-processed my data: this is the result. It sound strange for me, I expected to obtain a only one track after post processing. What do you think?

1 Like

Its one track showing 4 laps, not exactly the same track every lap but close enough i think.
Without knowing if you backtracked or retracked at the exact same position its hard for me to say wether this is right or wrong.

I think it’s important for you to know, that we only support Chrome and Firefox browsers. The older ones can mess with the Reach configuration process.

does the sidewalk go around a building?

Hello, no the sidewalk doesn’t go around a building. I walked in the four sides of a square (6 m x 6 m) leaving my base module in a point at known coordinates. I made the post-processing with the RTKLIB, insering the coordinates of the base station. In this image you can see the result.

.
What could be the problem of orange points? Orange points mean not fix, that is to say float. Does this refer to the situation of satellites? I mean the problem is during the data acquisition or during the post-processing phase?

I am a hardware guy so others here can help more with post.

All I can tell you is you may have better luck with your rover on a stick to get the antenna with ground plan over your head. Even blocking with your body can cause issues. And make sure your base is in a really good clear sky position. Once that is done others can help with your post settings.

Hi,

This looks a little like you may have REC DYNamics set to ON and receiver M/sec^2 set too low. I got similar results in post processing. I think that with all the software involved, the location results get projected from smoothed data rather than being what is known as a critically damped control system (data out -vs-data in).

Of course, it may be something else, but I throw it out as a possibility. I do see that you have the controls set at a MAX Accel of 1 M/Sec^2. Try a higher value. the overshoot at corners may go away at the expense of less smooth float traces.

Good luck…

Hi!

In my opinion, you got really good result in such conditions.

You can see that fix is quite accurate (green). I think it’s ±20-30 cm according to your picture.
Moreover, you’ve walked around house, it’s not the best way to have clear sky and best satellites visibility.

Maybe you’ve started your walk before getting fix. Because I can see that last laps where all fix.

You can send your logs and I’ll give you more details :slight_smile:

Hello, here you have the raw data from my acquistion (from rover and base modules) Acquisizione_2017_01_16.zip (1.1 MB)

Hello, is there any possibility to open the file .ubx about raw data?

Hi, following your suggestions, I made another acquisition setting the acceleration at 3 m/s^2 and putting the antenna of the rover module over a metal plate located in a pole. I waited until the fix (green led both in base and rover modules), and then I waited 1 minute stable in a point. Then I walked on the side of my square of 6 m x 6 m for 10 times. In the image the results. I’m not so happy about this acquisition…


Maybe better go back to the previous setting?

Nah…
Got pretty good results with fix&hold and continuous and turn off glonass AR. But more or less out the box default setting
I bit few visible satelites.

Once float reach fixed modus, it stays there but drops every time you loose signal from one ore two satellite. One thing to keep in mind when struggeling for fix sollution.

Hello, sorry, you mean that I have to set the base module as GPS AR mode = Fix-and-hold while the rover module as GPS AR mode = Continous?
When I am out in the field, the only way to see if the modules have fixed is check the led and see when it is green. Is it Ok?