Reach 2 UART connection issue, using lemo-db9 cable - use highest possible baud rate

My contact (Central Queensland agriculture researcher) is using position data from their Reach RS2 (firmware image version 2.22.3), outputing via NMEA to a small industrial computer for recording of positions of video frames from two cameras on a mobile platform. EMLID Rover and Base were both on.

The Reach RS2 is outputting position data successfully with NMEA via Bluetooth or USB-PC connection. As expected, each line of output has a string prefixed with a $ followed by data.

However there is error outputting position via the serial cable (the Emlid faux lemo-db9 cable). The same error occurs if the lemo-db9 cable is connected to a ATTEN USB to serial bridge adapter, with connection to the PC through usb.

Use of the Lemo-db9 cable is preferred though as this cable can also be used to power the unit (using pin 9 of the lemo connector) with the advantage of an auto-power feature (the receiver is on a mast). The Emlid Lemo cable with db9 connector was purchased but the power wire is not connected at the db9 connector. The db9 connector was therefore cut off and replaced with a db9 connector, enabling connection of the power wire. This cable connectors to a cabinet mounted db 9 connector, with the power wire separated from the communication wires which pass to the computer COM rs-232 serial port (db9 connector).

For this output mode, in ReachView under ‘Position output’, ‘Serial’ is set to UART, 9600 baud and NMEA format. The PC com port is also set at 9600 baud.

The issue is that there is frequent concatenation of two lines into a single line, e.g., $GNZDA,074146.00,$GNRMC,074147.40,A,2319.3698097,S,15030.9570454,E,0.04,230420,D*4A

Sometimes the $ is not followed by data.

The NMEA location log for two cases (UART and USB) is attached for reference - in ZIP file.

Can anyone provide suggestions on how to get the NMEA data output OK via Serial Port?

NB. Noting the post Reach RTK position output via UART to microcontroller
and the fact that my contact also has the Emlid db9 connected to 12 V power supply power (+ and -) (this powers the PC also) and to the serial port of the PC. The power supply earths to the input power ground wire. Maybe there is an earth issue with this??

Cheers, Alistair (11.0 KB)

Solution that worked !!!
The trouble was with lower baud rates (9600 and 19200). Higher baud rates (e.g., 115200) worked fine.

Hi Anand,

Glad to hear it works fine now!

Indeed, a low baud rate сan lead to data loss. We always recommend using the highest baud rates supported by the serial port.